Do I need a new amp? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old May 1st, 2009, 8:10 am Thread Starter
Senior Member
 
PrimePower's Avatar
 
Join Date: Apr 2009
Location: Williamsburg, VA, USA
Posts: 121
Do I need a new amp?

Just picked up an 05 LT yesterday. Well it runs great as I had a 3 hour ride but the right rear speaker doesn't work. After taking it apart, and checking the speaker and wiring I searched the forum and unplugged my battery. That worked for a while. Then, back to no right rear speaker. So my questions are: do I need a new amp? where is the best/cheapest place to buy one? where is the amp located? Thanks
PrimePower is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old May 1st, 2009, 8:17 am
Senior Member
 
MikeERideWNC's Avatar
 
Join Date: Jun 2007
Location: Murphy, NC, USA
Posts: 793
Re: Do I need a new amp?

Sounds like you are loosing the rear channels in the head unit.

But don't worry, BMW antisipated this and built a surplus.
You will be able to replace the radio for around 600.00 if you do the labor yourself.

Do a search and you will find some other affordable options.

Also make sure all of your connections are clean and making a good connection.

BMW radios...

I bought mine from Chicago BMA for 500.00 a few years ago.
Installation is is quick and painless. It is the only option for keeping the bar controls.

Sorry for your luck.

Visit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
_ Why is there never enough time to do it right the first time, but always enough time to do it over?
MikeERideWNC is offline  
post #3 of 9 Old May 1st, 2009, 9:21 am Thread Starter
Senior Member
 
PrimePower's Avatar
 
Join Date: Apr 2009
Location: Williamsburg, VA, USA
Posts: 121
Re: Do I need a new amp?

So the amp is built into the radio. OK. Connections are good as it will work if I disconnect power, but later shuts off. So is it the CD player part or is there another HU somewhere? I can do the labor, but man that is pricey. Might wait till they all go out.
PrimePower is offline  
 
post #4 of 9 Old May 1st, 2009, 9:53 am
Senior Member
 
JPSpen's Avatar
 
Join Date: Jul 2005
Location: Jones, OK, USA
Posts: 3,525
Re: Do I need a new amp?

Might not be the amp.

There are two sets of connections, One on the left side of the stingray. and one at the top box under the passenger seat.

Check clean and di-electric those connections and I'll bet you'll find your problem.

The radios are not nearly as troublesome as those connectors.

John

Live and direct from the new earthquake capitol of the U.S. Jones, Oklahoma
08 Can-Am Spyder (Miss Lindy's)
03 R1200CLC Capri Blue "Flipper"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 R1100RT Glacier Blue "Lucky"
91 R100GS "It'sNotAMoneyPit"
The voices in my head may not be real, But they have some good ideas!


"I like the wind in my face and Boobies on my back. No, Wait, I got that backwards"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JPSpen is offline  
post #5 of 9 Old May 1st, 2009, 10:21 am
Senior Member
 
Vince_nj1's Avatar
 
Join Date: Mar 2003
Location: Whippany, NJ, USA
Posts: 155
Re: Do I need a new amp?

I just changed mine on my 03. Both rear speakers were out. My connections were fine. You can try all the creative suggestions listed here, but in the end you will most likely need to buy a new radio. The radio and CD are one unit. Older tape deck models can be repaired, but the CD unit in the 2003 generation can not.

I'm not sure I would describe the installation as quick and painless. It is time consuming and requires that you remove all of the plastic to swap it out. If you haven't done that yet, it can be a little intimidating. There are probably 30 + screws.

One word of advice, the antenna is connected to the radio on the back and you will need to release the little lock that holds the connection before removing the radio. When I removed mine, I broke that connection and didn't realize it. It was a clean break. When I got the new radio the antenna wouldn't go into the new radio, only after inspection did I realize that the old clip was still attached to the antenna. You should be able to see it in the top right of this picture.

I lived with just front speakers for about 1 year, I finaly broke down and bought a new radio and I am glad that I did. If you are going to tear into your bike you might want to change your airfilter and possibly fuel filter while your at it. I changed my airfilter, but didn't want to mess with a fuel filter.

Good luck




Vince - 2003 LT.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Vince_nj1 is offline  
post #6 of 9 Old May 1st, 2009, 12:01 pm
Senior Member
 
MikeERideWNC's Avatar
 
Join Date: Jun 2007
Location: Murphy, NC, USA
Posts: 793
Re: Do I need a new amp?

To me with a BMW quick and painless is two hours.
Then I about a month later I tore it all apart and added XM with the convertor in placed in the stingray.

If you have checked all the connectors, then you are familar with taking the plastic off.

It is much easier your second, third, forth time.

I agree... Replace the air filter while you have it apart.

I think the peplacement BMW is the best route, however the cost is to high.
Make sure to seal up the stingray when you reassemble.

Visit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
_ Why is there never enough time to do it right the first time, but always enough time to do it over?
MikeERideWNC is offline  
post #7 of 9 Old May 1st, 2009, 1:32 pm Thread Starter
Senior Member
 
PrimePower's Avatar
 
Join Date: Apr 2009
Location: Williamsburg, VA, USA
Posts: 121
Re: Do I need a new amp?

Thanks for the advice. Because I have just bought the bike, I'm going to wait and just go with three speakers for now. Sucks, but don't have $500 just laying around right now. But when I do, where is the best source for these.
PrimePower is offline  
post #8 of 9 Old May 1st, 2009, 4:23 pm
Senior Member
 
Steve_R's Avatar
 
Join Date: Mar 2003
Location: Snellville, GA, USA
Posts: 6,424
Re: Do I need a new amp?

If you lucky, ltparts.com, beemerboneyard, and you dealer.

On His Ride,
Steve
-
KA5MTE
'02 LTE - Red-blooded Dragonfly
'00 Unigo - Dragon's Egg
'01 LTC - Flying Purple People Eater (Ya gotta be old enough to understand)(RIP)
'00 LTC - Canyon Red Rover (RIP)

Have you
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwlt.com lately????



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"To not know me is to lose nothing, to not know Him is to lose everything."
Steve_R is offline  
post #9 of 9 Old May 1st, 2009, 6:29 pm
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Do I need a new amp?

Quote:
Originally Posted by Steve_R
If you lucky, ltparts.com, beemerboneyard, and you dealer.
Also watch E-Bay there's a lot of LT parts on it.

Stevie Shreeve
katnapinn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome