Cruise Control Issue - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Feb 18th, 2009, 9:13 pm Thread Starter
Sac
Junior Member
 
Join Date: Apr 2005
Location: Ashland, OH, USA
Posts: 26
Cruise Control Issue

I have 99LT with 56,000 miles on it. This past season while on a trip the cruise stopped working. I checked the fuse and having found that it had blown - replaced it. After replacing the fuse things seemed OK for a short while and now the fuses continue to blow. I have put a total of 4 fuses in. Does anyone have an opinion as what should be tested or done first? Any information on this is appreciated!
Thanks - Sac
Sac is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Feb 18th, 2009, 9:21 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Cruise Control Issue

Quote:
Originally Posted by Sac
I have 99LT with 56,000 miles on it. This past season while on a trip the cruise stopped working. I checked the fuse and having found that it had blown - replaced it. After replacing the fuse things seemed OK for a short while and now the fuses continue to blow. I have put a total of 4 fuses in. Does anyone have an opinion as what should be tested or done first? Any information on this is appreciated!
Thanks - Sac
Click here and go to Radio and Extras and item #7 for a diagnostic ritual to check thangs out.
Dick is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm Stumped..... Cruise Control Issue Cochinosucio K1200LT 10 Dec 13th, 2008 11:51 am
Cruise Control issue CaDude145 K1200LT 15 Jul 17th, 2007 7:44 am
MCCruise.com electronic cruise control installed Randy GS Series 16 Jun 22nd, 2007 10:04 am
Section speed trap in The Netherlands vvk Europe 4 Apr 18th, 2006 4:40 am
Speed traps in The Netherlands vvk Chit Chat 0 Oct 24th, 2005 10:38 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome