Radio has no power - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jan 13th, 2006, 4:41 pm Thread Starter
Member
 
starvingdrummer's Avatar
 
Join Date: Jun 2005
Location: Santa Rosa, CA, USA
Posts: 70
Question Radio has no power

I let the LT sit too long and the 16 month old batt went dead. Checked the electrolyte level, charged it up, everything's ok so far. Now the bike starts, but the radio is dead. The secondary fuse under the seat is ok, the CD changer has power, which makes me think I'll be having to remove the stingray to get to the fuse at the back of the deck.

Does anyone think I can remove the left panel just to get at this fuse?

Thanks
starvingdrummer is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jan 13th, 2006, 4:58 pm
Senior Member
 
zaphod's Avatar
 
Join Date: Aug 2003
Location: Little Rock, AR, USA
Posts: 654
You should try disconnecting the battery and leave it disconnected for 30 minutes or so. Make sure the ignition is in the "locked" position before disconnecting the battery.

Malcolm McGee
Little Rock, AR
'00 K1200LTC Canyon Red
'09 Kawasaki KLR 650
'96 Bunkhouse
IBA #24557
BMWMOA #117769


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zaphod is offline  
post #3 of 5 Old Jan 13th, 2006, 6:53 pm Thread Starter
Member
 
starvingdrummer's Avatar
 
Join Date: Jun 2005
Location: Santa Rosa, CA, USA
Posts: 70
I forgot to mention that step. I disconnected the negative for at least 2 hours. No change.
starvingdrummer is offline  
 
post #4 of 5 Old Jan 13th, 2006, 11:06 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,301
To get to the radio fuse (10 amp in the rear)requires removal of both sides as well as the stingray and dissassembly of the radio housing.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #5 of 5 Old Jan 14th, 2006, 12:04 am
Senior Member
 
onions's Avatar
 
Join Date: Apr 2003
Location: Melbourne, Victoria, Australia
Posts: 1,094
Why would the fuse blow?

Quote:
Originally Posted by jzeiler
To get to the radio fuse (10 amp in the rear)requires removal of both sides as well as the stingray and dissassembly of the radio housing.
As John said, there is a fair bit of mucking around to get to the fuse... So before doing so, might be worth while considering all of the possible causes. And begs the question as to why the fuse would blow if the bike has just been left with the power draining out from the battery... Is there absolutely no power to the radio evident? Any hissing in the speakers etc?

If you haven't pulled the stingray before and been into the radio...let us know here and I'm sure we can talk you through it...

Good luck...

Ian
Melbourne, Australia

2000 K1200LT Grey - 'The Airbus'
onions is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio just quit atps1234 K1200LT 62 May 29th, 2017 11:43 pm
Radio static fixed (or "Curses, foiled again.") wcarter K1200LT 8 Dec 31st, 2008 8:37 pm
Fix for the Baehr K1200LT and CB radio. CARNEYM Intercom, CB, & 2-Way Radios 5 Jan 15th, 2006 5:01 pm
Best place to grab power for Satellite Radio? atps1234 Satellite Radio 9 Nov 26th, 2005 9:32 am
Delayed Power to Headset and Detector Canabarry K1200LT 8 Oct 15th, 2005 10:20 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome