ABS Failure on 2000LT - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Jan 9th, 2006, 8:22 pm Thread Starter
Senior Member
 
Join Date: Jan 2003
Location: Sioux City, IA, USA
Posts: 129
Unhappy ABS Failure on 2000LT

Went for a ride Saturday in 43 weather. ABS went off on a slow stop at a sandy intersection. Abs tried to reset as I pulled away, but with a strange sound. ABS warning lights started to flash! After a trip to the dealer and a new battery the ABS unit is toast. It had a piston failure code and resets the code on pulling away. Tried exercising it on MoDiTec, but it now fails routinely with that code. Just had the clutch and brakes flushed this fall. I really wish I had bought an extended warranty. $1605 for the unit and $375 for installation. 48K on the bike.

Anyone have a good used ABS unit? I have a post in the classifieds, but thought I may get more responses here.

Chuck Swenson,
Sioux City, IA
2010 R1200RT Low with ESA2!
2005 LT
iowalt is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Jan 9th, 2006, 9:25 pm
was
Senior Member
 
was's Avatar
 
Join Date: Apr 2005
Location: Guilford, CT, USA
Posts: 805
Chuck, there is a guy on eBay selling brake parts for an '03 (IIRC). He had the front and rear brake calipers listed a few days ago. Did not see the ABS unit listed, but in at least one of his ads he said to email him for other parts. It might be worth checking out. Good luck.

Bill

Bill
Guilford, CT
'99 Canyon Red K1200 LT - Buddah Bike
was is offline  
post #3 of 6 Old Jan 9th, 2006, 9:31 pm Thread Starter
Senior Member
 
Join Date: Jan 2003
Location: Sioux City, IA, USA
Posts: 129
ABS Fault

Thanks Bill,
I think the ABS unit needs to be from a 99-01 to work. Does anyone know if the k12RS unit is the same?

Chuck Swenson,
Sioux City, IA
2010 R1200RT Low with ESA2!
2005 LT
iowalt is offline  
 
post #4 of 6 Old Jan 10th, 2006, 1:20 am
 
Join Date: Jun 2002
Posts: 3,413
Quote:
Originally Posted by iowalt
Does anyone know if the k12RS unit is the same?
It doesn't appear to be, no. I checked part numbers of an ABS Pressure Modulator Hydro Unit for both 2000 KLT and KRS and they're not the same:

KLT: # 34 51 2 333 232

KRS: # 34 51 2 331 637

Links to online parts' fiches in the HoW (k.1).
beemerlt is offline  
post #5 of 6 Old Jan 10th, 2006, 10:51 pm
Senior Member
 
JCarver's Avatar
 
Join Date: Mar 2004
Location: Greensboro, GA, USA
Posts: 398
Wink Re: ABS on 2000LT

Chuck:

Seems we are quite similar, my ABS went out almost a year ago. I've secured a replacement unit, but no time to install it as of yet. But one place you might want to check: http://www.re-psycle.com/

I acutally found my replacemet on EBay, look under "Buy It Now" dealers. But be warned, some of those dealers have gone like dealer prices for used parts. You might have to keep a diligent watch for some time, but it is worth the effort.

As for your 2000, it will operate quite well without the ABS. Only aggravation is the flashing lights and you can undo the bulb to stop that.

ttyl

John Carver
K1200LTC, AMA, BMWMOA
Greensboro, GA

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JCarver is offline  
post #6 of 6 Old Jan 10th, 2006, 11:20 pm
 
Join Date: Jul 2004
Posts: 161
ltcanup is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear or Final Drive Failure fitzy79 Australia, New Zealand, and AsiaPac 33 Jan 3rd, 2012 8:25 pm
ABS unit gone again plonk K1200LT 9 Jun 17th, 2011 5:06 am
Bridgestone BT020R 160/70R-17 tire failure. mudman Tires 23 Aug 28th, 2006 3:36 am
Help with ABS LT2B K1200LT 15 Jun 16th, 2006 1:22 am
ABS II Failure captainasty K1200LT 2 Oct 3rd, 2005 4:46 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome