HID- kit question - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Oct 23rd, 2008, 8:49 am Thread Starter
Senior Member
 
emsweeney's Avatar
 
Join Date: Jul 2003
Location: Parkton, MD, USA
Posts: 681
HID- kit question

I have a HID kit I purchased a while back in the group buy. It has worked fine except when starting the bike it sometimes does not fire. Turn key off and on again and it usually fires, maybe have to repeat for the 3rd. time but it has never failed to fire. When I called the folks they sent me a new connector that goes to the light and the igniter with a capacitor in line. It came with a warning about hooking to the + & - or it will blow.

Two questions; Has anybody had the same problems and did they use this new link? If so did it help the inconsistent lighting?

Thanks in advance,

Gene Sweeney

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
emsweeney is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Oct 23rd, 2008, 8:57 am
 
Join Date: Feb 2004
Posts: 4,905
Re: HID- kit question

I cut that capacitor off of my kit. Probably 1 in 10 starts, the low-beam will not fire up with the engine. I simply restart, and all is well. I never had to try a third time. Theoretically, that inline super-cap could solve the problem. I can't see how it could hurt. The X-spurts will come along shortly and get it sorted out for ya.
messenger13 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
CQ Light HID post-install tech Question wkclark K1200LT 9 May 8th, 2008 6:53 pm
Question About High Hid Install On 06 K1200lt BMWWANDRR K1200LT 1 Apr 16th, 2008 7:06 am
FashTek HID Question hifiman K1200LT 5 Apr 9th, 2008 9:56 am
HID Install Question...help!!! petevandyke Lighting 27 Feb 1st, 2007 5:09 pm
HID Question bbake250f Lighting 4 Jan 10th, 2006 8:12 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome