Radio Issue - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Oct 13th, 2008, 9:25 am Thread Starter
Senior Member
 
EzyMount's Avatar
 
Join Date: Apr 2002
Location: Franklin, NC USA
Posts: 1,423
Radio Issue

ANother confirmation that radio is causing excessive battery drain, in this case. While searching for battery drain, I finally pulled fuse for Radio Circuit, which resulted in 0-drain overnight, as compared to appx 1V drain overnight while connected, as measured several nights in a row...

Anyone seen this before ?

Jim Lawson 2016 R1200RT
Retired to NC !


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
EzyMount is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Oct 13th, 2008, 10:08 am
Senior Member
 
Join Date: May 2008
Location: New York, NY, USA
Posts: 475
Re: Radio Issue

If the steering lock isn't on, the radio has power, so it can in theory use up power. I don't think thats causing your battery to drain though. If you put the steering wheel lock on does the battery still drain?
Caveno is offline  
post #3 of 5 Old Oct 13th, 2008, 2:53 pm Thread Starter
Senior Member
 
EzyMount's Avatar
 
Join Date: Apr 2002
Location: Franklin, NC USA
Posts: 1,423
Re: Radio Issue

did not seem to make a diff ! based on the way the radio has been acting latey, on/off, inconsistent speaker responses, etc. I believe my radio is toast and needs to be replaced. unless the connectors under my stingray need attention ?

Jim Lawson 2016 R1200RT
Retired to NC !


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
EzyMount is offline  
 
post #4 of 5 Old Oct 13th, 2008, 9:55 pm
Senior Member
 
AlaskaFish's Avatar
 
Join Date: Apr 2002
Location: Hillsboro, OR, USA
Posts: 3,136
Red face Re: Radio Issue

Jim, sounds strange, but possible I guess. I do know that the '99 and some early '00 LT's supposedly had a problem with the radios running down the batteries, but it seems you would have seen this long ago!

If you are sure it is the radio, and can't find one anywhere else, drop us a PM since we do have one from a '00 LT that we would be willing to part with. The one we have is the Radio/Cassette version.

Good Luck!

John

John & Marilyn Fisher
'00 K1200LTC "Katie"
'95 Triumph "Tigger"
'12 Triumph 800XC "Tigger II" (RIP)
'12 Triumph 1200 Explorer "Shadow Tigger"
Hillsboro, Oregon

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AlaskaFish is offline  
post #5 of 5 Old Oct 14th, 2008, 1:38 pm
Senior Member
 
Join Date: May 2008
Location: New York, NY, USA
Posts: 475
Re: Radio Issue

What happens when you pull the fuse on the radio?

The radio may be draining your battery, but the problem may not be the radio. The radio shouldn't have any power in the first place, it may be a wiring problem. You could also disconnect the radio and hook up a multimeter to it, see if the radio is getting power when it shouldn't.

Sounds like a fun problem to solve, wish I had this problem An excuse to take her apart!
Caveno is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio issue Travis K1200LT 4 Aug 13th, 2008 11:03 pm
Radio Reception in NJ and First Gear Issue sully2028 K1200LT 1 Apr 7th, 2008 10:17 pm
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm
Need help debugging radio issue hd2bmw Bike Talk 6 May 2nd, 2007 6:28 pm
Help with strange Radio issue hd2bmw K1200LT 1 Apr 20th, 2007 4:40 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome