Another radio quitting problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Oct 11th, 2008, 11:55 am Thread Starter
Senior Member
 
simon's Avatar
 
Join Date: Sep 2003
Location: Upminster, Essex, UK
Posts: 504
Another radio quitting problem

Riding my bike yesterday (05) when I got off, I noticed the two front speakers not working. Played around with the fader but still nothing. Read up all the "speaker quit" posts on the site last night and disconnected the battery overnight.
Turned it on this morning, fronts worked for one, maybe two seconds then quit again.
This afternoon took all the tupperware off, and cleaned all visible connections (using switch cleaner), still no better. Disassembled the stingray to get to the connector at the back of the stereo unit (see pics), and after getting it off, sprayed it with the switch cleaner. Plugged it back in, front left working plus rears, took it off again, plugged it back in, front left no longer working!
I've tried all the connectors I can find, but it seems like I may have a duff unit! anything else I can try?
Simon
Attached Thumbnails
Click image for larger version

Name:	connectors-1.jpg
Views:	95
Size:	71.9 KB
ID:	19990   Click image for larger version

Name:	connectors-2.jpg
Views:	92
Size:	42.7 KB
ID:	19991   Click image for larger version

Name:	connectors-3.jpg
Views:	102
Size:	82.2 KB
ID:	19992  

2006 k1200LT........my 13th!
simon is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Oct 11th, 2008, 12:51 pm
Senior Member
 
Join Date: Nov 2007
Location: Macon, Ga, USA
Posts: 105
Re: Another radio quitting problem

I've tried all of that and both my left speaker still don't work. I e-mailed Harman Becker and they said I needed a new circuit board. It would cost $400 for them to fix it and the parts are 6 weeks back ordered. I'm tying to figure a way to replace it with something better? I know you would not be able to use the controls on the handle bars but. I think a marine radio would work. You could mount a controler in the top where the buttons are. I'm still thinking. Moisture seems to be the thing killing the radios. I would have thought something better would have been in them.....
ronnieds is offline  
post #3 of 8 Old Oct 11th, 2008, 4:40 pm
Senior Member
 
big_ed's Avatar
 
Join Date: May 2007
Location: Humble, Texas,
Posts: 244
Re: Another radio quitting problem

It's probably hosed. The speaker amplifiers seem to be the culprit when all else checks out. I too tried everything then tried this zany idea to deal with it...
http://www.bmwlt.com/forums/showthread.php?t=35906
big_ed is offline  
 
post #4 of 8 Old Oct 11th, 2008, 6:00 pm
Senior Member
 
MikeERideWNC's Avatar
 
Join Date: Jun 2007
Location: Murphy, NC, USA
Posts: 793
Re: Another radio quitting problem

As I have posted this before: The marine radio would be the ultimate answer for a motorcyle radio.
However, all control functions are gone.

When I had a Sea Ray it had a Maxima Marine AM/FM Cassette.
I was cleaning the boat and accidently preasure washed the radio.
There must have been a gallon of water through the cassette deck, the radio always worked fine.
Imagine if BMW used a radio with half of that quality.

Visit
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
_ Why is there never enough time to do it right the first time, but always enough time to do it over?
MikeERideWNC is offline  
post #5 of 8 Old Oct 14th, 2008, 1:20 pm Thread Starter
Senior Member
 
simon's Avatar
 
Join Date: Sep 2003
Location: Upminster, Essex, UK
Posts: 504
Unhappy Re: Another radio quitting problem

Despite my best efforts with contact cleaner, the two fronts are still out. I've taken the unit (and control panel) to a radio specialist, he's going to inspect it tomorrow and report back. I'll post with the news then.
Simon

2006 k1200LT........my 13th!
simon is offline  
post #6 of 8 Old Oct 14th, 2008, 8:49 pm
Member
 
niobium's Avatar
 
Join Date: Jan 2005
Location: Green Bay, WI, USA
Posts: 87
Re: Another radio quitting problem

I bought my 2006 used back in July 2008 with 1100 miles on it. The radio did not work at the time of purchase and the dealer agreed to fix it as part of the sale. Turns out that the radio needs to be replaced (under warranty) but BMW no gots no steenkin' radios. Dealer re-assembled the fat girl and gave her back to me until he can get a radio; says they are on (inter)national back order.

Rick

2014 K1600GTL Exclusive
2013 R1200GS LC
2011 Husqvarna TE630


"Never ask a man what computer he uses; if it's a Mac, he'll tell you. If not, why embarrass him?" -- Tom Clancy
niobium is offline  
post #7 of 8 Old Oct 21st, 2008, 4:45 am Thread Starter
Senior Member
 
simon's Avatar
 
Join Date: Sep 2003
Location: Upminster, Essex, UK
Posts: 504
Unhappy Re: Another radio quitting problem

Just spoke with the guy who has my radio. He says he's going to have to get in touch with Becker (UK) to find out the problem. He says it MAY be the main pcb, in which case it'll have to go back to Becker in Germany!
I can see this is getting expensive!

2006 k1200LT........my 13th!
simon is offline  
post #8 of 8 Old Oct 22nd, 2008, 4:46 am Thread Starter
Senior Member
 
simon's Avatar
 
Join Date: Sep 2003
Location: Upminster, Essex, UK
Posts: 504
Re: Another radio quitting problem

Thought so! My radio guy has been in touch with Becker who say the radio is under licence (?) to BMW and they can't work on it, only option is new/exchange radio which he says will cost 1,000 ($2000).
Luckily enough, just managed to find a company breaking a 2006 LT and have bought the radio off that for just 100!
Simon

2006 k1200LT........my 13th!
simon is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird electrical problem with Radio hd2bmw K1200LT 6 Jul 7th, 2010 7:10 pm
XM radio *technical bulletin* notice. Dick Satellite Radio 4 Aug 18th, 2008 11:13 am
Radio May Be Going Bad gdroege K1200LT 7 Aug 8th, 2008 12:16 pm
radio problem on 1200LTE couleekid Chit Chat 0 Jul 3rd, 2008 11:40 pm
Radio flickering KMC1 K1200LT 3 Jun 7th, 2006 10:50 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome