Spiegler Brake Line Problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Aug 18th, 2008, 11:02 am Thread Starter
Senior Member
 
Join Date: Sep 2002
Location: Augusta, GA, USA
Posts: 796
Spiegler Brake Line Problem

I replaced my leaking OEM brake lines with the Spiegler SS brake lines a couple of weeks ago and have been very pleased with the improvement in braking (and not leaking) until now.

Saturday morning we took a little 75+ mile ride to go to the shop made available by one of our local club member (which was only 6 miles away) so we could change the oil in his GSA and bleed his brakes.

When I arrived home, I backed my bike into the carport so I could change the rear drive lube. While changing the lube I noticed a puddle forming beside my front wheel. The front right rotor was soaked in brake fluid but no brake fluid was on any part of the tupperware or wheel indicating it had just started leaking.

I reached up to test the brake lever and it offered no resistance and brake fluid sprayed out of the line at the front wheel. I thought one of the lines was bad, but it turned out that the machined "T" connector furnished by Spiegler had split open at the lower part of the "T". I don't know if this has happened to anyone else, but it really bothers me that there was no warning at all - and the leak started when the bike was sitting still.

Spiegler was emailed this morning and I received a prompt response that they were sending out a replacement unit right away - which makes me feel a little better. Hope this does not happen to anyone else.

Lee Nowell
Black 01, LTC
BMWRA & MOA, AMA, IBA
lnowell is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Aug 18th, 2008, 11:32 am
Senior Member
 
hallzee's Avatar
 
Join Date: Mar 2006
Location: Gold Country, CA, USA
Posts: 2,571
Re: Spiegler Brake Line Problem

Sorry to hear about that. Make sure they send you the crush washers too!

Brian
CCR: 2008, Midway; 2011, Boise; 2012, Duluth; 2014, Chattanooga. MOA: Billings, 2015; SLC, 2017
CCR-R: 2018, Russellville
'13 K1600 GTL-P - "Eva"
Sold but "beloved" ride: K12 LT - "Pepe"
IBA #31242 (SSx2, BB, BBG)
MOA #136148

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
hallzee is offline  
post #3 of 6 Old Aug 18th, 2008, 11:45 am Thread Starter
Senior Member
 
Join Date: Sep 2002
Location: Augusta, GA, USA
Posts: 796
Re: Spiegler Brake Line Problem

No crush washers needed at this connection. I actually had an extra crush washer included in my kit.

Lee Nowell
Black 01, LTC
BMWRA & MOA, AMA, IBA
lnowell is offline  
 
post #4 of 6 Old Aug 18th, 2008, 12:01 pm
Senior Member
 
hallzee's Avatar
 
Join Date: Mar 2006
Location: Gold Country, CA, USA
Posts: 2,571
Re: Spiegler Brake Line Problem

Quote:
Originally Posted by lnowell
No crush washers needed at this connection. I actually had an extra crush washer included in my kit.
You're right.... Now you know why they call it "Hallzheimer's"...

When I got my kit, I was actually short one crush washer - so you're the guy that got it!

Brian
CCR: 2008, Midway; 2011, Boise; 2012, Duluth; 2014, Chattanooga. MOA: Billings, 2015; SLC, 2017
CCR-R: 2018, Russellville
'13 K1600 GTL-P - "Eva"
Sold but "beloved" ride: K12 LT - "Pepe"
IBA #31242 (SSx2, BB, BBG)
MOA #136148

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-
hallzee is offline  
post #5 of 6 Old Aug 18th, 2008, 12:04 pm
Senior Member
 
Steve_R's Avatar
 
Join Date: Mar 2003
Location: Snellville, GA, USA
Posts: 6,424
Re: Spiegler Brake Line Problem

That's the first I've heard of it Lee. Mine are still working just fine, but I'll take a peek at all the connectors today.

On His Ride,
Steve
-
KA5MTE
'02 LTE - Red-blooded Dragonfly
'00 Unigo - Dragon's Egg
'01 LTC - Flying Purple People Eater (Ya gotta be old enough to understand)(RIP)
'00 LTC - Canyon Red Rover (RIP)

Have you
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwlt.com lately????



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"To not know me is to lose nothing, to not know Him is to lose everything."
Steve_R is offline  
post #6 of 6 Old Aug 18th, 2008, 12:48 pm Thread Starter
Senior Member
 
Join Date: Sep 2002
Location: Augusta, GA, USA
Posts: 796
Re: Spiegler Brake Line Problem

Actually I could not see it. That would be too easy. As you would suspect, the split is on the inside lower arm of the "T". I doubt if you are going to have a problem with yours if it has been on a while. I think mine is just a bad machine part or bad billet stock.

Lee Nowell
Black 01, LTC
BMWRA & MOA, AMA, IBA
lnowell is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Brake light problem xenia K1200LT 1 Jun 7th, 2007 10:53 pm
Front Brake Pad R&R (looong story) was K1200LT 1 Sep 3rd, 2006 10:48 pm
Blown brake line UPDATE JPSpen K1200LT 0 Aug 21st, 2006 9:36 pm
HELP ! Blown brake line JPSpen K1200LT 5 Aug 20th, 2006 10:54 am
Brake light problem buffalo K1200LT 3 Oct 23rd, 2005 3:34 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome