Radio Noise Help? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Apr 21st, 2008, 4:58 pm Thread Starter
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Radio Noise Help?

On the last 200 miles of a 1700 mile tip this weekend I developed an electronic buzz or static that I can hear in the radio at around 3000 RPM's.. It is very load and comes back for a few seconds at higher RPM's I know this does not give y'all a lot of info but I'm sure someone has had this happen to them and will help me out.

Stevie Shreeve
katnapinn is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old May 15th, 2008, 7:23 pm Thread Starter
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Radio Noise Help?

Quote:
Originally Posted by katnapinn
On the last 200 miles of a 1700 mile tip this weekend I developed an electronic buzz or static that I can hear in the radio at around 3000 RPM's.. It is very load and comes back for a few seconds at higher RPM's I know this does not give y'all a lot of info but I'm sure someone has had this happen to them and will help me out.
Ok I got no feed back on this thread soooooo I'll try again . It is static in the radio at 2700 to 3000 RPM's I have rewired all the farkles to a NEW BlueSea fuse block (Thanks Chan and this forum) I disconnected ALL electronics and I still get the noise !!!! Could it be that the noise is in the Radio itself? I've searched the forum with no luck on this type of problem. PLEASE HELP ME !!!!!!

Stevie Shreeve
katnapinn is offline  
post #3 of 8 Old May 15th, 2008, 7:49 pm
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
Re: Radio Noise Help?

Thru the stock speakers or a headset-helmet speakers?

I remember reading about noise in the LT sound system a few years ago? 05 model?

Griff built an electronic isolating blue box that didn't solve the problem?

Bob

"He was a foul caricature of himself, a man with no soul, no inner convictions, with the integrity of a hyena, and the style of a poison toad." H. S. Thompson
BecketMa is offline  
 
post #4 of 8 Old May 15th, 2008, 8:13 pm
Senior Member
 
Mike_H's Avatar
 
Join Date: Feb 2004
Location: New Berlin, WI, USA
Posts: 269
Re: Radio Noise Help?

I Have the same (or similar) problem with the radio on my 2005 LT. It is most noticable whem listening through the speakers in my helmet. I sounds like spark noise because it varys with engine speed.

I've been through the wiring, checked all the grounds and connections and can't get rid of it. My dealer says he's had the same thing happen to other '05 LTs and has never found the solution.

I started wearing foam ear plugs and to my surprise the filtered out the buzz but not the music, so that's my el cheapo solution.

Inside my 60 year old body is a 35 year old brain wondering what the hell happened.
2005 K1200LT
2005 Suzuki Burgman
BMWMOA #130574
Mike_H is offline  
post #5 of 8 Old May 16th, 2008, 6:03 am Thread Starter
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Radio Noise Help?

Quote:
Originally Posted by BecketMa
Thru the stock speakers or a headset-helmet speakers?

I remember reading about noise in the LT sound system a few years ago? 05 model?

Griff built an electronic isolating blue box that didn't solve the problem?

Bob
Bob it is thru the headset. I have not tried it thru the bike's speakers.

Stevie Shreeve
katnapinn is offline  
post #6 of 8 Old May 16th, 2008, 6:21 am
Senior Member
 
bigbear's Avatar
 
Join Date: Dec 2005
Location: Winnebago, IL, USA
Posts: 1,178
Re: Radio Noise Help?

katnappin,

I presume you did not change headsets or com systems? If so messenger13 pointed me towards a noise isolation device from radio shak. I would have to do some searching to find the model number but not sure if this would solve your problem since it sounds like system worked fine for awhile.

possibly PM messy13 and pick his brain.

Roy

Roy Gregersen

Ride Slow, Ride Fast, Always Ride Safe
85 K100RT sold
02 LTC DOA 9/21/14
12 R1200RT
bigbear is offline  
post #7 of 8 Old May 16th, 2008, 6:26 am Thread Starter
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Re: Radio Noise Help?

Quote:
Originally Posted by bigbear
katnappin,

I presume you did not change headsets or com systems? If so messenger13 pointed me towards a noise isolation device from radio shak. I would have to do some searching to find the model number but not sure if this would solve your problem since it sounds like system worked fine for awhile.

possibly PM messy13 and pick his brain.

Roy
Roy. the system has worked great for 43,000 miles it just started in the last 400 or 500 miles. I had the same headset for over a year.

Stevie Shreeve
katnapinn is offline  
post #8 of 8 Old Jul 4th, 2008, 12:48 pm Thread Starter
Old Slow Guy in A Fast Car
 
katnapinn's Avatar
 
Join Date: Apr 2006
Location: Kyle, Texas, USA
Posts: 8,597
Update !!!!!!

Well after 2 and 1/2 month of trial and error I've finally fixed the snap crackle pop in my radio. I've rewired everything to a "SeaBlue" fuse box. cleaned and greased all connections. I've pulled the stingray 3 times with no love. I made a call to Tony at LTParts.com and he sent me a newer radio. it was a 2002 modal. Not sure who's bike it was from but I'll find out. Installed it today, total time for for the job was 1 hour and 45 minutes. That is to pull both upper faring, tipover wing , vent wings and stingray. Pull radio apart install new one and reassemble every thing. Went for a short 50 mile ride and the radio worked flawlessly. THANKS TONY !!!

Stevie Shreeve
katnapinn is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine noise over radio Hollywood K1200LT 13 Jun 25th, 2008 4:22 pm
voice separation on the LT's loudspeaker jusufbw K1200LT 6 Oct 8th, 2007 10:03 pm
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm
XM Radio merging with Sirius Radio Tomakazie Satellite Radio 11 Feb 21st, 2007 7:12 am
Radio Question...Searched Hall of Wisdom hybridcage K1200LT 7 Dec 4th, 2006 1:32 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome