My 2005 Lt blowing fuse after reconnected battery - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Apr 5th, 2008, 2:03 pm Thread Starter
Junior Member
 
Join Date: Apr 2007
Location: NEW YORK, NEW YORK, USA
Posts: 12
My 2005 Lt blowing fuse after reconnected battery

I disconnected my battery on my 2005 lt for about a month and reconnected and the fuse from horn ,brake light etc blowed ,change for new one and same thing ,bike start normal but no horn no brake light,ant-theft alam system with central locking. Can you help me
n2taq is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Apr 5th, 2008, 2:19 pm
 
Join Date: Feb 2004
Posts: 4,905
Re: My 2005 Lt blowing fuse after reconnected battery

The first objective is to isolate what the cause of the problem is, obviously. If it's the same fuse setup as the pre-'05s, that fuse is for the horn, the brake lights, and the anti-theft system (if installed). I would remove the fuse and start the bike. While running, install a new fuse. If it pops instantly, it almost has to be the anti-theft system that's causing the problem. Your horn and brake light aren't being used if the bike is just parked and idling there.
messenger13 is offline  
post #3 of 4 Old Apr 5th, 2008, 4:37 pm
Senior Member
 
grifscoots's Avatar
 
Join Date: May 2002
Location: Outside New Braunfels , TX, USA
Posts: 13,451
Re: My 2005 Lt blowing fuse after reconnected battery

Mayhaps some furry leetle creature has been in there gnawing while the bike was asleep.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

-=grif=-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Grok
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
grifscoots is offline  
 
post #4 of 4 Old Apr 23rd, 2008, 4:39 pm Thread Starter
Junior Member
 
Join Date: Apr 2007
Location: NEW YORK, NEW YORK, USA
Posts: 12
Re: My 2005 Lt blowing fuse after reconnected battery

Was The Alarm.had To Be Replace By New One .
n2taq is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Alarm fuse F3 keeps blowing sparky_k1200lt Batteries, Chargers, & Electrical 3 May 6th, 2013 7:44 pm
'05 Lt Battery And Recharging With An Electronic Low Amps Tender ajs K1200LT 2 Apr 9th, 2007 10:11 am
Gadgets to Battery & Fuse Block murray Batteries, Chargers, & Electrical 2 Feb 28th, 2007 9:55 am
Bike only 14 months old - battery problems Thor1340 K1200LT 14 Aug 30th, 2006 4:59 pm
Is a charger a charger? graydude Batteries, Chargers, & Electrical 28 Dec 10th, 2005 11:13 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome