Left rear speaker issue???? - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Mar 22nd, 2008, 10:05 pm Thread Starter
 
Join Date: Feb 2008
Posts: 14
Left rear speaker issue????

I need help from my fellow BMW riders...... What can be done about my left rear speaker does not have any sound? Removed seat disconnected center plug reconnected but still nothing.... Any other suggestions?
Timmy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Mar 22nd, 2008, 11:10 pm
Senior Member
 
Join Date: Dec 2002
Location: South Georgia, , USA
Posts: 1,136
Re: Left rear speaker issue????

My left rear speaker just blew. Not working also. Bike is six years old. I guess time to buy new rear speakers.
wardenross is offline  
post #3 of 5 Old Mar 23rd, 2008, 12:26 pm Thread Starter
 
Join Date: Feb 2008
Posts: 14
Re: Left rear speaker issue????

Warden,
Thanks for the heads up, your response prompted me to some other links which I think will help...... I see you were in Ashville, beautiful area.....
Tim
Timmy is offline  
 
post #4 of 5 Old Mar 24th, 2008, 8:50 am
Senior Member
 
zaphod's Avatar
 
Join Date: Aug 2003
Location: Little Rock, AR, USA
Posts: 654
Re: Left rear speaker issue????

Check and make sure itís the speaker. My left rear went out, but after trouble shooting I found out the speaker was fine and that it was the output stage of the stereo. My intercom still had full stereo, so I decided to live with it rather that go through the time and expense of a repair.

Malcolm McGee
Little Rock, AR
'00 K1200LTC Canyon Red
'09 Kawasaki KLR 650
'96 Bunkhouse
IBA #24557
BMWMOA #117769


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zaphod is offline  
post #5 of 5 Old Mar 24th, 2008, 5:52 pm
Waz
Junior Member
 
Join Date: Nov 2007
Location: Malvern, Worcestershire, UK
Posts: 24
Re: Left rear speaker issue????

The rear speakers are virtually unknown to fail. It is possible, as is the wiring connections, but circa 2005 models are notorious for an electrical component failure in the output stage of the radio unit itself, which causes one of the speakers (generally the rear ones) to fail. Usually when the unit is stone cold it works for a few seconds then fails. BMW normally change the unit under warranty (if you have an extended one) otherwise it is an expensive operation involving removing the tupperware and a repair job.
The best option is either to ignore it or take the radio unit to a competent radio repair shop.
There are quite a few threads on this issue.
Best of luck
Waz
K1200 LT Basalt Grey
K1200 LT Light Yellow
K1200 RS Blue/silver
Waz is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rather longish, but good tips & info! vvk Bike Talk 7 Jun 19th, 2011 5:43 pm
Left rear speaker issue???? Timmy K1200LT 2 Mar 21st, 2008 9:00 am
Speaker issue?????? Timmy K1200LT 2 Feb 28th, 2008 10:05 pm
Cheap Rear Speaker Replacement MolenaarD K1200LT 5 Jul 10th, 2006 3:17 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome