Radio fixed with new battery.. - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Jan 10th, 2008, 7:55 am Thread Starter
Senior Member
 
emsweeney's Avatar
 
Join Date: Jul 2003
Location: Parkton, MD, USA
Posts: 681
Talking Radio fixed with new battery..

Thanks to this forum my 2003 radio was fixed with a new battery. Tuesday as I started off for my ride to work, no radio, just back lighting. Checked fuses, good, check all other bike functions, good, so I called Bob's. I spoke to a service writer, not the service techs, and asked what might be the problem. To their credit they said the radio is usually very dependable, but off the top without inspection it sounds like it may need replacing and it's expensive. When I got to work I checked this forum and tried the cable removal trick, nothing. The bike has the original battery so I thought what the heck, it needs a new one any how, so I swung by Bob's and picked up a new gel battery. Like magic ESPN radio was back on the air and no high dollar radio replacement was required. Thanks again for all the forum wisdom it saved me big bucks!!!!
Plus, now my "no post" banner will go away for a while.

Gene Sweeney

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
emsweeney is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Jan 10th, 2008, 8:20 am
Cooler on the east coast!!!
 
gglove's Avatar
 
Join Date: Oct 2007
Location: Mount Pleasant South Carolina
Posts: 1,239
Gene same thing happened to me. Glad to hear the fix worked for you as well.

G-Glove
2003 Silver LTC
gglove is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Problem fixed thanks to the HoW... lhamonic K1200LT 8 Oct 20th, 2016 12:30 pm
Radio static fixed (or "Curses, foiled again.") wcarter K1200LT 8 Dec 31st, 2008 8:37 pm
Motorcycle Communicator radio jimmayor007 Intercom, CB, & 2-Way Radios 0 Dec 10th, 2007 5:46 pm
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 7:55 pm
Radio quit after battery got low BushWacker K1200LT 3 Jan 29th, 2006 7:29 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome