Sound and Screen problems - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Dec 17th, 2007, 11:12 pm Thread Starter
 
Join Date: Sep 2007
Posts: 9
Sound and Screen problems

1. Every time I start the bike, the stereo can be heard, cd. & radio o.k. After a couple of minutes it just fades away and doesn't come back until the bike is started again, any help??
2. My screen is scratched and blurry, it looks as if the previous owner cleaned it with a sandpaper, can it be durably fixed or do I need a new one? Anybody knows how much the short one is??
Thank you for your answers.
Stormvic is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
ZTechnik Windshield Big_E Ergonomics & Rider Comfort 30 Jun 12th, 2006 10:04 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome