Tach & Speedo Surge - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Oct 25th, 2007, 11:36 am Thread Starter
Member
 
GeezerBeemer66's Avatar
 
Join Date: Sep 2007
Location: Indy, IN, USA
Posts: 42
Tach & Speedo Surge

Anyone experienced this? My '05 LT tach will, from an idle, surge to about 3K RPM and drop right back to idle. The speedo will surge also, but not as pronounced... more like just a blip upward and back. The tach does not jump up near as far when motoring down the road, but at a steady speed, I will see an occasional blip upward. Myabe it was happening before, but I didn't notice this until I had installed the following electrical farkles (all installed within a few days of each other):

Caliper mount Motolights
Autoswitch to control Motolights from turn signal cancel button
DICE converter for iPod in place of 6-disc CD changer
Trailer wiring with Dauntless hitch

Is this surge a real problem or more of an annoyance?

R.I.P. George Wood 6-24-07
R.I.P. Harry Woolf 5-18-09
"Ride In Peace"

'07 R1200GSA - 27000 miles "Mad Max"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'06 FLHTCUI - 36K "Geezr"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'03 FLHT - 35K "Junior"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'05 K1200LT - 19K "Lumbering Rhinoceros" Sold

"We're reaching critical mass!"
GeezerBeemer66 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Oct 25th, 2007, 10:26 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,263
It is not normal and I would strive to correct it. It could just be a loose connector on the back of the instrument cluster (there are two). If that is not it then I would start with undoing each of the farkles one at a time to see when the surge goes away. When you find the one that is affecting it then look further as to why.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 7 Old Oct 26th, 2007, 7:36 am Thread Starter
Member
 
GeezerBeemer66's Avatar
 
Join Date: Sep 2007
Location: Indy, IN, USA
Posts: 42
Thanks. I'll start removing them one by one and see if that corrects it.

R.I.P. George Wood 6-24-07
R.I.P. Harry Woolf 5-18-09
"Ride In Peace"

'07 R1200GSA - 27000 miles "Mad Max"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'06 FLHTCUI - 36K "Geezr"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'03 FLHT - 35K "Junior"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'05 K1200LT - 19K "Lumbering Rhinoceros" Sold

"We're reaching critical mass!"
GeezerBeemer66 is offline  
 
post #4 of 7 Old Oct 26th, 2007, 1:00 pm
Senior Member
 
Join Date: Sep 2004
Location: statesville , n.c., usa
Posts: 257
tach & speedo

What is the condition of your battery? These bikes do a lot of wierd things if the battery is now up to par. My tach & speedo needles would both jump from peg to peg when i used the brake. that was just before my battery let me down.
danbrown is offline  
post #5 of 7 Old Oct 27th, 2007, 1:30 pm Thread Starter
Member
 
GeezerBeemer66's Avatar
 
Join Date: Sep 2007
Location: Indy, IN, USA
Posts: 42
Quote:
Originally Posted by danbrown
What is the condition of your battery? These bikes do a lot of wierd things if the battery is now up to par. My tach & speedo needles would both jump from peg to peg when i used the brake. that was just before my battery let me down.
Did replacing your battery solve the problem? I'm not sure if this battery is the original from June 2005. I do know that it's a gel battery, which may mean the original was replaced.

R.I.P. George Wood 6-24-07
R.I.P. Harry Woolf 5-18-09
"Ride In Peace"

'07 R1200GSA - 27000 miles "Mad Max"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'06 FLHTCUI - 36K "Geezr"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'03 FLHT - 35K "Junior"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'05 K1200LT - 19K "Lumbering Rhinoceros" Sold

"We're reaching critical mass!"
GeezerBeemer66 is offline  
post #6 of 7 Old Oct 28th, 2007, 4:01 pm
Senior Member
 
Join Date: Sep 2004
Location: statesville , n.c., usa
Posts: 257
I am not sure when BMW started using the gel batt. from the factory. my bike is an 03. I got 3 yrs out of orignal. when replaced it cured my prob. good luck.
danbrown is offline  
post #7 of 7 Old Jul 21st, 2008, 11:09 pm
Member
 
AlanLT's Avatar
 
Join Date: Dec 2006
Location: Garden Grove, CA, USA
Posts: 49
Garage
Re: Tach & Speedo Surge

Quote:
Originally Posted by GeezerBeemer66
Anyone experienced this? My '05 LT tach will, from an idle, surge to about 3K RPM and drop right back to idle. The speedo will surge also, but not as pronounced... more like just a blip upward and back. The tach does not jump up near as far when motoring down the road, but at a steady speed, I will see an occasional blip upward.
Did you find the source of this problem? I'm having the exact same symptoms on my '07 ever since they did the 24k service.

Alan
Garden Grove, CA

'07 K1200LT Biaritz Blue (97k miles)
'08 K1200LT Biaritz Blue (76k miles and climbing)

"Good judgment comes from experience, and experience - well - that comes from poor judgment." -A.A. Milne

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
AlanLT is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo Fix ndmunro K1200LT 1 Aug 4th, 2007 8:00 pm
Speedometer Question BUGKILLER K1200LT 15 Jun 22nd, 2007 5:13 pm
Speedo failure 1st bustedknuckles K1200LT 6 Feb 15th, 2007 9:17 pm
Speedo inop 02' k1200 bustedknuckles K1200LT 2 Jan 21st, 2007 1:19 pm
speedo correction for older RT retiredjj RT Series 0 Sep 13th, 2006 10:18 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome