HELP! No brake light, horn, locks, or alarm - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Oct 8th, 2007, 7:17 pm Thread Starter
Member
 
GeezerBeemer66's Avatar
 
Join Date: Sep 2007
Location: Indy, IN, USA
Posts: 42
Unhappy HELP! No brake light, horn, locks, or alarm

OK, I'm an idiot. I just received my Dauntless Motors hitch today and have installed it. I was checking my brake and tailights for functionality after having connected the supplied wiring harness from Dauntless. The running lights work, but not the brake light. Also, no horn, no central locking, and no alarm. All four of these are on the same 15A fuse, but the fuse is good. I've checked all the connections and they are correct and tight. I've got to get this fixed tonight and I've hit a wall... any thoughts?
GeezerBeemer66 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Oct 8th, 2007, 7:28 pm
Senior Member
 
Jabrown's Avatar
 
Join Date: Apr 2007
Location: Mattoon , Il, USA
Posts: 456
First off I know you probably already did this but have you checked all your wires for continuity? If you have some dead wires then I would look to see why they are dead. i.e. did you break a wire? Are the connectors working properly? I am not familiar with the wiring harness but if it is possible to remove the harness and set it up before you plugged in the harness to make sure everything still works, would be a good place to start to see if it is a harness issue or something that is not even related? These are just some thoughts, I am not trying to treat you like an idiot, I am just trying to break it down simple so maybe you can come up with an idea. I hate electrical work but sometimes its something so simple you overlooked.

Good luck!!

Jeremy
1999 Champagne
Bike #70151
Jabrown is offline  
post #3 of 6 Old Oct 8th, 2007, 7:53 pm Thread Starter
Member
 
GeezerBeemer66's Avatar
 
Join Date: Sep 2007
Location: Indy, IN, USA
Posts: 42
Thumbs up Problem Solved!

Like I said when I started this thread... I'M AN IDIOT!!! I know I looked at the fuse 5 different times and it wasn't blown. Lo and behold, the 6th time I looked it was blown! I put in a new fuse and BINGO! Amazing how that works, huh?! Thanks for your help. It's nice to know that there are people out there willing to help those of us with significantly lower intelligence!
GeezerBeemer66 is offline  
 
post #4 of 6 Old Oct 8th, 2007, 9:21 pm
Senior Member
 
MattKas's Avatar
 
Join Date: Apr 2004
Location: San Clemente, CA, USA
Posts: 1,185
OK. This is what I would do. Undo the hitch connections. Then check the fuses and replace if any. See if you can get back to normal. If you can then you would know if t one or more of the connections you made were wrong.

Matt Kas

13 Triumph Trophy SE Lunar Silver
12 Suzuki Burgman 650 Executive Pearl White

Laguna Niguel, Southern California (South Orange County)
"Riding Year around"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
MattKas is offline  
post #5 of 6 Old Oct 9th, 2007, 9:19 pm
Senior Member
 
Jabrown's Avatar
 
Join Date: Apr 2007
Location: Mattoon , Il, USA
Posts: 456
Quote:
Originally Posted by GeezerBeemer66
Like I said when I started this thread... I'M AN IDIOT!!! I know I looked at the fuse 5 different times and it wasn't blown. Lo and behold, the 6th time I looked it was blown! I put in a new fuse and BINGO! Amazing how that works, huh?! Thanks for your help. It's nice to know that there are people out there willing to help those of us with significantly lower intelligence!
KISS principle works again. keep it as simple as possible and there is your answer. Glad you got it figured out.

Jeremy
1999 Champagne
Bike #70151
Jabrown is offline  
post #6 of 6 Old Oct 10th, 2007, 3:10 pm
Senior Member
 
Newf's Avatar
 
Join Date: Oct 2006
Location: Ottawa, Ontario, Canada
Posts: 353
Gotta watch those electrical gremlins

Manny
Where is the nearest Tims?

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Need to stay awake

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Newf is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How many forum posters does it take to change a light bulb? brianbeemer Humor 24 Mar 26th, 2010 1:46 pm
Help w/diagnosing cruise light stays on? coug66 K1200LT 7 Sep 17th, 2007 9:05 am
brake light won't shut off Jabrown K1200LT 4 Jun 29th, 2007 10:07 pm
How many of us does it take to change a light bulb?! Bruce_Yates Humor 4 Mar 1st, 2006 8:03 am
Brake Light Switch jeffklt K1200LT 7 Nov 15th, 2005 2:24 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome