Radio Died Again - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Aug 11th, 2007, 10:37 am Thread Starter
 
Join Date: May 2007
Posts: 4
Radio Died Again

For the second time in 3,000 miles my 2004 K1200LT radio has died totally. The dealer replaced it under warranty the first time not sure if they will this time. Just wondering if this has happened to anyone else. No complaints about the dealer they have been very helpful.
comm1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Aug 11th, 2007, 10:47 am
Senior Member
 
cccpastorjack's Avatar
 
Join Date: Jul 2006
Location: Cornelius, North Carolina, USA
Posts: 1,986
Radio malfunctions on an LT????? Never heard a single complaint about that.

Now, for the serious answer. Yes, the radio/stereo system on the LT is a pain for a significant number of riders. Mostly with distortion (bad connectors). But, I have not heard that many complaints about it failing to work period. Do any of the radio/stereo features work or is the whole unit dead?

Jack Homesley
Cornelius, NC USA
'06 Goldwing - "The Black Pearl"
Too many others to list...


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


GO!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
cccpastorjack is offline  
post #3 of 5 Old Aug 11th, 2007, 11:06 am
Lifetime Supporter
 
Join Date: May 2003
Location: Phoenix, AZ, USA
Posts: 1,305
The replacement radio is covered with a factory warranty for two years. At least the replacement that was installed on my '02 in 2005 was when it went crapped out in a year and a half.

Motor On ,/'


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jkersh1 is offline  
 
post #4 of 5 Old Aug 11th, 2007, 1:03 pm Thread Starter
 
Join Date: May 2007
Posts: 4
Re:Radio Died Again

Thanks for the repllies the unit will only power up with no display and will do nothing else. I have even disconnected the battery and left it in that state for over an hour. Well hopefully I will be lucky and get the same warranty for the two year period. Have to wait and see I guess.
comm1 is offline  
post #5 of 5 Old Aug 13th, 2007, 7:14 pm
Senior Member
 
Brian-NC's Avatar
 
Join Date: Mar 2006
Location: Charlotte, NC, USA
Posts: 353
Hi Jack,
My radio system quit on me about 50 miles into a 600 mile ride to the great state of WV. Mine would act as if it was powering up then - nothing. I couldn't play CDs or the radio. I got used to the (refreshing) silence pretty quick. When I got back, the Charlotte service guy told me it was toast. Replacement was a whopping $300.00 plus. He just happened to have an old one from a crashed LT that he sold me for $100.00. I had it installed and it's been working fine. Naturally, my bike was out of warranty. I wish I knew more about electronics, I would have torn that baby apart and tried to fix it. Probably costs about 22.50 to fix, who knows..

There is a guy in Morganton NC who sells nothing but used or crash/pirated BMW parts and a lot of folks in these parts use him with good results. If yours is gone, you might want to check into the used market for one.

Good luck with that,

Brian
02 LTC silver
Charlotte
Brian-NC is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio just quit atps1234 K1200LT 62 May 29th, 2017 10:43 pm
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm
XM Radio merging with Sirius Radio Tomakazie Satellite Radio 11 Feb 21st, 2007 7:12 am
Radio Question...Searched Hall of Wisdom hybridcage K1200LT 7 Dec 4th, 2006 1:32 pm
Help needed, radio died after washing jswag13 K1200LT 4 Sep 5th, 2006 4:14 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome