Nice ride on bad roads & a comm problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Aug 8th, 2007, 8:15 pm Thread Starter
egs
 
Join Date: Jan 2007
Posts: 74
Thumbs up Nice ride on bad roads & a comm problem

Just got back from my first real trip on the LT. We had a wedding to attend in eastern OH (I'm in No. NJ) and I glibly suggested to my wife it would be a lot more fun to take the bike. To my suprise and delight she agreed so we packed light and took off.

We needed to make time so our 400 mi route out was mostly super-slab. Everything went fine except for the fact that most of PA seems to be under construction! Despite several jams and construction slow-downs we still made decent time. Never having taken that long a ride on a true touring bike was amazing! When the traffic allowed we cruised along at a true 75-80 (GPS speed). My wife even said she felt more rested than if we'd taken the car.

The return trip was a different, slightly longer route (450 mi) that included some scenic detours. Was again delighted on how the bike handled the curves even though fully loaded. Unfortunately we arrived in the Poconos just as the NASCAR race was letting out. The GPS came to the rescue again and we navigated an alternate route away from the traffic. My only complaint is that I learned first hand just how bad the stock saddle is on a longer drive. Still feeling it two days later There's definitely a pad or new seat in my future...

My other problem is that the comm system acted up and was literally screeching in our ears. I pulled the tuppeware today, cleaned all the connectors, then re-assembled things a piece at a time. The result is I found one of our IC cords if bad. It's the short, 8" section that connects the helmet mount to the coiled cord. I contacted my dealer who informed me they only sell the complete headset at a $225. I would like to know if anyone knows how to repair the cord, has one they'd sell, or knows where to buy one. I did write J&M to see if they can help. Thanks.
egs is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Aug 8th, 2007, 10:36 pm
Senior Member
 
jamesgoodchild's Avatar
 
Join Date: Jan 2003
Location: Regina, SK, Canada
Posts: 460
I replied back to your post in the classifieds for this item. J&M sells replacement parts. It is around $22.

So many toys out there, so little time!
2015 BMW K1600GTLE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2008 Piaggio 250 Betty's toy
2001 HD FLSTSI
1957 BMW R60
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

IBA #26695
RA #39456
MOA #150880

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Always looking for more...
jamesgoodchild is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mechanical Problem After a Ride hschisler K1200LT 44 Mar 26th, 2006 7:59 am
Triple BBG-Ride Report murray Ride Tales 8 Nov 20th, 2005 6:34 pm
Thanks for the nice ride on a Beautiful Day Lzyellodog North East 6 Nov 4th, 2005 9:34 pm
First long ride to SD/Badlands bossxii Ride Tales 4 Oct 6th, 2005 3:49 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome