Nav II install question- wisdom needed.. - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old May 21st, 2007, 9:50 am Thread Starter
 
Join Date: Apr 2007
Posts: 18
Nav II install question- wisdom needed..

Hi All,
I have a BMW Nav II unit I am going to install on my 2005 K1200LT. I bought the mount kit from BMW as well as the cables. I do not have any comm system on the bike. My question is this, when I remove the stingray to mount the Nav mount, where do the cable(s) attach to on the bike? I am assuming there are some empty connectors present? Also how many cables will it take? I am guessing since I have no Comm system it would just be 1 cable?? For some reason BMW dealer ordered me 2 seperate cables totalling approx $200.. I thought I just would need 1?
Let me know thoughts so I can narrow down the hunt as well as any tips. Like to have a heads up before I rip her apart & am lacking a part....

While I have it apart I am also going to add XM to the auxillary radio input on the radio (BMW Cable part #82 11 0 149 389), any thoughts where to pull switched 12V from?? (yes I have the 12V-6V hardwire adapter power cable for the XM).

Chris
Chrmer3 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Autoswitch 5NCY & PIAA Lights Install Question Safedog Lighting 10 Feb 6th, 2007 5:57 pm
HID Install Question...help!!! petevandyke Lighting 27 Feb 1st, 2007 5:09 pm
Radio Question...Searched Hall of Wisdom hybridcage K1200LT 7 Dec 4th, 2006 1:32 pm
Baehr Install Question leckhart Intercom, CB, & 2-Way Radios 2 Jul 5th, 2006 3:04 pm
New Battery install question tvolk K1200LT 5 May 19th, 2006 3:38 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome