ComSystem Problem- I need a part - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old May 10th, 2007, 1:02 pm Thread Starter
 
Join Date: May 2007
Posts: 7
ComSystem Problem- I need a part

I purchased a 2003 LT and found that the relay attached to the Power Relay Harness is misssing. I contacted my dealer, he says he can't get the part anymore, and I should contact J&M directly. I did and John L said they didn't make the harness and the dealer should be able to find one. Does anyone know what kind of relay it was or where to find one. If you have one one your bike please look under the seat and find out what brand and part number is on the relay. Thanks, Duane

Last edited by dwingnut52; May 10th, 2007 at 3:37 pm.
dwingnut52 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird electrical problem ronbok K1200LT 5 Jul 2nd, 2008 10:37 pm
Power tap for ComSystem Schweintechnik Intercom, CB, & 2-Way Radios 2 Nov 22nd, 2006 4:07 pm
ABS fault problem GBarnes K1200LT 6 May 5th, 2006 5:52 pm
Speedbleeder part# for a 2001 K1200LT cjgonzo1 K1200LT 7 Mar 8th, 2006 10:47 pm
ComSystem Owners Manual (Help); Part Numbers 1jusbill1 Intercom, CB, & 2-Way Radios 11 Mar 1st, 2006 7:55 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome