Leaking Tranny Question-need your input! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Mar 1st, 2007, 1:04 pm Thread Starter
 
Join Date: Jul 2004
Posts: 208
Question Leaking Tranny Question-need your input!

I just had a new tranny input and output seal replaced under warranty. I also had them drill the slave cylinder weep hole. The mechanic called and asked if I was using Amsoil synthetic gear oil in the tranny. I sais YES. He indicated that he thought that could "possibily" have caused the leak! What do you Gurus think?
Ron Ray
ronlray is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Mar 1st, 2007, 1:11 pm
Senior Member
 
Join Date: Sep 2003
Location: Austin, TX, USA
Posts: 878
The dealer in Austin uses synthetic lube in the transmission at least on the 12k.He also sells Amsoil lube and oil which would indicate to me that there shouldn't be any problem in using Amsoil. The only issue with synthetic oils and lubes that I have heard of has been on older vehicles.

ďRes ipsa loquitur, sed quid in infernos dicet?Ē

Alan Stuber
2003 K1200 LTC Titan Silver
Austin, Texas



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
astuber is offline  
post #3 of 4 Old Mar 1st, 2007, 2:40 pm
Senior Member
 
Steve_R's Avatar
 
Join Date: Mar 2003
Location: Snellville, GA, USA
Posts: 6,424
You didn't say how many miles were on your bike when you made the switch to Amsoil. Not being a specialist in the oil area, I believe that if you have used dino oils for a long period of time, you will more than likely have an oil leak sooner or later when switching to synthetics. I also believe if you use synthetics from the get go, you have less of a chance. Just my two bits worth.

On His Ride,
Steve
-
KA5MTE
'02 LTE - Red-blooded Dragonfly
'00 Unigo - Dragon's Egg
'01 LTC - Flying Purple People Eater (Ya gotta be old enough to understand)(RIP)
'00 LTC - Canyon Red Rover (RIP)

Have you
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwlt.com lately????



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"To not know me is to lose nothing, to not know Him is to lose everything."
Steve_R is offline  
 
post #4 of 4 Old Mar 1st, 2007, 3:13 pm Thread Starter
 
Join Date: Jul 2004
Posts: 208
Wink Tranny leak question

Steve , I changed over to synthetic at 18,000 miles ( after break-in). I presently have 31,000 miles on my 2004 LT. Thanks, Ron

Last edited by ronlray; Mar 1st, 2007 at 3:13 pm. Reason: inaccurate info
ronlray is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio input from Zumo (low tech solution) wcarter GPS 0 Jan 15th, 2007 9:54 pm
Clutch slave, Rear Main & Transm Input Tourdog K1200LT 7 Sep 17th, 2006 11:02 pm
Shift linkage question (or paging Mark Neblett to the...) kdog K1200LT 4 Apr 22nd, 2006 9:17 pm
Luggage Input / Question TouringProf K1200LT 9 Apr 8th, 2006 3:11 pm
Question for MyFi XM Radio users??? Portguyofva Satellite Radio 4 Mar 9th, 2006 8:46 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome