power centre stand help - BMW Luxury Touring Community
 1Likes
  • 1 Post By alabrew
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jun 23rd, 2019, 6:10 pm Thread Starter
Senior Member
 
Join Date: Sep 2003
Location: Victoria, BC, CANADA
Posts: 182
power centre stand help

Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
dodgeman88 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jun 23rd, 2019, 8:27 pm
Senior Member
 
mr1150gs's Avatar
 
Join Date: Feb 2005
Posts: 269
Re: power centre stand help

Quote:
Originally Posted by dodgeman88 View Post
Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
I would Suspect the battery strength as you do not have much time and would put it on a charger over night. Hopefully this would address your issue or at least see if there is any further time needed before confidently taking the LT out on such a long ride.

"If at first you don't succeed... well, so much for skydiving."

BMWMOA - #47511
2015 F700GS - For my better half whenever I'm not using it!
2007 K1200LT - Nice now!
2003 R1150GS -Black Beauty (sold)
2006 K1200LT - Blue Baby (sold)
2003 R1150GS - Yellowbird (sold)
1981 R100CS - Sadly gone
1991 K1100RS - Sold and burned
1986 K100RS - In the past
mr1150gs is online now  
post #3 of 5 Old Jun 23rd, 2019, 9:12 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,899
Re: power centre stand help

Quote:
Originally Posted by dodgeman88 View Post
Hi all
as always looking for your help

When I try to use the electric centre stand on my2005 k1200lt, I get a low voltage warning on the dash and so it does not deploy,
done the obvious, cleaned battery connections checked grounds, etc, light comes on but flashes fast
anyone know where relay is located? cruise quit at same time, I can not find any relationship on wiring diagrams
anyone had a similar problems
Help needed, leaving on 4000 km trip 6 am tomorrow
Sounds like you need to invest in a new battery before you leave.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
 
post #4 of 5 Old Jun 29th, 2019, 10:09 am
Junior Member
 
Join Date: Mar 2017
Posts: 7
Re: power centre stand help

Hi I have a 07 LT. Centre stand deploys, but doesnt fully retract when I rock her off it! Means side stand out, dismount and ease up with foot before setting off. Do I need to remove, dismantle and play with it, or is it a replacement part that needs fitting? (Not a great tech head as you can tell!)

Sent from my SM-N960F using Tapatalk
DaveIves is offline  
post #5 of 5 Old Jun 29th, 2019, 1:04 pm
Senior Member
 
Join Date: Jul 2002
Location: Pelham, AL, United States
Posts: 517
Re: power centre stand help

Dave, I would lube the pivot points first before I took it apart. Should just use a spring or two to bring it up.
DaveIves likes this.

_____________

Kim Thomson
Motorcycle Cigar Smoker
05 K1200LT - The Golden Rocket Ship
91 K100RS - The White Stallion
85 K100 Standard - Big Red
79 R65 - "The Bee" is a buzzin' again!
06 525i - Premium, Sport, Comfort, Xenons

Gone, but not forgotten...
02 K1200LTC - Big Blue (accident at 40k)
88 K100RT - Chocolate (it was brown, melted - fire)
85 K100RT - (wore out)
82 Yamaha Vision - (electrics)
72 Yamaha R5C 350 - (broke trans)
alabrew is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome