Left side speakers not working. - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jun 23rd, 2019, 5:17 am Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 4
Left side speakers not working.

I am a total Newby to this bike and group, coming from a GSA. I love my bike and it is a 2007 with on 40000 on the clock. This weekend I installed a Ice link on the radio, but after assembly found that the left side speakers is not playing. Any ideas where I can start looking?

Sent from my SM-N960F using Tapatalk
KAMPNEL is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jun 23rd, 2019, 9:25 am
Senior Member
 
rspyder's Avatar
 
Join Date: Jul 2002
Location: El Dorado Hills, CA, USA
Posts: 696
Re: Left side speakers not working.

I found my ICE-link to be a total waste of money. Never worked properly out of the box. Customer service was terrible as they wanted shipping and repair cost if you sent it back and wouldn't guarantee it would work when returned. Never bothered to return the unit.

Current
2016 Yamaha FJR1300A (Cobalt Blue)
1973 Honda CL350 (Red)

Previous
2001 K1200LT Pacific Blue
and a long list...
rspyder is offline  
post #3 of 4 Old Jun 23rd, 2019, 10:53 am Thread Starter
Junior Member
 
Join Date: Jun 2019
Posts: 4
Re: Left side speakers not working.

I must say,, mine is working beautifully.

Sent from my SM-N960F using Tapatalk
KAMPNEL is offline  
 
post #4 of 4 Old Jun 23rd, 2019, 12:14 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,071
Re: Left side speakers not working.

If you have already adjusted the side to side balance and no joy then the left side amp chip has failed. Common issue with these radios. But on of the members here replaces the stock chips with a nice little board that uses more powerful and robust chips. He also has a BT module he can install.
"chrischenusa" is his user name (in the US, or go with "Baris" in the UK).

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by jzeiler; Jun 23rd, 2019 at 12:21 pm.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome