4 Way Flasher / Hazard Lights stuck on! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Jun 22nd, 2019, 5:06 am Thread Starter
Member
 
CameronM's Avatar
 
Join Date: Nov 2013
Location: Hexham, Northumberland, UK
Posts: 49
4 Way Flasher / Hazard Lights stuck on!

Hoping someone can help (I couldn’t find a clear answer anywhere in the forum).... turned the ignition on my 2004 LT today and hazard lights came on. Figured I must have hit the switch when I parked up, but cannot get them to turn off except by disconnecting the battery. Here's my efforts so far with a minimum of tools and knowledge other than being able to do an oil change!....

The hazard switch lights up with the ignition on and goes off with the ignition off which is normal.

With ignition on and hazards on they flash normally, when switched to off the indicators flash slightly irregularly sometimes with the lights remain on slightly longer than normal - so I'm figuring that's when the switch is toggled to the off position as you can’t tell from the position or feel of the switch.

The hazard switch not longer illuminated when ignition off bit lights continue to flash.

I removed every fuse in sequence from the three fuse boxes under the pillion seat but this did not stop the flashing.

I removed the switch cluster partially from the handlebar hoping to dismantle the switch and perhaps remove the hazard switch or interrupt the circuit to the switch but the rear part seems fixed at the indicator paddle part and I can only slightly open it up at the top and can’t see inside the unit properly... so stopped before I forced anything and broke something. A couple of threads say to spray some electrical lubricant into the switch but I need to buy some and do that if people think that’s right and thought that if I'm driving into town (in the car!) for that I should perhaps seek confirmation first and also pick up anything else you might recommend or perhaps try some other kind of fix if someone out there knows of one.

The only other relevant things might be:

I've had the bike for 5 years and never had this fault before.... 47,000 miles on the clock 37,000 of them are mine over the time I've had the bike.

The ABS was successfully removed and bypassed by a local motorcycle mechanic (non BMW) after it malfunctioned just after I brought the bike (grrrrrrrr!!) following the advice from very helpful folk on this forum.

The alarm (15 years old) gave up as the internal battery 'died' 2 months ago and I brought a plug and play replacement which has operated fine for 1 month till I went on holiday (not thinking that might be the problem but worth a mention?)

The bike gets used most days BUT was parked up for a month until yesterday as I've been away on holiday. I rode out on the bike for 2 hours yesterday with a few stops ignition off/on and no problems. As the bike was parked up for so long I checked all the lights and switches (including the hazard switch!) tyre pressures etc before I went out so I know they worked OK at that point.

Thanks in advance for helping me out,

Cameron

K1200LT lux 2004, UK
CameronM is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Jun 22nd, 2019, 4:05 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,077
Re: 4 Way Flasher / Hazard Lights stuck on!

It could very well be the alarm since it does send a signal to the flasher at the same point the handle bar switch does. Quick way to find out is to access the alarm 12 pin connector (circled in red) and snip the Yellow Violet wire on pin 4 and see if the flashers stop flashing. If they don't then it may be the switch on the bars or the flasher unit itself.
Attached Thumbnails
Click image for larger version

Name:	alarm location.jpg
Views:	10
Size:	130.1 KB
ID:	152787  

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by jzeiler; Jun 24th, 2019 at 8:52 pm.
jzeiler is offline  
post #3 of 3 Old Jun 24th, 2019, 11:25 am Thread Starter
Member
 
CameronM's Avatar
 
Join Date: Nov 2013
Location: Hexham, Northumberland, UK
Posts: 49
Re: 4 Way Flasher / Hazard Lights stuck on!

Thanks - I can now report problem solved without snipping wires. Used electrical connector cleaner on switch while also putting battery on charge again for longer and problem rectified itself.

I am thinking that perhaps because the bike stood for a month and the battery was only charged for a couple of hours before I took it out that it may have not been sufficiently charged the next day when I switched her on and she went all hazardous on me. I read somewhere on the various threads that a low charge can cause electrical gremlins. Will now see if battery holds charge as it may be a sign I need a new one - current one (pun intended!) in 5.5 years old. Will check threads for best battery option if a replacement is required.

K1200LT lux 2004, UK
CameronM is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome