Electrical issue after rear seal replacement. - BMW Luxury Touring Community
 3Likes
  • 1 Post By jzeiler
  • 2 Post By Voyager
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Mar 17th, 2019, 12:20 pm Thread Starter
Junior Member
 
Ftreno's Avatar
 
Join Date: Jul 2018
Posts: 6
Electrical issue after rear seal replacement.

Picked up after rear seal replacement and being in shop several weeks. Battery dead. No big deal. Jumped it then drove home and put on charger. Now Won’t start and makes bad whirring crackling electrical noise briefly then just constant buzz. Thoughts?
Ftreno is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Mar 17th, 2019, 5:06 pm
Senior Member
 
Join Date: Dec 2017
Location: Brisbane Australia
Posts: 222
Re: Electrical issue after rear seal replacement.

The battery may have died because they pinched some wiring while doing the seal replacement which would probably require them to drop the back of the engine. When they put it back together they may have shorted out some wiring that has in turn drained the battery. The crackling electric noise you are hearing could be that short to ground. I would be pulling all the plastic off and having a good look.
Wazza is offline  
post #3 of 6 Old Mar 17th, 2019, 5:45 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,071
Re: Electrical issue after rear seal replacement.

Most of the inspection can be done under the seat. But judging on the fact that you go a jump and the bike started OK and drove OK. Then I would believe the battery is shot. You said put on charger, was it a charger or a battery tender? I would try a true charger that is capable of 2-6 amps to try and revive the battery. There is a circuit in the starter system that prevents it from engaging if the battery is low. Charge it and then let it sit a day and measure the battery terminals, should be at least 12.6.
beech likes this.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 6 Old Mar 17th, 2019, 9:27 pm
Member
 
Join Date: Jan 2019
Posts: 59
Garage
Re: Electrical issue after rear seal replacement.

Quote:
Originally Posted by Ftreno View Post
Picked up after rear seal replacement and being in shop several weeks. Battery dead. =
Have them come get it. If they caused the problem they need to take care of it. Any reputable shop will take care of it.

2002 BMW K1200LT 57k (new to me 1-20-19)
1971 BMW R60/5 27k (father-in-law was original owner)
1972 & 1973 Honda Trail 70s
1971 Honda XL175 (grandfather was original owner)
1997 Ducati 748 Sold
2000 Ducati 996 7k
2001 Ducati Monster 800 Sold
2008 Ducati Monster 696 Sold
1997 Honda CBR600 Sold
1973 Suzuki GT550 (2 stroke!) Sold
1973 Honda CB500 Sold
krazzz is offline  
post #5 of 6 Old Mar 17th, 2019, 9:52 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,898
Re: Electrical issue after rear seal replacement.

Quote:
Originally Posted by krazzz View Post
Have them come get it. If they caused the problem they need to take care of it. Any reputable shop will take care of it.
A reputable shop would not have let a customer pick up a bike with a dead battery that had to be jumped.
ibbones and krazzz like this.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is online now  
post #6 of 6 Old Mar 22nd, 2019, 4:39 pm Thread Starter
Junior Member
 
Ftreno's Avatar
 
Join Date: Jul 2018
Posts: 6
Installed Odyssey Supreme PC680 MJ battery. All is Good!!!
Ftreno is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Final Drive Seal Replacement & Fuel Strip DCR1200RT RT Series 13 Sep 28th, 2013 4:30 pm
Rear brake stuck/ not fully releasing joseph_p K1200LT 16 Aug 28th, 2013 6:38 pm
rear seal leak, search chanllanged ebear695 K1200LT 2 Dec 24th, 2012 9:11 pm
Tight Valve and rear seal leaking on 05 LT WillieC K1200LT 6 Jul 3rd, 2012 11:43 am
Replacement of rear shock suspension unit PhillWard Australia, New Zealand, and AsiaPac 3 Jan 17th, 2006 5:01 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome