Speedometer Jumpy - BMW Luxury Touring Community
 3Likes
  • 2 Post By mtrevelino
  • 1 Post By Dick
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Apr 21st, 2018, 8:18 pm Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 4
Speedometer Jumpy

I have a '99 K1200LT and right before winter the speedometer stopped working correctly. It started jumping around at steady speeds. Can anyone tell me what might be the problem and how I might remedy it?
elleryw is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old Apr 21st, 2018, 9:00 pm
Senior Member
 
mtrevelino's Avatar
 
Join Date: Apr 2002
Location: Williamsburg, VA, USA
Posts: 2,552
Re: Speedometer Jumpy

It sounds like a broken wire by the rear wheels speed sensor. It was a common failure on the early model LT’s. It most likely broke by the wire clamp. I am not on my pc so I cannot provide a picture.
Munmi and elleryw like this.

Mike Trevelino
Williamsburg, VA
2008 RT
2000 LT - Totaled at 99,960 miles


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
mtrevelino is offline  
post #3 of 9 Old Apr 21st, 2018, 9:05 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Speedometer Jumpy

Quote:
Originally Posted by elleryw View Post
I have a '99 K1200LT and right before winter the speedometer stopped working correctly. It started jumping around at steady speeds. Can anyone tell me what might be the problem and how I might remedy it?
HTH. Click on the *Technical* drop down item, then click on troubleshooting, then electrical system, then on erratic speedo fix. When there, click on 'Dave Shealey' and that'll pull up the easy fix to a well known early year issue. Good luck.
elleryw likes this.
Dick is offline  
 
post #4 of 9 Old Apr 25th, 2018, 3:44 pm Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 4
Re: Speedometer Jumpy

Thanks for the tip. I will check that out at the first opportunity.
elleryw is offline  
post #5 of 9 Old May 17th, 2018, 10:30 pm Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 4
Thanks for the tip. However I checked the speed sensor wire for possible breaks but couldn’t detect any, so I decided to replace it with a new one. Now the speedo doesn’t jump, but only goes to about 25 mph. The odometer seems to still work though. Any other suggestions?
elleryw is offline  
post #6 of 9 Old May 18th, 2018, 8:11 am
Senior Member
 
Scouter-50's Avatar
 
Join Date: Apr 2012
Location: Columbus, Texas, USA
Posts: 1,286
Re: Speedometer Jumpy

Pull the sensor back out and see if the slotted ring in the final drive that she sensor reads has come loose in the final drive.

They that can give up essential liberty to obtain a little temporary safety deserve neither liberty nor safety.
Benjamin Franklin (1706 - 1790)


2000 K1200LT "Latifah"
1994 R1100RSL (wife's)
1981 R80GS
1976 R90S
1965 R80/2 Frankenbike (wife's)
2001 Bunkhouse LX (given to son)
2011 Bunkhouse Queen

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Scouter-50 is offline  
post #7 of 9 Old May 18th, 2018, 8:53 am
Senior Member
 
bmwcoolk1200's Avatar
 
Join Date: Feb 2015
Posts: 3,995
Re: Speedometer Jumpy

Quote:
Originally Posted by Scouter-50 View Post
Pull the sensor back out and see if the slotted ring in the final drive that she sensor reads has come loose in the final drive.
I was thinking the same thing, or at least to check it. As Scouter-50 said, remove the sensor and look down in from the top to see if this ring is still attached. you may need a good light and a mirror but you should be able to see if it has come loose. The attached pictures are what you are looking through and what you are looking at. This one is still attached.
Attached Thumbnails
Click image for larger version

Name:	DSC_0015A.jpg
Views:	53
Size:	409.5 KB
ID:	144569   Click image for larger version

Name:	DSC_0025A.jpg
Views:	53
Size:	583.2 KB
ID:	144577  

Gordon
Sugar Hill, GA
2001 K1200LTI – Champagne (current ride) Lazy Susan
1998 R1100RT – Never should have sold it
1974 Yamaha TX 750 Twin. Omni Phase Balanced


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
bmwcoolk1200 is offline  
post #8 of 9 Old May 18th, 2018, 12:00 pm Thread Starter
Junior Member
 
Join Date: Apr 2018
Posts: 4
Re: Speedometer Jumpy

Thanks for the tip. I'll give it a look. Not sure what to do if it has moved, though. If you know of a tech link on how to repair if needed, I would appreciate it. Thanks again guys.
elleryw is offline  
post #9 of 9 Old May 18th, 2018, 12:05 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,263
Re: Speedometer Jumpy

Look over the procedure listed here . If the ring is loose you can safely open up the drive on the bike and clean the area and loctite the ring in place, then re-assemble the drive.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer Is Off by 5 to 10 fast 00K1200LT K1200LT 17 Sep 10th, 2017 8:29 am
Tach and speedometer spiking - 2005 KLT HammerStar K1200LT 3 Dec 5th, 2012 12:53 pm
Speedometer - Electric or Mechanical LTFan K1200LT 6 Jun 9th, 2012 11:08 pm
Low speedometer reading Ride2Ski K1200LT 14 Apr 26th, 2010 10:24 am
Speedometer Issue Beamer007 K1200LT 3 Aug 17th, 2009 3:57 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome