Radio Sound Problem ( Becker ) - BMW Luxury Touring Community
 6Likes
  • 1 Post By chrischenusa
  • 1 Post By james216
  • 1 Post By chrischenusa
  • 1 Post By Voyager
  • 1 Post By leshenits215
  • 1 Post By MH60PIC
 
LinkBack Thread Tools Display Modes
post #1 of 49 Old Apr 11th, 2018, 7:52 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Arrow Radio Sound Problem ( Becker )

I can fix the radio for you

The most common problem encountered with the BMW K1200LT radio, is the Integrated Circuit Amplifiers failure that causes one or more speaker to stop functioning, or fading.
This could happen permanently, or after few seconds.
The number of speakers that goes off is random.
If it's what you are encountering, this is fully fixable, and the method consists of taking the original amplifiers off the radio motherboard, and installing my custom 4x35W - 4x40w maxi amplifier module.
Note that the original output power is 15-20W, after the repair, you are running 35W-40W.
The CD player stays in the radio after repair.

I am fixing these radio since 2012, and I'm pretty comfortable doing that work.

Options are also available
Bluetooth device
Cable (type Jack 3.5mm - 1/8-inch) for Cellphone, Mp3 player, or Ipod

Feel free to contact me if you have any question.

[email protected]

Have a good day

Chris
Attached Thumbnails
Click image for larger version

Name:	IMG_0008.JPG
Views:	364
Size:	123.3 KB
ID:	142602   Click image for larger version

Name:	BMW Professional 2000.jpg
Views:	334
Size:	79.0 KB
ID:	142610   Click image for larger version

Name:	Becker fix K1200LT.jpg
Views:	312
Size:	227.7 KB
ID:	142618  
ddowney likes this.

Last edited by chrischenusa; Apr 12th, 2018 at 5:50 pm.
chrischenusa is offline  
Sponsored Links
Advertisement
 
post #2 of 49 Old Apr 12th, 2018, 7:02 am
Senior Member
 
james216's Avatar
 
Join Date: Jan 2013
Location: Garfield Hts, Ohio, USA
Posts: 1,341
Re: Radio Sound Problem ( Becker )

Wished i would have known 5 years ago when i had to send mine to carphonics in the UK. He did a great job. But like i said. He's in England. But. Great to know you fix these, should i need radio work done again.
chrischenusa likes this.

2004 K1200LT. Big Mama
1999 Suzuki Intruder VL1500LC. Betty Lou.
I'm a 4 percenter.
james216 is offline  
post #3 of 49 Old Apr 12th, 2018, 7:29 am
Senior Member
 
Join Date: Dec 2017
Location: Brisbane Australia
Posts: 204
Re: Radio Sound Problem ( Becker )

I have an 05 LT and my right front and left rear speakers have stopped working. I live in Australia, do you accept jobs from overseas?
Wazza is offline  
 
post #4 of 49 Old Apr 12th, 2018, 2:07 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Thumbs up Re: Radio Sound Problem ( Becker )

Hi, Yes I do the repair for anyone who need it, it will cost you a little bit more because of the shipping cost.
Please email me to [email protected] .
I will let you know how much the repair will cost you.
Have a great day
ddowney likes this.

Last edited by chrischenusa; Apr 13th, 2018 at 7:10 am.
chrischenusa is offline  
post #5 of 49 Old Apr 12th, 2018, 2:07 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Hi, It would have been a pleasure! I tried years ago to contact the UK guy who fix the radio too, but he unfortunately he never answered.
But I heard that he is doing a good job.
Have a great day!
chrischenusa is offline  
post #6 of 49 Old Apr 13th, 2018, 1:19 am
Junior Member
 
Join Date: Oct 2013
Location: Rustenburg, Northwest Province, South Africa
Posts: 10
Re: Radio Sound Problem ( Becker )

I have an 05 LT and my right front and left rear speakers have stopped working. I live in South Africa, do you accept jobs from Africa?
RUSTY is offline  
post #7 of 49 Old Apr 13th, 2018, 7:09 am Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Hi, Yes I do the repair for anyone who need it, it will cost you a little bit more because of the shipping cost.
Please email me to [email protected] .
I will let you know how much the repair will cost you.
Have a great day
chrischenusa is offline  
post #8 of 49 Old Apr 13th, 2018, 8:38 am
Senior Member
 
Join Date: Dec 2017
Location: Brisbane Australia
Posts: 204
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by RUSTY View Post
I have an 05 LT and my right front and left rear speakers have stopped working. I live in South Africa, do you accept jobs from Africa?
That's exactly what I just wrote except I live in Australia. What is it with 05 LT's and right front left rear failure.
Wazza is offline  
post #9 of 49 Old Apr 13th, 2018, 8:40 am
Senior Member
 
Join Date: Dec 2017
Location: Brisbane Australia
Posts: 204
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
Hi, Yes I do the repair for anyone who need it, it will cost you a little bit more because of the shipping cost.
Please email me to [email protected] .
I will let you know how much the repair will cost you.
Have a great day
So ball park figure. excluding any shipping costs what is your average charge for this repair and what kind of turn around time on average are we looking at.
Wazza is offline  
post #10 of 49 Old Apr 13th, 2018, 3:09 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Wazza View Post
So ball park figure. excluding any shipping costs what is your average charge for this repair and what kind of turn around time on average are we looking at.
Please go to My garage, you will find the infos you need.
Tkx
Chris

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by chrischenusa; Apr 13th, 2018 at 4:41 pm.
chrischenusa is offline  
post #11 of 49 Old Apr 15th, 2018, 6:23 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by james216 View Post
Wished i would have known 5 years ago when i had to send mine to carphonics in the UK. He did a great job. But like i said. He's in England. But. Great to know you fix these, should i need radio work done again.
Baris was his name! The UK guy! the cost of his work matches mine, but the Bluetooth or mp3 cable option cost much more!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #12 of 49 Old Apr 16th, 2018, 8:48 am
Senior Member
 
james216's Avatar
 
Join Date: Jan 2013
Location: Garfield Hts, Ohio, USA
Posts: 1,341
Re: Radio Sound Problem ( Becker )

Yep. Baris i know. Well. Great to know your the option stateside.

2004 K1200LT. Big Mama
1999 Suzuki Intruder VL1500LC. Betty Lou.
I'm a 4 percenter.
james216 is offline  
post #13 of 49 Old Apr 16th, 2018, 1:45 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by james216 View Post
Yep. Baris i know. Well. Great to know your the option stateside.
I have a question for you, I see you are a Senior member, what did you do for that? I joined the site in 2012 and still a junior member! not a big deal I know, but I'm just curious...

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #14 of 49 Old Apr 16th, 2018, 3:00 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,780
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
I have a question for you, I see you are a Senior member, what did you do for that? I joined the site in 2012 and still a junior member! not a big deal I know, but I'm just curious...
I think it is based on post count.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
post #15 of 49 Old Apr 16th, 2018, 4:23 pm
Senior Member
 
Join Date: Dec 2017
Location: Brisbane Australia
Posts: 204
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
I have a question for you, I see you are a Senior member, what did you do for that? I joined the site in 2012 and still a junior member! not a big deal I know, but I'm just curious...
It looks like you are now a member, must be post count.
Wazza is offline  
post #16 of 49 Old Apr 16th, 2018, 8:16 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Voyager View Post
I think it is based on post count.
Oh, Ok...I thought at 55 years old, I could have been a Senior member! L

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #17 of 49 Old Apr 16th, 2018, 8:21 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Wazza View Post
It looks like you are now a member, must be post count.
Yes I see that, just a coincidence, I talk about this a I got a new rank! I was Junior yesterday!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #18 of 49 Old Apr 17th, 2018, 12:24 pm
Senior Member
 
james216's Avatar
 
Join Date: Jan 2013
Location: Garfield Hts, Ohio, USA
Posts: 1,341
Re: Radio Sound Problem ( Becker )

Gotta agree with Voyager. Gotta be post count. I didn't do anything for senior membership.

2004 K1200LT. Big Mama
1999 Suzuki Intruder VL1500LC. Betty Lou.
I'm a 4 percenter.
james216 is offline  
post #19 of 49 Old Apr 17th, 2018, 1:35 pm
Senior Member
 
gorm5's Avatar
 
Join Date: Mar 2016
Posts: 171
Re: Radio Sound Problem ( Becker )

Add me to the list of 05's with speaker issues. Both of my fronts and 1 rear are out. I figured I would just have to always wear a helmet to listen to music. I will be emailing you today to see if it's worth fixing.

Patrick Russell
I live and ride in Illinois, which has some of the straightest roads in the country.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


1984 Bluish Honda CB 650 (retired)
1986 Red Honda Nighthawk 450 (abandoned)
Didn't own a bike from 1999 to 2012
1997 Black Honda Valkyrie (still own)
2005 Ocean Blue BMW K1200LT "Apocalypse" (bought in March '16)

IBA Saddlesore 1000

Bucket List destinations:
Sturgis (maybe)
Nova Scotia
Pacific Coast highway
gorm5 is offline  
post #20 of 49 Old Apr 18th, 2018, 7:49 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Thumbs up Re: Radio Sound Problem ( BMW Professional 2000 ) Becker

Fairing removal:
Radio removal:

Last edited by chrischenusa; Apr 18th, 2018 at 7:55 pm.
chrischenusa is offline  
post #21 of 49 Old Apr 28th, 2018, 7:35 pm
Member
 
Join Date: Dec 2017
Posts: 56
Garage
Re: Radio Sound Problem ( Becker )

I had Chris repair my radio and it is road tested and works great! Price was reasonable, turnaround was quick, and it is better than new. I highly recommend Chris to repair your radio if it is acting up.

George

2004 K1200LT - Gray Ghost
longride is offline  
post #22 of 49 Old Apr 29th, 2018, 6:31 am
Junior Member
 
Join Date: May 2017
Posts: 11
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by longride View Post
I had Chris repair my radio and it is road tested and works great! Price was reasonable, turnaround was quick, and it is better than new. I highly recommend Chris to repair your radio if it is acting up.


So is this Becker auto sound out of New Jersey? I am pulling my radio today and would like to know.


Sent from my iPhone using Tapatalk
Larry Barto is offline  
post #23 of 49 Old Apr 29th, 2018, 8:20 am
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,015
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Larry Barto View Post
So is this Becker auto sound out of New Jersey? I am pulling my radio today and would like to know.


Sent from my iPhone using Tapatalk
No this a guy in FL and he puts in an amp better than what Becker would do. Becker would sell you a new board for $400 and then you would have the same radio that would fail again down the road. Look at his "garage" link in his post at the top.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #24 of 49 Old Apr 29th, 2018, 8:54 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by longride View Post
I had Chris repair my radio and it is road tested and works great! Price was reasonable, turnaround was quick, and it is better than new. I highly recommend Chris to repair your radio if it is acting up.
Thanks, I'm glad you are happy with the upgrade!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #25 of 49 Old May 13th, 2018, 3:33 pm
Junior Member
 
Join Date: Apr 2018
Posts: 1
Re: Radio Sound Problem ( Becker )

Hi Chris, I please need information about your radio repair.
ddowney is offline  
post #26 of 49 Old May 14th, 2018, 12:08 pm
Junior Member
 
Join Date: May 2018
Posts: 4
Re: Radio Sound Problem ( Becker )

I have an 01 and surprisingly all the speakers work just fine loud as can be but the sound quality is the worst (just noise). Any ideas on how to get some sound separation (hi and lows) bass and treble out of the factory system?
Realridda is offline  
post #27 of 49 Old May 17th, 2018, 11:42 am
Junior Member
 
Join Date: Jul 2015
Posts: 1
Re: Radio Sound Problem ( Becker )

I was loosing one speaker in my 2003 LT and found this post . I sent my radio off to Chris and told him if possible I needed it back for a trip in June . He received it on a friday and must have worked on it over the weekend because on sunday night I got and email that it was done and shipped . I got it on Wed and put it and man what a difference. I looked at his work and it is amazing . The sound is better then before and it looks like this is going to last a long time . DO not hesitate to contact Chris and get your radio fixed A++++++++++++++++++++++from me on this : smile:
skidoosnopro is offline  
post #28 of 49 Old May 17th, 2018, 1:07 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by skidoosnopro View Post
I was loosing one speaker in my 2003 LT and found this post . I sent my radio off to Chris and told him if possible I needed it back for a trip in June . He received it on a friday and must have worked on it over the weekend because on sunday night I got and email that it was done and shipped . I got it on Wed and put it and man what a difference. I looked at his work and it is amazing . The sound is better then before and it looks like this is going to last a long time . DO not hesitate to contact Chris and get your radio fixed A++++++++++++++++++++++from me on this : smile:
Yes it should last forever! Enjoy your upgraded radio!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #29 of 49 Old May 17th, 2018, 1:15 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Realridda View Post
I have an 01 and surprisingly all the speakers work just fine loud as can be but the sound quality is the worst (just noise). Any ideas on how to get some sound separation (hi and lows) bass and treble out of the factory system?
Hard to answer to this really, The sound is bad you say, but is that sound like statics only or you may hear the radio or CD sound still?

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #30 of 49 Old May 17th, 2018, 2:12 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,780
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
Yes it should last forever! Enjoy your upgraded radio!
Forever is a very long time.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
post #31 of 49 Old May 17th, 2018, 2:38 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Voyager View Post
Forever is a very long time.
Yes Sir, My life time warranty on my repair! LOL

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #32 of 49 Old May 17th, 2018, 2:54 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,780
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
Yes Sir, My life time warranty on my repair! LOL
What is your secret to living forever. Please let us in on it!

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
post #33 of 49 Old May 17th, 2018, 6:53 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Voyager View Post
What is your secret to living forever. Please let us in on it!

I should have said... the rest of my life... that makes it shorter, but it's all right!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #34 of 49 Old May 17th, 2018, 8:06 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,780
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
I should have said... the rest of my life... that makes it shorter, but it's all right!
Bummer! I thought you had found the fountain of youth and might let us in on it.
chrischenusa likes this.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
post #35 of 49 Old May 20th, 2018, 8:46 am
Junior Member
 
Join Date: Oct 2005
Location: Lincoln, NE, USA
Posts: 14
Re: Radio Sound Problem ( Becker )

Years back I had Becker Auto Sound repair my '00 LT radio. I had already moved to a Starcom system to get my audio into my Nolan helmet. Since then I've migrated to the N-Com system and attempted to use the Starcom bluetooth adapter without success. Currently I have a FM transmitter connected to the bike and listen to the audio via the N-Com built-in FM radio. I'm very interested in the bluetooth addition to the bike's radio. What Bluetooth standard is your adapter? Has it been tested with the Nolan N-Com B4 system?

I'm also looking at moving up to the new Nolan 100-5 and the N-Com B901 later this year. the B901 advertises that it has Bluetooth 4.1 + EDR, class 2. Would your bluetooth adapter be compatible with this newer standard?

(Sorry for the specific questions but I've already spent $$$$ on technology that doesn't work)
djb

2000 K1200lt, 1977 R100/7, 1977 RS, 1974 R90/6, 1978 SR500 (Thumper)
BMW 400,000 Mile Award

Last edited by Bruners4; May 20th, 2018 at 9:08 am.
Bruners4 is offline  
post #36 of 49 Old May 23rd, 2018, 7:56 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Voyager View Post
Forever is a very long time.
[SIZE="7"][SIZE="7"][SIZE="6"]
Hi, I have a question for you...I'm asking you, as you are a member for a long time and also a paid subscriber.
I also paid the Premium member fee but nothing really changed after that, I don't even see my avatar changed, I wrote to the webmaster about this and other things, but I didn't receive any answers, do you know if there is somebody who still takes care of this site? Tku+

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #37 of 49 Old May 23rd, 2018, 9:35 pm
Lifetime Supporter
 
Voyager's Avatar
 
Join Date: Jun 2007
Location: Lawrenceville, PA, USA
Posts: 6,780
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by chrischenusa View Post
[SIZE="7"][SIZE="7"][SIZE="6"]
Hi, I have a question for you...I'm asking you, as you are a member for a long time and also a paid subscriber.
I also paid the Premium member fee but nothing really changed after that, I don't even see my avatar changed, I wrote to the webmaster about this and other things, but I didn't receive any answers, do you know if there is somebody who still takes care of this site? Tku+
I am not sure. I paid for the membership for a couple of reasons:

1. I have benefitted immensely from the advice from many members here and

2. I use a 5 year old iPad mini and the ads kept crashing Safari.

I really didn't look for any other changes. Getting rid of the ads was the big win for me.

2017 KLR650 "Mule"
2007 K1200LT "Starship Enterprise", VOICE II, Navigator V, Motorrad Communicator
1987 Kawasaki Voyager XII
1976 Kawasaki KH400
1973 Kawasaki 100 G5
1970 Rockford Chibi (the orange one)

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Voyager is offline  
post #38 of 49 Old May 24th, 2018, 9:37 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Voyager View Post
I am not sure. I paid for the membership for a couple of reasons:

1. I have benefitted immensely from the advice from many members here and

2. I use a 5 year old iPad mini and the ads kept crashing Safari.

I really didn't look for any other changes. Getting rid of the ads was the big win for me.
Ok Thank you!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #39 of 49 Old May 24th, 2018, 9:39 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Bruners4 View Post
Years back I had Becker Auto Sound repair my '00 LT radio. I had already moved to a Starcom system to get my audio into my Nolan helmet. Since then I've migrated to the N-Com system and attempted to use the Starcom bluetooth adapter without success. Currently I have a FM transmitter connected to the bike and listen to the audio via the N-Com built-in FM radio. I'm very interested in the bluetooth addition to the bike's radio. What Bluetooth standard is your adapter? Has it been tested with the Nolan N-Com B4 system?

I'm also looking at moving up to the new Nolan 100-5 and the N-Com B901 later this year. the B901 advertises that it has Bluetooth 4.1 + EDR, class 2. Would your bluetooth adapter be compatible with this newer standard?

(Sorry for the specific questions but I've already spent $$$$ on technology that doesn't work)
djb
Hi, The only thing I do is to add a Bluetooth device on the AUX of the original Becker radio, and repair the Amp problem.

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #40 of 49 Old Aug 3rd, 2018, 7:58 pm
Member
 
leshenits215's Avatar
 
Join Date: Nov 2004
Location: Stroudsburg, PA, USA
Posts: 48
Re: Radio Sound Problem ( Becker ) Fixed by Chris

My 06' LT radio crapped out last year, so I finally sent it to Chris in Florida last week. He worked on it the same day, and I got it back today. Installed it and it works now perfectly. With increased power = double the wattage - and everything works on it. Better than new. I HIGHLY RECOMMEND CHRIS CHENDARD. He did everything as promised, kept me informed by email and was good on his word. I am thrilled. Now I just have put the tupperware back and start enjoying music again. The problem with mine was the common problem - the amps!
chrischenusa likes this.
leshenits215 is offline  
post #41 of 49 Old Aug 4th, 2018, 6:33 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Thumbs up Re: Radio Sound Problem ( Becker ) Fixed by Chris

Quote:
Originally Posted by leshenits215 View Post
My 06' LT radio crapped out last year, so I finally sent it to Chris in Florida last week. He worked on it the same day, and I got it back today. Installed it and it works now perfectly. With increased power = double the wattage - and everything works on it. Better than new. I HIGHLY RECOMMEND CHRIS CHENDARD. He did everything as promised, kept me informed by email and was good on his word. I am thrilled. Now I just have put the tupperware back and start enjoying music again. The problem with mine was the common problem - the amps!
Tku Les, appreciate it!

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by chrischenusa; Aug 4th, 2018 at 8:35 pm.
chrischenusa is offline  
post #42 of 49 Old Aug 4th, 2018, 8:28 pm
Junior Member
 
Join Date: Jun 2008
Location: Savannah, GA, USA
Posts: 9
Re: Radio Sound Problem ( Becker )

I just had my radio repaired by Chris as well and I cannot recommend him highly enough. The entire process took one week! I had been without a radio for a year because I assumed it was a difficult wiring problem and now the radio works better than new. I took the bike out today and it was just like old times. Thank you Chris!
chrischenusa likes this.
MH60PIC is offline  
post #43 of 49 Old Aug 4th, 2018, 8:35 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by MH60PIC View Post
I just had my radio repaired by Chris as well and I cannot recommend him highly enough. The entire process took one week! I had been without a radio for a year because I assumed it was a difficult wiring problem and now the radio works better than new. I took the bike out today and it was just like old times. Thank you Chris!

Tkx Dan, I highly appreciate it

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #44 of 49 Old Oct 22nd, 2018, 11:12 am Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Exclamation Re: Radio Sound Problem ( Becker )

About Bluetooth!


I figured out how to make my Bluetooth module powerful and clear, avoiding the connection to the original radio low input AUX.

This new module is more elaborate and provides a clear and powerful sound.

Note that a micro switch has been added to the front of the radio, allowing you to select the radio or the Bluetooth. (See picture#11 "Garage")

I offer you this new Bluetooth module for $55

Tku

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by chrischenusa; Oct 22nd, 2018 at 2:22 pm.
chrischenusa is offline  
post #45 of 49 Old Feb 25th, 2019, 6:18 pm
Junior Member
 
Join Date: Feb 2019
Posts: 1
Re: Radio Sound Problem ( Becker )

I found this thread a couple of weeks ago and contacted Chris. Chris was very patient with me as I had a lot of questions and suggestions - yeah, I'm one of those LOL! After pulling the radio and sending it to Chris, he had the radio for day, fixed it, and shipped it back the next day. It had lost the left rear channel and he replaced the amp chips using more powerful chips than the stock ones.

I also asked him to add the Bluetooth option to the unit; however, I asked him to install it through the AUX channel because I wanted to be able to use the speed sensitive volume control along with being able to use the OEM volume switch on the grips.

I installed it this weekend and it works great!

I also found a Bluetooth media remote (see picture) that allows me to pause and advance songs on my phone as well as control the volume of the phone. Using this remote, I could have asked Chris to wire the Bluetooth directly to the amp - but I wouldn't have preserved the speed control feature which I really like.

Now I have the best of both worlds - speed controlled volume with manual volume controls on the grip - as well as being able to advance or pause music without having to switch away from my navigation screen on my phone which is now mounted on a RAM mount where my old Motorrad nav used to be.

Chris also provided the information to alter the AUX input level. I haven't tried it yet, but I'm already super-satisfied with the volume levels I got this weekend while cruising at 80 mph. Anything more will be icing on the cake!

Life is good! Thank you Chris!
Attached Thumbnails
Click image for larger version

Name:	s-l640.jpg
Views:	25
Size:	19.8 KB
ID:	150101   Click image for larger version

Name:	BMW K1200LT AUX Input Adjustment.jpg
Views:	32
Size:	51.6 KB
ID:	150103  
bmeyer07 is offline  
post #46 of 49 Old May 17th, 2019, 10:31 am
Member
 
Bob.K1200LT's Avatar
 
Join Date: Jul 2018
Posts: 50
Re: Radio Sound Problem ( Becker )

Chris recently repaired my radio and also added an AUX jack on the front bezel. Highly recommend his service. Received and shipped same day!

Bob Johnson
Knoxville TN
2004 K1200LT
1973 R75/5
Bob.K1200LT is offline  
post #47 of 49 Old May 17th, 2019, 9:25 pm
Junior Member
 
Join Date: Sep 2017
Posts: 8
Does anyone know the number for the front wheel bearings and seals on an 01 k1200lt? I'd like to find them aftermarket if possible at a fastenall or other such distributor.
post #48 of 49 Old May 17th, 2019, 9:27 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by Bob.K1200LT View Post
Chris recently repaired my radio and also added an AUX jack on the front bezel. Highly recommend his service. Received and shipped same day!
Thank you Bob, I'm glad my work met your expectation.

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
post #49 of 49 Old May 17th, 2019, 9:30 pm Thread Starter
Member
 
chrischenusa's Avatar
 
Join Date: Dec 2012
Location: Cape coral, FL, USA
Posts: 63
Garage
Re: Radio Sound Problem ( Becker )

Quote:
Originally Posted by [email protected] View Post
Does anyone know the number for the front wheel bearings and seals on an 01 k1200lt? I'd like to find them aftermarket if possible at a fastenall or other such distributor.
Check this out
https://www.bmwlt.com/forums/k1200lt...l-done%85.html

Chris
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
chrischenusa is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kit Repair Radio Bmw Professional 2000 ( Becker ) sikkim K1200LT 73 Jun 9th, 2018 3:55 pm
Radio Problem mtrevelino RT Series 7 Mar 23rd, 2016 3:27 pm
Another radio problem (I searched first) garage monster K1200LT 6 Oct 22nd, 2015 3:51 pm
No Sound thru radio on my 2001LT magnet K1200LT 10 Oct 25th, 2011 6:54 pm
voice separation on the LT's loudspeaker jusufbw K1200LT 6 Oct 8th, 2007 10:03 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome