Finally back with the LT community - BMW Luxury Touring Community
 5Likes
  • 5 Post By motorhead
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Mar 8th, 2018, 12:18 pm Thread Starter
Senior Member
 
motorhead's Avatar
 
Join Date: Feb 2004
Location: Old Hangtown, CA, USA
Posts: 2,406
Talking Finally back with the LT community

Been near 5 years away having the old girl still whirling away w/o issue until recently

Last spring it Suffered the bad ground of the starter interrupter circuit ... key on, lights on & hit starter getting nothing but lights going out and a click from start solenoid !!
Was so busy last season closing down our buisness and other stuff just could not bring myself up to diving into the bike fixing it. Now the wifes after me to fix it or sell it ... WHAT ?
Good thing all those valuable threads of 10+ years ago are still there ! few hours of reading to get the snippets required to chase the ground wires battery to the blocks to the starter & frame all has returned to normal !!

2000 LTI with @ 70K on the clock and running once more.

Scott
mtrevelino, cws, trussell and 2 others like this.

"00" Canyon Red LTI ~ Well Farklized ~ Bug Splattered
Our "semi" quiet riot
*** Trailer Too ***

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
T
wisties Required
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

motorhead is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Mar 8th, 2018, 5:10 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,269
Re: Finally back with the LT community

Welcome back Scott. Glad to see you also sorted out your gear position indicator as well.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #3 of 4 Old Mar 9th, 2018, 7:54 am
Lifetime Supporter
 
oly223cal's Avatar
 
Join Date: Nov 2017
Location: Hortonville, WI
Posts: 46
Garage
Re: Finally back with the LT community

Welcome back Scott.
oly223cal is offline  
 
post #4 of 4 Old Mar 11th, 2018, 11:40 am
Member
 
Billyjoe Jimbob's Avatar
 
Join Date: Oct 2017
Posts: 37
Re: Finally back with the LT community

I didn't know you were gone.

Being a real noob to both the bike and this group, I gotta say that this may be the best bike forum I've dealt with. I look forward to your posts!

I pulled in to Nazareth, I was feeling about half past dead...
Billyjoe Jimbob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Vernal Equinox Rally, Oklahoma meese Ride Tales 27 Apr 5th, 2011 11:54 am
2010 Roadtrip back to the "Old Country" Slammer Ride Tales 0 Aug 11th, 2010 5:48 am
Finally back together.. cfell K1200LT 5 Jul 18th, 2010 10:01 pm
We're Back! (GT Info) (Long!!) AlaskaFish North West 5 Jun 26th, 2006 3:08 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome