Right rear Speaker going out - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Dec 3rd, 2006, 9:54 pm Thread Starter
 
Join Date: Nov 2006
Posts: 20
Right rear Speaker going out

Just some recommendations from you guys on how to approach this with the dealer. I have had the bike for about 6 weeks and approx 3k in miles in that time. The right rear speaker is not working properly. I bought the bike used with 15k on it. Any thoughts?

Thanks
Racer222 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old Dec 4th, 2006, 6:44 pm
Senior Member
 
RVB1019's Avatar
 
Join Date: Jan 2005
Location: Long Island , NY, USA
Posts: 1,733
Garage
Before dealing with you dealer, try resetting the radio's memory. If you diconnect the terminals from the battery, it may reset itself. If that doesn't work, you may have a loose connection somewhere. I would think it would be covered by warranty but you never know.

To get to the radio, you have to remove the left side stingray to get to the radio itself. Depending on who you listen to on the board, this is not a big job - 2 hours sounds like a good estimate.

You can also search the forums to check the right side speaker. The wires there may have simply slid off.

Try disconnecting the battery first. That's the easiest.
Then the rear speaker.

Good Luck,

Rob V.B.
2015 Triumph Explorer 1200
2007 BMW GT (SOLD)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 BMW LT (SOLD)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 BMW R1150 traded for 2002 Yamaha FZ1 traded for a 2003 GSXR 750

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RVB1019 is offline  
post #3 of 9 Old Dec 4th, 2006, 7:07 pm
Senior Member
 
JPSpen's Avatar
 
Join Date: Jul 2005
Location: Jones, OK, USA
Posts: 3,525
Clean the connections

This most likely is a connection problem. It's fairly common. You'll need to clean and lube the connections with dielectric grease. Start with the connections at the rear trunk under the passenger seat. This is the easiest to get to and in your case seemingly the most likely...If that doesn't fix it then pull the left side tupperware and do the connections at the stingray. I don't think I've ever heard of the speakers themselves failing ( I could be wrong there ) . I guess if you abused the volume long enough you could blow a speaker but they're fairly robust little units.....

Good Luck

John

Live and direct from the new earthquake capitol of the U.S. Jones, Oklahoma
08 Can-Am Spyder (Miss Lindy's)
03 R1200CLC Capri Blue "Flipper"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 R1100RT Glacier Blue "Lucky"
91 R100GS "It'sNotAMoneyPit"
The voices in my head may not be real, But they have some good ideas!


"I like the wind in my face and Boobies on my back. No, Wait, I got that backwards"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JPSpen is offline  
 
post #4 of 9 Old Dec 4th, 2006, 9:48 pm Thread Starter
 
Join Date: Nov 2006
Posts: 20
Thanks guys. I will try my luck at the dealer. I race a kawasaki that I could take apart blind folded but I am a little nervous about messing with this machine.

Thanks

Marc
Racer222 is offline  
post #5 of 9 Old Dec 4th, 2006, 10:24 pm
Senior Member
 
JPSpen's Avatar
 
Join Date: Jul 2005
Location: Jones, OK, USA
Posts: 3,525
Fear not

Don't be afraid to wrench on the LT.. It's just a motorcycle underneath all the covers....

Stand them on their heads and they're all sisters....


IT's probably just dirty connectors....


John

Live and direct from the new earthquake capitol of the U.S. Jones, Oklahoma
08 Can-Am Spyder (Miss Lindy's)
03 R1200CLC Capri Blue "Flipper"
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

01 R1100RT Glacier Blue "Lucky"
91 R100GS "It'sNotAMoneyPit"
The voices in my head may not be real, But they have some good ideas!


"I like the wind in my face and Boobies on my back. No, Wait, I got that backwards"

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
JPSpen is offline  
post #6 of 9 Old Dec 7th, 2006, 2:08 pm Thread Starter
 
Join Date: Nov 2006
Posts: 20
Bike is still under warranty. Have an appointment on Saturday. Thanks for all the help. I will let you guys know how it turns out.

Thanks

Marc
Racer222 is offline  
post #7 of 9 Old Dec 8th, 2006, 11:29 am
Senior Member
 
BecketMa's Avatar
 
Join Date: Jul 2002
Location: Tucson, AZ, USA
Posts: 3,522
Ask the dealer to to not only get the speakers working correctly, but also to solve the problem as to why it/they wen't out.

Bob
BecketMa is offline  
post #8 of 9 Old Dec 8th, 2006, 10:32 pm Thread Starter
 
Join Date: Nov 2006
Posts: 20
Will do!!

Thanks
Racer222 is offline  
post #9 of 9 Old Dec 17th, 2006, 8:38 am Thread Starter
 
Join Date: Nov 2006
Posts: 20
Update

Seems like the speaker wasn't the problem. I haven't been told exactly what the problem is but they are ordering me a new radio to fix it. I will keep you all posted.

Thanks

Marc
Racer222 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cheap Rear Speaker Replacement MolenaarD K1200LT 5 Jul 10th, 2006 2:17 am
Left Rear Speaker out turbogunner Intercom, CB, & 2-Way Radios 5 May 31st, 2006 6:35 pm
Rear END????? kip K1200LT 13 May 24th, 2006 8:32 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome