Radio issues - BMW Luxury Touring Community
 1Likes
  • 1 Post By guitarjim
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old Nov 1st, 2016, 2:19 pm Thread Starter
Junior Member
 
cornfed's Avatar
 
Join Date: Oct 2016
Posts: 13
Radio issues

Hey all,

Radio works fine but 1: The display does not...
2: CD changer works, but I cannot figure out how to change CDs or play on random...

Please, everyone stop what you are doing and respond, I got real problems here. Just kidding, any info from you K bike pros is welcome on how to operate the changer, and what I need to do for the screen issues...

Gus
cornfed is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old Nov 1st, 2016, 10:09 pm
Senior Member
 
Axle's Avatar
 
Join Date: Oct 2007
Location: portland, victoria, Australia
Posts: 1,482
Garage
Re: Radio issues

cant help you with the display, does it not work or is it cloudy? what year is the bike, it makes a difference to the response....

Regards Linton
From the land of Kangaroo's and Koalas
and no koalas are not Bears



2002 K1200LT
2010 Suzuki GSX 1250FA (the Wifes)
2004 Cub Kamparoo Sprint
My Toys
1976 Datsun 260Z
1989 Nissan 300zx TT
Axle is offline  
post #3 of 11 Old Nov 3rd, 2016, 1:54 am
Senior Member
 
guitarjim's Avatar
 
Join Date: Nov 2015
Location: South Central Kansas
Posts: 646
Re: Radio issues

This past weekend, I pulled out my radio system out of the bike and put it in the garage. Now, I have like 3x more space to put more junk where I can easily get to it while riding. I have been using my bluetooth system in my helmet exclusively since I got it. So, no need for the radio. I can take calls, listen to and respond to text messages by voice, listen to music or radio station and I should have rider to rider communication (just haven't tried it out).

Save yourself some time and get a communication system for your helmet.
gdenton likes this.
guitarjim is offline  
 
post #4 of 11 Old Nov 10th, 2016, 10:27 am Thread Starter
Junior Member
 
cornfed's Avatar
 
Join Date: Oct 2016
Posts: 13
Re: Radio issues

It is a 2003, only 13k on it, but the display lights up, just nothing on it.
cornfed is offline  
post #5 of 11 Old Nov 10th, 2016, 4:21 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,265
Re: Radio issues

Sometimes a hard rest will cure some radio ills. Just undo the battery negative terminal for about 15 minutes, then reconnect. Don't mind the big spark as it is normal rush current. Then turn on the key but do not start. Open and close the throttle three times and shut the key off, then key on and start. See if that does not fix it. Also look at the display very close and see if it appears milky, a little alcohol and water will clear it up. (May want to do this first.)

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #6 of 11 Old Nov 10th, 2016, 7:32 pm
Senior Member
 
vernvernvern's Avatar
 
Join Date: May 2006
Location: King City, Missouri, USA
Posts: 812
Re: Radio issues

Quote:
Originally Posted by cornfed View Post
Hey all,

Radio works fine but 1: The display does not...
2: CD changer works, but I cannot figure out how to change CDs or play on random...

Please, everyone stop what you are doing and respond, I got real problems here. Just kidding, any info from you K bike pros is welcome on how to operate the changer, and what I need to do for the screen issues...

Gus
Alcohol swab will clear it up, if that's your problem. Also, on my '02LT when I first us the cd changer, I have to push the cd button 2 times to get the player to start.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
====
Bought used K1200LT number 3. This one is green/teal with 31,369(now 7/29/2018 54,143) miles and is an '02. The first 2 bikes made it to near 150,000 miles.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Due to heart health, the Dr says not to ride under 40 degree air temp. Ugh! Now it is harder to get my 18000 miles a year in just in the summer. Guess that stopped my 20 degree rides now.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


78 years young!
04 Honda Reflex.....Hers (it mostly sits)
Converted HD rider.
Love this LT bike and still waiting for my first speeding ticket. LOL
Vern
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

=====
vernvernvern is offline  
post #7 of 11 Old Nov 10th, 2016, 10:31 pm
Senior Member
 
silverlt2002's Avatar
 
Join Date: Jul 2002
Location: , ,
Posts: 189
Re: Radio issues

If you can't say for sure that you were able to see the display clearly in the recent past, then I recommend you try to clean the plastic display window with either an alcohol swab or cloth with some WD40. These plastic windows tend to cloud over due to the plastic degrading over time. You may be able to see the light coming through but the LED numbers don't. I just fixed this same problem for a guy who recently inherited a K1200LT. He thought the radio didn't work until I cleaned the display. Pretty much looked like magic to him.

Good luck

Steve Green
US Army (Ret)
2002 KLT
Titan Silver

I don't like making plans for the day....because then the word "premeditated" gets thrown around in the courtroom.
silverlt2002 is offline  
post #8 of 11 Old Nov 18th, 2016, 12:04 pm Thread Starter
Junior Member
 
cornfed's Avatar
 
Join Date: Oct 2016
Posts: 13
Re: Radio issues

I have power to it and the screen lights up, but no LCD on it, so I will try Alchohol etc and see what happens... Thanks.
cornfed is offline  
post #9 of 11 Old Nov 19th, 2016, 12:51 am
Senior Member
 
Join Date: Nov 2016
Posts: 186
I used 2000 grit wet sandpaper to scrape off the Cloudy layer of plastic on my display and then use rubbing compound and then polishing compound and then I covered it with wax and it looks beautiful
DeusExMaxima is offline  
post #10 of 11 Old Nov 19th, 2016, 8:16 am
Senior Member
 
Join Date: Dec 2013
Posts: 340
Re: Radio issues

Denatured Alcohol and a cotton ball. You can purchase it at your local hardware store. One can will last the lifetime of multiple LTs. I was given the top tip from another LT forum member.

Rob, 2000LT
Navarre, FL
Fun Bobby is offline  
post #11 of 11 Old Nov 25th, 2016, 2:18 pm
Senior Member
 
Join Date: Aug 2002
Location: Shoreline, WA, USA
Posts: 495
Re: Radio issues

So how would your helmet system work with GMRS, CB, GPS or Radar aural warnings? Just wondering if these things interphase at all?

Thanks :-)
stevea2980 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
k 1200 lt radio problem airplane K1200LT 16 Apr 23rd, 2018 5:48 pm
K1200LT Radio Issues - only one speaker working mondrage K1200LT 3 Apr 12th, 2016 10:41 am
Zumo, Autocom and Factory Radio on 06 RT goose512 Intercom, CB, & 2-Way Radios 2 Apr 11th, 2012 11:37 am
Radio issues mchammer717 K1200LT 13 Aug 22nd, 2010 7:23 pm
No Radio, No Motolights hschisler K1200LT 15 Oct 3rd, 2007 10:05 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome