1 speaker works after 30 seconds of radio on - BMW Luxury Touring Community
 1Likes
  • 1 Post By want2tour
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Sep 27th, 2016, 8:06 am Thread Starter
Junior Member
 
Guitarlos's Avatar
 
Join Date: Sep 2016
Posts: 19
Garage
1 speaker works after 30 seconds of radio on

I know, yet another radio thread.......but hey, its 2016 and I was inquiring to see if there are any new ways of handling this issue?

Id love to stay stock as I like the hands free auto-adjust on the volume with increased speeds plus the radio controls are good for safety and convenience, in my opinion.

Is it as simple as just adding an amplifier to the radio, externally from the radio?

Bluetooth, has anyone found a compatible kit or modification for a 2005 or higher radio?

I've had the bike for 2 weeks now and the radio is exuding a failure. Its a 2005 K1200LT.

Thanks for any updated information, I've searched and read several threads on here, so I feel comfortable seeing whats out there, but haven't really read anything, or much from recent years, so I thought Id try this approach.
Guitarlos is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Sep 27th, 2016, 12:52 pm
Senior Member
 
want2tour's Avatar
 
Join Date: Nov 2014
Location: Sandpoint, ID area
Posts: 275
Re: 1 speaker works after 30 seconds of radio on

So you know that the stock amp is crappy and that you can send the unit to Barris who will put in a better amp. Once I went to blutooth in the helmet, it became a non-issue for me.
Guitarlos likes this.

2005 KLT Graphite Gray
2003 F650GS Black
*Too slow for fast women
*A little adventure is good for the soul
want2tour is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio just quit atps1234 K1200LT 62 May 29th, 2017 11:43 pm
K1200LT Radio Issues - only one speaker working mondrage K1200LT 3 Apr 12th, 2016 10:41 am
Radio swap reusing handlebar control Rob't Intercom, CB, & 2-Way Radios 0 Mar 22nd, 2015 12:49 am
Radio Software mismatch Madsparkie1975 K1200LT 3 Oct 26th, 2014 12:21 pm
Stock Radio Antenna Works Itself Loose BCVBeck RT Series 1 Jun 10th, 2008 12:47 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome