Stop Lights not working on front brake. - BMW Luxury Touring Community
 4Likes
  • 2 Post By jzeiler
  • 2 Post By jimbobillybob
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jun 27th, 2016, 8:51 am Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 5
Stop Lights not working on front brake.

Hi I have a 2000 euro spec K1200lt , I recently noticed that the brake light doesn't work when I apply the front brake, it works fine, however when I apply the rear brake. Ive checked fuse one, its fine. Everything else on the bike seems fine, the brakes and abs are ok.I'm reasonably handy, doing my own servicing and small repairs, with the help of Kurt's videos from the Illinois Motorrad Club, but Im not sure where to start here.
Any help the forum can offer would be greatly appreciated , Ive had a search though old post but I found myself buried in posts about abs problems.

Thanks
jimbobillybob is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jun 27th, 2016, 9:29 am
Senior Member
 
sailor's Avatar
 
Join Date: Nov 2004
Location: Montreal ,QC , Canada
Posts: 1,171
Re: Stop Lights not working on front brake.

Quote:
Originally Posted by jimbobillybob View Post
Hi I have a 2000 euro spec K1200lt , I recently noticed that the brake light doesn't work when I apply the front brake, it works fine, however when I apply the rear brake. Ive checked fuse one, its fine. Everything else on the bike seems fine, the brakes and abs are ok.I'm reasonably handy, doing my own servicing and small repairs, with the help of Kurt's videos from the Illinois Motorrad Club, but Im not sure where to start here.
Any help the forum can offer would be greatly appreciated , Ive had a search though old post but I found myself buried in posts about abs problems.

Thanks
In a way, you are lucky to have a 1st generation K1200LT with ABS2 as these problems are much simpler to solve (compare to later IABS that controls brake switches).

On models like yours (1999-2001 for USA specs), BOTH brake switches go thru a single fuse AND a single brake light Relay. As you posted the rear brake flight / switch is working , we must conclude the problem is NOT these items (so...not the relay and not the fuse).
SO, it must be either:
(1) front brake switch defective -OR-
(2) wiring damage related to front brake switch

On ABS2, these switches are easy to test as they are "normal" logic: circuit is closed (continuity) only when brake is applied.
See 2 attached diagrams for FRONT brake switch connector location under fairing...
Attached Thumbnails
Click image for larger version

Name:	K1200LT (1999-2001) brake-switch-connector-FRONT_1.jpg
Views:	437
Size:	194.1 KB
ID:	111369   Click image for larger version

Name:	K1200LT (1999-2001) brake-switch-connector-FRONT_2.jpg
Views:	393
Size:	98.8 KB
ID:	111377  

-------------------------------------------------
John (Montreal, CANADA)
K1200RS (2002 IceBlue/Red - 96,000 miles)
-------------------------------------------------
Think twice before you hit [SUBMIT REPLY] - famous quote by another member:
"The value of this board is not founded on dismissing the ideas of others, but by posting to share our experiences and what we've learned from them."
sailor is offline  
post #3 of 5 Old Jun 27th, 2016, 7:47 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,300
Re: Stop Lights not working on front brake.

In addition to what John said, listen at the brake lever for a "click" of the micro switch. It may just be stuck or out of adjustment.
Attached Thumbnails
Click image for larger version

Name:	front switch.PNG
Views:	218
Size:	33.5 KB
ID:	111521  
Patric and beech like this.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 5 Old Jun 28th, 2016, 12:58 pm Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 5
Re: Stop Lights not working on front brake.

Thanks both for your replies. Concise, well informed and clear.
Plenty there to get me started, Ill investigate further and get back to you.
jimbobillybob is offline  
post #5 of 5 Old Jul 1st, 2016, 1:42 pm Thread Starter
Junior Member
 
Join Date: Jun 2014
Posts: 5
Re: Stop Lights not working on front brake.

Hi again, there was no click from the micro switch when the brake was pulled, when I started to disassemble it became clear I wasn't the first to do so. The switch had been bodged together before, I called round and found one at www.motorworks.co.uk they had it to me the next day. Getting it in was a fiddly job and a bit of a swine if I'm honest, but after a few hours I got it in. Brake light works now, another trip to the dealer avoided, nothing could be more satisfying.
Thanks both for your help, without it I would have been stuck.
Patric and johnbaker15 like this.
jimbobillybob is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
brake lights stuck "on" myrph226 K1200LT 22 Feb 7th, 2017 12:57 pm
Front brake pads not releasing shelmen1 K1200LT 8 Oct 2nd, 2014 12:52 pm
2008 LT front brake bleeding procedure acuningham K1200LT 5 May 2nd, 2012 12:57 pm
Is this Front Brake Line Normal? rovero K1200LT 7 May 27th, 2011 12:15 pm
Triple BBG-Ride Report murray Ride Tales 8 Nov 20th, 2005 7:34 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome