Signal light problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old Jun 12th, 2016, 9:17 pm Thread Starter
Junior Member
 
Join Date: Apr 2013
Location: Lee, NH, USA
Posts: 29
Signal light problem

Hi all
Just did the 24,000 mile service on my 07 and upon completion of reassembly I now have the right turn signal on constantly, both front and rear. The left side works fine..
What would cause that. The oddments box was a bear to reconnect because of the CB and tight quarters but I thought all the the connections there where for audio stuff. I checked fuses but don't think the lights would be on constantly if one where blown.
I did have it naked to include the tank for the fuel filter, air filter and coolant change out. Did the plugs and wires also.
Everything else works fine.
Thoughts?

Rick
captw3 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old Jun 12th, 2016, 9:22 pm
Senior Member
 
Axle's Avatar
 
Join Date: Oct 2007
Location: portland, victoria, Australia
Posts: 1,485
Garage
Re: Signal light problem

do you have a tow bar? you also need to check if you have caught a wire on that side and its grounded

Regards Linton
From the land of Kangaroo's and Koalas
and no koalas are not Bears



2002 K1200LT
2010 Suzuki GSX 1250FA (the Wifes)
2004 Cub Kamparoo Sprint
My Toys
1976 Datsun 260Z
1989 Nissan 300zx TT
Axle is offline  
post #3 of 8 Old Jun 12th, 2016, 10:43 pm Thread Starter
Junior Member
 
Join Date: Apr 2013
Location: Lee, NH, USA
Posts: 29
Re: Signal light problem

No tow bar. Was hoping not to have to remove the Tupperware again, but guess a short makes sense.
Thanks for the reply
Rick
captw3 is offline  
 
post #4 of 8 Old Jun 12th, 2016, 11:46 pm
Senior Member
 
Axle's Avatar
 
Join Date: Oct 2007
Location: portland, victoria, Australia
Posts: 1,485
Garage
Re: Signal light problem

look up under the front the indicator wires can be seen.

Regards Linton
From the land of Kangaroo's and Koalas
and no koalas are not Bears



2002 K1200LT
2010 Suzuki GSX 1250FA (the Wifes)
2004 Cub Kamparoo Sprint
My Toys
1976 Datsun 260Z
1989 Nissan 300zx TT
Axle is offline  
post #5 of 8 Old Jun 13th, 2016, 2:42 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,300
Re: Signal light problem

None of the "stingray" connectors are involved in your problem. I would pull the right front turn signal (one screw) and inspect the wires as far back as you can. Even if the switch was stuck or shorted the lights should flash. But you said on constantly as in flashing constantly? Or on solid? If they are flashing all the time I would trace the harness from the switch gear down to the area under the cowl as there could be a pinched wire there. This harness runs all the way down to the relay box under the fuel tank.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
post #6 of 8 Old Jun 13th, 2016, 7:34 pm Thread Starter
Junior Member
 
Join Date: Apr 2013
Location: Lee, NH, USA
Posts: 29
Re: Signal light problem

On solid as soon as the ignition is on. Looks like I'll be disrobing the red head again. I'll start on the right upper fairing.
Thank you for your response
Rick
captw3 is offline  
post #7 of 8 Old Jun 14th, 2016, 5:22 pm Thread Starter
Junior Member
 
Join Date: Apr 2013
Location: Lee, NH, USA
Posts: 29
Re: Signal light problem

Found the problem. Bulb was not seated well in the light fixture on the upper fairing. I feel much better now.
Thanks for the support.
Rick
captw3 is offline  
post #8 of 8 Old Jun 14th, 2016, 6:23 pm
Senior Member
 
Axle's Avatar
 
Join Date: Oct 2007
Location: portland, victoria, Australia
Posts: 1,485
Garage
Re: Signal light problem

well done

Regards Linton
From the land of Kangaroo's and Koalas
and no koalas are not Bears



2002 K1200LT
2010 Suzuki GSX 1250FA (the Wifes)
2004 Cub Kamparoo Sprint
My Toys
1976 Datsun 260Z
1989 Nissan 300zx TT
Axle is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
No left signal light ctraylor K1200LT 9 Apr 26th, 2014 7:12 am
Turn signal problem! rd_gonz K1200LT 1 Nov 28th, 2006 4:06 pm
Forum Humor eljeffe Humor 2 Mar 5th, 2006 7:14 pm
How many of us does it take to change a light bulb?! Bruce_Yates Humor 4 Mar 1st, 2006 9:03 am
How many forum members does it take to change a light bulb? RoyvL Humor 12 Feb 13th, 2006 1:49 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome