Clean Battery Cables - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Sep 20th, 2006, 5:19 pm Thread Starter
Senior Member
 
Zeke's Avatar
 
Join Date: Aug 2002
Location: Loxahatchee, Fl, USA
Posts: 986
Cool Clean Battery Cables

Hey all;

Had a interesting ride to work today. I ride 60 miles to/from work everyday. This morning at 5 riding on 95 used the brakes and the radio went dead for .5 to 1 sec came back. Used the turn signal to change lanes radio dead and the lights flash off and back on. Hit the brakes again bike dies for 1 sec and goes again. Now my cruise does not work,afraid to hit the brakes and dont you dare use the turn signals. Besides all that the bikes runs great. Get to work gliding to stops and hope the bike does not die. At lunch went out took the ground cables off the battery to clean them,not that bad, back on again and whalaa problem gone. Runs great. Just a note to check your cables once in a while so when you are out during the dark you dont end up in the dark.
WEIRD.

Zeke

45 years riding and still more places to see.
2002 K1200LT
2016 R1200RT
IBA # 41935
Zeke is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Sep 20th, 2006, 11:52 pm
Senior Member
 
jorawro's Avatar
 
Join Date: Jul 2002
Location: Strathmore, AB, Canada
Posts: 675
Good reminder----Thanks

Roy Jorawsky
Deputy Chief - SFD
2002 K1200LT - "BackDraft" - Deceased
2008 HD Ultra Screaming Eagle

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jorawro is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dog-Gone battery charger question! Yuck! wardenross K1200LT 17 Oct 24th, 2006 1:31 pm
I've tried to read everything on this site but I'm still confused kdale K1200LT 11 Jul 3rd, 2006 6:44 pm
Battery Concern please advise Hulkster Batteries, Chargers, & Electrical 8 Feb 6th, 2006 12:41 am
How NOT to treat your battery.... Zotter Batteries, Chargers, & Electrical 8 Nov 22nd, 2005 1:51 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome