05 Radio Problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jul 31st, 2014, 11:29 am Thread Starter
Junior Member
 
Join Date: Aug 2012
Location: Appleton, WI, USA
Posts: 27
05 Radio Problem

Seeing what i need to tear apart to fix my radio.Radio used to work fine but one night got rained on hard.And now radio is stuck on AUX mode and handlebar controls dont work.Are both shot or just radio ? I tried unhooking battery acouple times.Didnt change anything.Thanks in advance.
richierichr1 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jul 31st, 2014, 12:10 pm
Senior Member
 
Join Date: Mar 2014
Posts: 396
Re: 05 Radio Problem

I've read elsewhere that sometimes, the rain causes shorts and conduction in the radio controls in the center console.

If you still hear something from the radio, maybe you need to take the tupperware off and start drying the controls (hair dryer?).
I doubt the handlebar controls have an issue, but the center console might.

Good luck!
mondrage is offline  
post #3 of 5 Old Jul 31st, 2014, 8:47 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: 05 Radio Problem

The little rubber buttons crack with age and let the rain in. Best to open it up and clear water and any corrosion out.
Attached Thumbnails
Click image for larger version

Name:	Controller with back off.jpg
Views:	47
Size:	165.9 KB
ID:	61657   Click image for larger version

Name:	Controller board.jpg
Views:	45
Size:	73.8 KB
ID:	61665   Click image for larger version

Name:	Main.JPG
Views:	36
Size:	88.3 KB
ID:	61673  

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
 
post #4 of 5 Old Aug 1st, 2014, 8:56 am Thread Starter
Junior Member
 
Join Date: Aug 2012
Location: Appleton, WI, USA
Posts: 27
Re: 05 Radio Problem

Thanks guys.I'll have to open it up and check it out.Is there a good fix to reseal around the buttons ?
richierichr1 is offline  
post #5 of 5 Old Aug 1st, 2014, 7:29 pm
Wrencher Extraordinaire
 
jzeiler's Avatar
 
Join Date: May 2004
Location: Hazel Green, AL, USA
Posts: 13,307
Re: 05 Radio Problem

Have not tried it but maybe a thin application of silicon seal on the inside of each button might do it.

John
2009 K1300GT Red Rocket
2009 R1200GS (Gone)
2005 K1200LT Ocean Blue Blue Wizard 110 K and counting...
2006 Bushtec Turbo+2 Spell
2004 330 Ci Convertable
K4AN

Have ridden a Motorcycle in all 48
But lack DE, MA, RI and CT with the 2005 LT

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jzeiler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Radio Sound Problem Steveford K1200LT 1 Oct 14th, 2013 11:18 am
Another Radio Problem sh059 K1200LT 1 Jan 16th, 2011 6:22 pm
An 'Other" wierd Radio problem K1200LT-TH K1200LT 5 Oct 14th, 2009 11:24 am
Radio problem erichotdoc Bike Talk 3 Sep 12th, 2009 12:21 am
radio problem on 1200LTE couleekid Chit Chat 0 Jul 4th, 2008 12:40 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome