Lights won't turn off - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 8 Old May 22nd, 2014, 9:31 am Thread Starter
Member
 
Join Date: May 2013
Location: weatherford, tx, usa
Posts: 87
Lights won't turn off

While crusing along about 75-80mph the flashers started blinking (without pushing the flasher switch). When I finally stopped the lights wouldn't turn off.


Am I to assume the relay is stuck?

Thanks, Dave.

In the last 2 years...
'08 R1200GS---Loved it!!!
'01 H-D Ultra Classic---Hated it!!! (aka. the infernal noise making machine)
'02 K1200LT(black)---Even my GF is jealous of this one.
KI_OTE is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old May 22nd, 2014, 11:41 am
Lifetime Supporter
 
bblalock's Avatar
 
Join Date: Nov 2003
Location: Swansboro(area), NC, USA
Posts: 650
Re: Lights won't turn off

That could be. You might disconnect the battery and kill the system. Then reconnect, reset the Motronic and see if that cures the problem.
Just my .02

Benton Blalock
"I ride.....the bike doesn't"

'18 Honda Africa Twin Adventure SportDCT
'12 Kawi KLR 650 "Dirty" - traded in
'08 LT Black "Fireball" 113,000+ miles(RIP- transmission - may be seen on the road again)
'05 LT Yeller er Gold? "Ophelia"(RIP- fire) 80,000 miles
'04 R12CLC (RIP- hurricane) 36,000 miles
230,000+ BMW miles
'Rounder'
bblalock is offline  
post #3 of 8 Old May 22nd, 2014, 2:02 pm Thread Starter
Member
 
Join Date: May 2013
Location: weatherford, tx, usa
Posts: 87
Re: Lights won't turn off

Thanks.

Since this is my first LT....what & where is a Motronic and how do you reset it?

And...can you replace the relay without taking everything including the tank off?

In the last 2 years...
'08 R1200GS---Loved it!!!
'01 H-D Ultra Classic---Hated it!!! (aka. the infernal noise making machine)
'02 K1200LT(black)---Even my GF is jealous of this one.
KI_OTE is offline  
 
post #4 of 8 Old May 22nd, 2014, 2:39 pm
Senior Member
 
Join Date: Feb 2007
Location: Helsinki, Finland, Europe, Northern hemisphere
Posts: 594
Re: Lights won't turn off

Motronic = ECU has got nothing to do with flashers. But as for your question: Motronic-unit is under the gas tank.

Born to be wild so why not

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
C-A-D is offline  
post #5 of 8 Old May 22nd, 2014, 3:13 pm
Senior Member
 
dvgb131's Avatar
 
Join Date: Jul 2013
Location: Guilderland, NY, USA
Posts: 207
Garage
Re: Lights won't turn off

Quote:
Originally Posted by KI_OTE View Post
Thanks.

Since this is my first LT....what & where is a Motronic and how do you reset it?

And...can you replace the relay without taking everything including the tank off?
bblalock was referring to the need to reset the Throttle Position Sensor setting, which is required after you re-connect the battery.
1.Turn key to on - do not start bike.
2. Fully open and close the throttle twice.
3. Turn key off.

Doug B.
2000 LT purchased July 2013
dvgb131 is offline  
post #6 of 8 Old May 22nd, 2014, 3:24 pm Thread Starter
Member
 
Join Date: May 2013
Location: weatherford, tx, usa
Posts: 87
Re: Lights won't turn off

10-4. When you buy one with a dead battery you learn that pretty quick.

Thanks for clearing that up.

In the last 2 years...
'08 R1200GS---Loved it!!!
'01 H-D Ultra Classic---Hated it!!! (aka. the infernal noise making machine)
'02 K1200LT(black)---Even my GF is jealous of this one.
KI_OTE is offline  
post #7 of 8 Old May 22nd, 2014, 3:40 pm
Senior Member
 
Join Date: Apr 2002
Posts: 14,436
Re: Lights won't turn off

Quote:
Originally Posted by KI_OTE View Post
10-4. When you buy one with a dead battery you learn that pretty quick.

Thanks for clearing that up.
Hi, David - take a read thru this thread for flasher related fix. Good luck.
Dick is offline  
post #8 of 8 Old May 26th, 2014, 11:35 am Thread Starter
Member
 
Join Date: May 2013
Location: weatherford, tx, usa
Posts: 87
Re: Lights won't turn off

Disconnected the battery overnight, then reset the Motronic. That seemed to do it.

Thanks to everyone.

In the last 2 years...
'08 R1200GS---Loved it!!!
'01 H-D Ultra Classic---Hated it!!! (aka. the infernal noise making machine)
'02 K1200LT(black)---Even my GF is jealous of this one.
KI_OTE is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to make a tight u-turn Arby60 K1200LT 53 Dec 14th, 2011 1:29 pm
K1600 / Unigo Lights Wiring old1951 K1600GT/GTL 11 Jul 16th, 2011 2:16 pm
LED turn signal/running lights jrlakin K1200LT 0 Oct 30th, 2008 10:09 am
Turn signals to running lights davek1 K1200LT 0 Sep 13th, 2008 10:47 am
Instrument lights don't work wjg4 K1200LT 11 Aug 13th, 2007 10:18 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome