Installed different horns...myself! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Jun 2nd, 2008, 3:39 pm Thread Starter
Senior Member
 
kbmwgt's Avatar
 
Join Date: Nov 2007
Location: Morgan Hill, California, USA
Posts: 158
Installed different horns...myself!

Okay I'm a admitted electrical idiot.

With the help of Meese a couple months ago I attempted to install the horns I had from my old K1100RS. Nice dual FIAM horns. Well that day the installation wasn't a success due to the need of a relay and inline fuse so I reconnected the OEM horn and left it while I had the warranty work (airbox) and battery problems resolved.

So Sunday I buy the relay and an inline fuse at the auto parts store. Of course they always ask what car I'm working on. Of course when I metion a bike they also ask but they have no knowledge of the CANBUS and just direct me to the parts I need.

I take off the plasctic and with the start I had from the previous attempt I mount up the horns fine on the left side. Wire up the relay and fuse and nothing.
The relay is clicking away when I press the horn button but nothin' .

Take the inline fuse out of the circuit and "honk-honk". So its the in-line fuse.
Open it up and there's nothing in it. I told you I was an idiot. I thought when one buys and asks for a in-line fuse that that's what one gets. I didn't know it was only a holder and that I needed to buy a fuse for it too.

So go out again and buy a fuse. rewire it again and "honk-honk" albeit with a sound that needs adjusting. A few turns of the horn adjustment screws and it sounds okay. Well better than that 'beep-beep'.

Maybe I'll get brave and think about installing the Nautilus horn one day.
kbmwgt is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Jun 5th, 2008, 1:28 am
IBR# 366
 
meese's Avatar
 
Join Date: Apr 2002
Location: West Linn, OR
Posts: 16,427
Garage
Re: Installed different horns...myself!

Glad you got things working.

After all that work we did at my place, I finally wired up my own Stebel horn. I've sure been glad to have it over the last few thousand miles.

Ken
Pacific NorthWet
'13 Dark Graphite Metallic K16GTLD, 24K miles
'09 Magnesium Beige Metallic K13GT, 63K miles
'03 Anthracite Metallic K12LTC, 66K miles
'02 Mauve Metallic K12LTC, 106K miles and sold
BMWLT#143, IBA# 366, MOA# 111996, SCMA# 24032


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


Some people see the gas tank as half empty. Some see it as half full. All I care is that I know where the next tankful is coming from...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
meese is online now  
post #3 of 4 Old Jun 5th, 2008, 5:27 am
Senior Member
 
grifscoots's Avatar
 
Join Date: May 2002
Location: Outside New Braunfels , TX, USA
Posts: 13,451
Re: Installed different horns...myself!

Yeppir, that Stebel is good stuff. I especially like the how the OEM horn starts off with that tinny, "mweep" that then turns into an ear bleeding sound.



100% free webcam site! | Awesome chicks and it is absolutely free! | Watch free live sex cam - easy as 1-2-3

-=grif=-
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Grok
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
grifscoots is offline  
 
post #4 of 4 Old Jun 10th, 2008, 11:40 am Thread Starter
Senior Member
 
kbmwgt's Avatar
 
Join Date: Nov 2007
Location: Morgan Hill, California, USA
Posts: 158
Re: Installed different horns...myself!

Well the horns work but NOT as loud as they were when on the old RS.

Any guesses as to why not?

They also have a more tinny sound. I swear on the RS they sounded just like a Beemer car now I'm almost tempted to go back to the OEM horn.
kbmwgt is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another K1200LT Clutch Installed! cccpastorjack K1200LT 3 Jan 13th, 2008 5:16 pm
MCCruise.com electronic cruise control installed Randy GS Series 16 Jun 22nd, 2007 9:04 am
aftermarket horns sanjaun2 K1200/1300GT (The Next Generation) 20 Feb 15th, 2007 2:45 pm
Hella FF200s Installed hschisler Lighting 2 Sep 9th, 2006 8:32 am
NEW VOICE COMM II INSTALLED ... will report SMGray Intercom, CB, & 2-Way Radios 16 Apr 25th, 2006 5:10 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome