Abs pump - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 9 Old Apr 30th, 2015, 9:02 pm Thread Starter
Senior Member
 
Join Date: Oct 2004
Location: Lake Stevens, WA, USA
Posts: 2,651
Abs pump

I am getting ready to head out on a cross country trip in the next few weeks and my abs pump has failed again. my bike is a 2007 K1200gt I think the motor crapped out and I could not get it working this time. Anybody know of a pump that needs a new home. Even one that triggers a abs fault? I maybe able swap parts with mine to get it going. I lost a bid war for one on ebay. The rest on ebay are quite pricey. Let me know if you know of one. Brian [email protected]

Brian Ley
WA State of mindless sheep
USA where everything is illegal
2007 K1200GT
2010 650GS
2000 k1200LT Sold but not forgotten
BMWOA 119892
sanjaun2 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old May 1st, 2015, 4:37 pm
Senior Member
 
kellenbenz's Avatar
 
Join Date: Apr 2002
Location: Tyler, TX, USA
Posts: 2,046
Re: Abs pump

Brian,

Module masters will rebuild it for $250 and it takes them a week. I had mine done for my RT last year and it was a perfect experience.

ModuleMaster

They also warranty it for 5 years.

Ron


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


735,834 miles on touring motorcycles since 1990

IBA 45658 MOA167437

2000 LTC 90,600 miles KIA (new)
2003 LTE 164,188 miles Silver (Purchased with 1687)
2008 R1200RT 176,196 miles (Purchased with 16458)
2017 R1200RT 84,612 miles (new)
Total BMW miles 497,451
1982 GL1100 rode 84108 miles (bought with 12012 sold 96120)
1988 GL1500 rode 12067 miles (bought with 19893 totaled 31960)
1989 GL1500 rode 142208 miles (bought with 20302 sold 162510)
Goldwing miles 238,383
kellenbenz is offline  
post #3 of 9 Old May 1st, 2015, 10:32 pm Thread Starter
Senior Member
 
Join Date: Oct 2004
Location: Lake Stevens, WA, USA
Posts: 2,651
Re: Abs pump

Thanks Ron, I called them earlier today. I suspect the bearing in the motor is going bad and slowing down the motor. They said that would not be replaced. Also said trying to remove the bearing would ruin the motor. I just may have to take this trip without abs. Just like the old days!

Brian Ley
WA State of mindless sheep
USA where everything is illegal
2007 K1200GT
2010 650GS
2000 k1200LT Sold but not forgotten
BMWOA 119892
sanjaun2 is offline  
 
post #4 of 9 Old May 2nd, 2015, 2:18 am
Senior Member
 
kellenbenz's Avatar
 
Join Date: Apr 2002
Location: Tyler, TX, USA
Posts: 2,046
Re: Abs pump

It was worth a try Brian. My problem was like most others in that the brushes were hanging up. You could tap on it and it would run again for a while.

Ron


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


735,834 miles on touring motorcycles since 1990

IBA 45658 MOA167437

2000 LTC 90,600 miles KIA (new)
2003 LTE 164,188 miles Silver (Purchased with 1687)
2008 R1200RT 176,196 miles (Purchased with 16458)
2017 R1200RT 84,612 miles (new)
Total BMW miles 497,451
1982 GL1100 rode 84108 miles (bought with 12012 sold 96120)
1988 GL1500 rode 12067 miles (bought with 19893 totaled 31960)
1989 GL1500 rode 142208 miles (bought with 20302 sold 162510)
Goldwing miles 238,383
kellenbenz is offline  
post #5 of 9 Old Jun 3rd, 2015, 9:19 am Thread Starter
Senior Member
 
Join Date: Oct 2004
Location: Lake Stevens, WA, USA
Posts: 2,651
Re: Abs pump

I was able to fix my abs pump and lube the bearing a day before leaving. I rode about 5K miles and the abs light never came on! except for the normal flashing light before you ride off. So far so good...... Original pump with 104K miles now.

Brian Ley
WA State of mindless sheep
USA where everything is illegal
2007 K1200GT
2010 650GS
2000 k1200LT Sold but not forgotten
BMWOA 119892
sanjaun2 is offline  
post #6 of 9 Old Jun 3rd, 2015, 11:14 am
IBR# 366
 
meese's Avatar
 
Join Date: Apr 2002
Location: West Linn, OR
Posts: 16,368
Garage
Re: Abs pump

Quote:
Originally Posted by sanjaun2 View Post
I was able to fix my abs pump and lube the bearing a day before leaving. I rode about 5K miles and the abs light never came on! except for the normal flashing light before you ride off. So far so good...... Original pump with 104K miles now.
That's good news, Brian.

Hope you enjoyed the trip, and came back with a saddlebag full of chiles.

Ken
Pacific NorthWet
'13 Dark Graphite Metallic K16GTLD, 24K miles and counting...
'09 Magnesium Beige Metallic K13GT, 63K miles miles and counting...
'02 Mauve Metallic K12LTC, 106K miles and sold
BMWLT#143, IBA# 366, MOA# 111996, SCMA# 24032


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


All lower 48 states plus Alaska on the K13GT in two weeks . . .

Some people see the gas tank as half empty. Some see it as half full. All I care is that I know where the next tankful is coming from...
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
meese is offline  
post #7 of 9 Old Jun 3rd, 2015, 11:29 am Thread Starter
Senior Member
 
Join Date: Oct 2004
Location: Lake Stevens, WA, USA
Posts: 2,651
Re: Abs pump

Ken, I ate a lot of green chilies, But to early for harvest season. Get to go back again in August/September thanks again for the advice on abs ideas.

Brian Ley
WA State of mindless sheep
USA where everything is illegal
2007 K1200GT
2010 650GS
2000 k1200LT Sold but not forgotten
BMWOA 119892
sanjaun2 is offline  
post #8 of 9 Old Jul 25th, 2015, 8:46 am
Junior Member
 
Lenbo's Avatar
 
Join Date: Jan 2009
Location: NW, FL, USA
Posts: 6
Re: Abs pump

Quote:
Originally Posted by sanjaun2 View Post
I was able to fix my abs pump and lube the bearing a day before leaving. I rode about 5K miles and the abs light never came on! except for the normal flashing light before you ride off. So far so good...... Original pump with 104K miles now.
Brian please tell us how you lubed the bearing , my abs is failing.

Have a Great Ride, Lenbo

2008 BMW K1200 GT
2000 HD Night Train
88 HD Softail Custom
86 1100 HD Sportster
69 900 HD Sportster
Lenbo is offline  
post #9 of 9 Old Jul 27th, 2015, 11:38 am Thread Starter
Senior Member
 
Join Date: Oct 2004
Location: Lake Stevens, WA, USA
Posts: 2,651
Re: Abs pump

Lenbo, I took the pump motor apart again and applied a small drop of lube to the bearing. This is not normally the problem. I tried totally disassembling the pump motor for better access to the brushes and I think I tweaked the bearing a little. The bearing is not meant to come off the shaft easily. Thats why module masters does not do that. Normal procedure is to stretch the springs that tension the brushes and to tweak the brush cages so they move without binding.

Brian Ley
WA State of mindless sheep
USA where everything is illegal
2007 K1200GT
2010 650GS
2000 k1200LT Sold but not forgotten
BMWOA 119892
sanjaun2 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Coming home from work.. ABS light lights up and ABS pump won't turn off Ksnarf K1200LT 19 Mar 1st, 2015 3:42 am
2006 LT ABS and Fuel Pump Fuse Hilton K1200LT 5 Feb 11th, 2014 9:55 pm
My Father purchased 2002 K1200LT with 7000 miles the abs pump stays on all the time Autodeal1 K1200LT 6 May 2nd, 2012 6:02 am
ABS pump not starting - rear only dslempke K1200LT 6 Dec 5th, 2009 9:34 am
BMW to introduce a "G" series motorcycle? eljeffe Bike Talk 24 Oct 10th, 2006 4:56 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome