Problem Integrating BlackBerry Storm2 - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Mar 24th, 2010, 9:35 pm Thread Starter
Senior Member
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,769
Problem Integrating BlackBerry Storm2

I'm not sure this is an audio system problem, and it's not a GPS problem, but it's an audio-GPS-phone integration question, or - more likely - a phone question.

I have an '05 LT with a Baehr intercom, Zumo 550 GPS and a BlackBerry Storm2. Before the Storm2, I was able to pair the GPS to the (previous) phone via BlueTooth, and could make/receive phone calls through the Zumo. With the Storm2 on board, and the GPS and phone paired, I can answer the call via the GPS but I have to press the Headset button on the phone for the call to work (otherwise, the caller can't hear me). This is inconvenient, not to mention impractical while on the road and unsafe! When the phone's headset jack is not in use, the "Headset" button is replaced by a "Speaker" button on the display.

We know the Baehr helmic mic is working because my passenger and I can talk back and forth with no issues.

I have tried the Storm2 three ways:
(1) Baehr 2.5mm cell phone cable > Radio Shack 2.5mm-3.5mm converter > Storm2 3.5mm headphone jack, paired to the GPS.
(2) same as (1), but BlueTooth disabled.
(3) paired via BlueTooth only (no physical connection to anything.

I have looked through all the Storm2's config menus and I don't see anything related to a headset mode. Other cell phones have an auto-answer option when in headset mode, making it truly hands-free.

Is there something I'm missing? Something else I need to do? I know Baehr makes a BlueTooth option (very expensive) but I don't think I need that... do I? My instinct says it's just a phone setting somewhere.

I'd appreciate any help!

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hschisler is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Mar 25th, 2010, 12:12 am
Senior Member
 
CohesiveTechnology's Avatar
 
Join Date: Feb 2009
Location: Keene, NH, USA
Posts: 280
Re: Problem Integrating BlackBerry Storm2

I don't know the answer but...
What you are describing is a problem with the hands free profile of the Storm. In Bluetooth there are "profiles" that control a device's ability to do things. When you hear stereo music you are using the A2DP profile. When you use a device like the Zumo to pick up a call, increase volume or mute (for example) you are using the HFP profile. It is common for devices to use more than one profile.

Bluetooth

It is also common for a device to not completely work on all profiles.

Make sure that the Storm and the Zumo have the latest software. I do not know the setting of these devices, but look for settings that would affect the HFP (perhaps check boxes in the configuration that should be true).

Following that, pair the Storm with another headset that has controls on it for picking up a call and so forth. This proves the profile works.

If your Zumo works with another phone then you can assume that profile is running.

Forget the cables altogether unless you want to be wired.

Bluetooth uses a master/slave scheme called a piconet. There can only be one master (here it would be the Zumo). Is your Storm sinked (sunk, sank, whatever) to another device while you are trying this?

Failing that, take it to the store where you purchased the Storm; they can help.

HTH
CohesiveTechnology is offline  
post #3 of 7 Old Mar 25th, 2010, 8:40 pm Thread Starter
Senior Member
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,769
Re: Problem Integrating BlackBerry Storm2

Thanks for the ideas. Here is some additional info. It doesn't help much, it just answers a few of your questions.

I have successfully used the Storm2 with a Plantronics BT headset off of the bike. No issues whatsoever.

While on the bike, the only BT devices I have are the GPS and phone.

Through more experimentation last night, the only way I could make the new phone work (integrated into the audio system) was to press the "headset" button on the Storm2 (after pressing "Answer" on the GPS, of course).

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hschisler is offline  
 
post #4 of 7 Old Mar 25th, 2010, 9:06 pm
Member
 
BlackWing18's Avatar
 
Join Date: Aug 2004
Location: Alexandria, ON, Canada
Posts: 70
Re: Problem Integrating BlackBerry Storm2

Howard, not sure if my input will help you diagnose your situation or not...but I have a similar problem using my new Blackberry Bold 9700.

For the last 3 years I have been very happily using my '05RT for rides when 'on call' by having my Motorola 'flip phone' paired with my Autocom Active 7 with the optional Bluetooth Dongle installed. I also have my Garmin 376c connected to the Autocom by stereo 3.5mm lead which gives me my XM radio and GPS direction audio ( when selected, but almost never, too annoying! ).

So when the company dictated a new Blackberry device was required back in January I didn't expect a problem...it has bluetooth built in of course. And I had been using it with absolutely no problems in my vehicle pairing to my Garmin Nuvi 760, it pairs automatically whenever the vehicle was powered up. No 'auto answer' or 'out of the holster' selections required.

Went out to the shop a few weeks ago for my first ride of the year ( YAY !! ) and went to 'pair' the new BB to the Autocom dongle, and no luck. Ever.

Ended up calling Autocom in the UK and having a new 'updated' dongle shipped to me here in Canada. Now that one 'pairs' with the BB but the phone refuses to auto answer. And when I push 'answer' on the phone I can hear the caller but they cannot hear me!

No solution found so far! I'll probably send the new 'expensive' dongle back to England...don't know what to try after that.

Jim

'05 R1200RT Red
Aluminum GPS mount:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Replacement windshield arms:

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
BlackWing18 is offline  
post #5 of 7 Old Mar 26th, 2010, 1:54 pm Thread Starter
Senior Member
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,769
Re: Problem Integrating BlackBerry Storm2

I responded just last night to your similar thread. Yes, our "problems" are similar - if not the same.

I think it has to do with the phones' profiles and the lack of old-school headset settings. As you point out, our older phones could be configured to auto-answer when a headset was plugged in.

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hschisler is offline  
post #6 of 7 Old Jun 14th, 2010, 9:52 pm Thread Starter
Senior Member
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,769
Re: Problem Integrating BlackBerry Storm2

Update:
I have installed the latest firmware on both the BlackBerry Storm 2 and the Zumo 550 GPS. Still no good, so I'm currently Googling this problem. The situation still is: I can answer an incoming call via the GPS; I can hear the calling party, but they can't hear me. I would suspect the microphone is not working, but it works fine as an intercom.

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hschisler is offline  
post #7 of 7 Old Jun 14th, 2010, 11:37 pm
Senior Member
 
mwnahas's Avatar
 
Join Date: Dec 2004
Location: Bedford Hts, OH, USA
Posts: 4,218
Re: Problem Integrating BlackBerry Storm2

Hey Howard, I don't have the toys you have, but I do have a Baehr. I had the same issue with trying the BT on my 2820 and my Razor and ended up just wiring the phone to the intercom.

I don't think I understand or follow you how it could work.

Your head set is wired to the intercom, the Zumo is wired to the intercom, but is it two way connection? Your sound from the zumo goes to the intercom but is there a cable from the intercom to the zumo Mic input? I don't know if Baehr has such a cable configuration. Do you have a second mic that goes to the Zumo?

Maybe the Zumo can hear your phone via BT, but it can't hear you? Unless you got two mics in your helmet?

Somehow your wired headset mic which goes to the intercom has to also get to the Zumo mic input or you also have a BT Mic in your headset?

All I have are questions.

Just Go
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mike
Cleveland Ohio
2019 K1600b Grand America, Blue Max.
mwnahas is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird electrical problem ronbok K1200LT 5 Jul 2nd, 2008 11:37 pm
Problem with a BMW car - Am I being unreasonable? DanDiver Chit Chat 8 Dec 20th, 2007 12:51 pm
Intaride RP-1 and cell phone problem bowlesj Intercom, CB, & 2-Way Radios 0 Nov 7th, 2007 9:15 pm
Motolight problem lnowell Lighting 4 Sep 18th, 2007 11:14 am
Battery problem or what else johnkeyes K1200LT 2 Feb 13th, 2006 8:14 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome