CB / Com system - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 2 Old Oct 11th, 2007, 10:12 am Thread Starter
tpg
Junior Member
 
Join Date: Jun 2005
Location: , ,
Posts: 27
CB / Com system

My K1200LT (03) is at the dealers (for two weeks). I had the com system added about two years ago and after some frustrating false starts and help from J&M it has worked well until recently. I broke the electrical connection on the antena, didn't realize that I had to undo the allen screw on the base. The dealership installed a new antena and at the first opportunity to use the CB on a ride with my brother on his RT, he could hear me but I couldn't hear him. I can hear, in my helmet, my Garmin 2730, the com system radio and ipod. The tech at my dealership is frustrated and told me that they don't get training on CB's. I called Sierra of Ohio and the tech their suggested that it might be my brother's CB not transmitting, but the local tech ruled that out using a CB in the shop. J&M has not responded this time to several e-mails sent by the dealership. I have read on this forum that CB antenas have to be tuned. Should I have the dealership put it back together and bring it to a CB professional? I also have an 06 R1200GS with a J&M CB which is fine. Thanks.
tpg is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old Oct 24th, 2007, 3:51 pm
Lifetime Supporter
 
GBaker's Avatar
 
Join Date: Sep 2006
Location: Summerville, South Carolina, USA
Posts: 287
That does not sound like the J & M I have dealt with. I am not sure what the electrical connection is you refer to. But would think propably the antenna cable that is one of the BMW antenna parts (which at that time was probably supplied to BMW by J & M). Or it may be an antenna ground wire. Either of which should be simple fixes.

I do understand J & M and BMW are not or have not been on the best of terms for a while since BMW changed suppiliers. But would think J & M and particularly John Lazzeroni would be of assistance on one of their own products and especially to their customers. They were of great help to me on the helmet headset I got for my '06 LT. They do get testy re BMW and the VOICE systems.

I suggest you call them and tell them the model etc on your cb, how long you have had it, the problem, and if possible avoid telling them it is on a BMW or at least tell them that after they have had a chance to respond to the problem. And if neccessary that it has nothing to do with the VOICE comm system. Here is the contact info I have used.

http://www.jmcorp.com/

John Lazzeroni, J&M Corporation President [email protected]

Phone Toll Free in U.S and Canada
1-800-358-0881
Outside the U.S.A. 1-520-624-7000
FAX (24 hour) 1-520-624-6202

J&M Corporation
1415 South Cherry Avenue
Tucson, Arizona 85713-1997
USA

Hope you get it straight.
GBaker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening the Com System? LTPenguin Intercom, CB, & 2-Way Radios 6 May 5th, 2007 11:50 am
Comm system via speakers and headset? fitsman Intercom, CB, & 2-Way Radios 2 Sep 6th, 2006 8:21 am
New ABS System and Advanced Stability Control Details eljeffe Bike Talk 3 Jul 17th, 2006 12:58 am
Help - 2610 Hoolk-up to Comm System KYLT05 K1200LT 4 Apr 10th, 2006 10:36 pm
Spiii Compatibility With Voice Com System Lynn_Keen GPS 3 Nov 19th, 2005 9:01 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome