Regular radio question - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 3 Old Oct 9th, 2007, 8:05 am Thread Starter
 
Join Date: Oct 2007
Posts: 19
Regular radio question

No reception on my regular bike radio..even the closest strong stations. Can't seem to find a thread on why. Can anyone help so I can finish my intercom install?
parocket is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old Oct 9th, 2007, 10:07 am
Senior Member
 
RVB1019's Avatar
 
Join Date: Jan 2005
Location: Long Island , NY, USA
Posts: 1,733
Garage
Quote:
Originally Posted by parocket
No reception on my regular bike radio..even the closest strong stations. Can't seem to find a thread on why. Can anyone help so I can finish my intercom install?
My guess- The Antennae wire came loose in the back of the unit. The problem is you have to remove all of the tupperware to get to the back of the radio.

Does it play through the tape/CD player? If not, just unhook the battery overnight and it may clear.

Did you check the fuse under the seat? Could it be blown?

The first time I peeled my LT a part it took just under 6 hours. The second, just under 4. I hear that 3 is the average.

Good Luck!

Rob V.B.
2015 Triumph Explorer 1200
2007 BMW GT (SOLD)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2003 BMW LT (SOLD)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2002 BMW R1150 traded for 2002 Yamaha FZ1 traded for a 2003 GSXR 750

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
RVB1019 is offline  
post #3 of 3 Old Oct 9th, 2007, 10:16 am
Senior Member
 
Join Date: Sep 2003
Location: Austin, TX, USA
Posts: 878
A number of people have reported problems with the antenna. There is a small spring in the base of the antenna that can become corroded. Much easier to check than the inputs to the radio itself.

Res ipsa loquitur, sed quid in infernos dicet?

Alan Stuber
2003 K1200 LTC Titan Silver
Austin, Texas



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
astuber is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
CB radio question jdunique K1200LT 8 Oct 21st, 2007 2:26 pm
Radio removal connector question? MickS K1200LT 8 Jan 24th, 2007 7:18 am
A stupid question (hopefully) about LT's radio Andy-SC K1200LT 10 Jan 9th, 2007 5:19 pm
Radio Question...Searched Hall of Wisdom hybridcage K1200LT 7 Dec 4th, 2006 1:32 pm
Question for MyFi XM Radio users??? Portguyofva Satellite Radio 4 Mar 9th, 2006 7:46 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome