kudos to Motocomm - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Mar 27th, 2007, 11:57 pm Thread Starter
Senior Member
 
dwsdad's Avatar
 
Join Date: Jul 2004
Location: Marshall, TX, USA
Posts: 1,751
kudos to Motocomm

About 5 yrs ago I bought the Motocomm AudioBoss AB-1 and it served me well - until recently. The FM radio quit. It wouldn't work with a 2-way radio. And the mic had an intermittent short that i traced back to the unit. I called them to ask about repair and they said to send it in. A month went by and they finally got back to me. A month may sound like a long time, but I figured the darn thing wasn't working anyway, so i really wasn't missing too much. Anyway, they call and tell me that it isn't really worth their time to repair it and would I mind if they sent me the updated version, the ST-1. Same little blackbox, but without all the cords dangling from it and improved electronics. Tonight, about 10 days later, the UPS guy drops a box from Motocomm. Inside is a brand new, still shrink wrapped ST-1, complete with all the connectors, cables, mics, headsets, and instructions! I was expecting just unit, not the whole flippin' thing! Anyway, I thought it was pretty cool that this company just flat replaced a 5+ yr old unit with a new one, no questions asked.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'99K1200LT - "Bertha" - gone, but not forgotten!
'86 Concours - "Horse with no name" (under reconstructive surgery)
'06 K1200GT - "Road Rocket"
Marshall, Tx


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dwsdad is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Mar 28th, 2007, 12:40 am
Lifetime Supporter
 
deputy5211's Avatar
 
Join Date: Oct 2006
Location: Dallas Area, TX, USA
Posts: 4,877
Wow, Doug, that's pretty awesome. Many vendors get the talking part done, but fail miserably when it comes to the doing part. Nice to see when one goes above and beyond on their own accord.

Antony (Tripod)
Dallas' Northern Suburbs
-----------------------------------------------

If you want to be happy for a day, drink.
If you want to be happy for a year, marry.
If you want to be happy for a lifetime, ride a motorcycle.

-----------------------------------------------


'05 K1200LT - Dark Graphite - RIP 04 OCT 2015
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


'99 Road King Classic - Custom Blue/Silver & Chrome - "My Baby" Gone but forever in my heart!

and many, many others.
*

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
deputy5211 is offline  
post #3 of 6 Old Mar 28th, 2007, 11:28 am
Lifetime Supporter
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Hey, Doug... I had the same unit but the thing was always "on"... constantly open mic. Too distracting for me... Let us know if the new one resolves that ...

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
 
post #4 of 6 Old Mar 28th, 2007, 12:34 pm Thread Starter
Senior Member
 
dwsdad's Avatar
 
Join Date: Jul 2004
Location: Marshall, TX, USA
Posts: 1,751
I'll let you know. How did you have the switch set? I always had mine on the Medium setting and never had an issue.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

'99K1200LT - "Bertha" - gone, but not forgotten!
'86 Concours - "Horse with no name" (under reconstructive surgery)
'06 K1200GT - "Road Rocket"
Marshall, Tx


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dwsdad is offline  
post #5 of 6 Old Mar 28th, 2007, 1:15 pm
Lifetime Supporter
 
cfell's Avatar
 
Join Date: Apr 2004
Location: Round Rock, TX, USA
Posts: 7,794
Med did not work for me.. too much ambient noise perhaps...still, the "open mic" just duplicated existing noise... and was a distraction...

...............
J.M.J...
Dcn Channing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
cfell is offline  
post #6 of 6 Old Oct 4th, 2007, 5:07 pm
Senior Member
 
Join Date: Jan 2007
Location: Calgary, Alberta, Canada
Posts: 339
Motocomm has also served me well. I had a dead speaker plug and asked them if I could buy just the plug.

Thanks to Eric Lewis, a complete headset with mic and speakers arrived at my door 5 days later...FREE of charge.

My bad, I still owe them a testimonial for the outstanding service.

If you're out there Eric, my apologies, and I hope this helps.

2000 K1200LT
1981 Honda CBX ( kind of for sale)
K1200LTryder is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Kudos... NCoe Chit Chat 5 Mar 26th, 2007 12:58 pm
Kudos to Olympia Moto Sports Crestwood330 Rider's Gear & Luggage 11 Sep 20th, 2006 8:32 am
Kudos to HID-ONLINE RMW K1200LT 0 Oct 4th, 2005 10:59 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome