2005 K1200LT Dead RADIO and INTERCOM - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Mar 25th, 2018, 4:36 pm Thread Starter
Junior Member
 
valcenius's Avatar
 
Join Date: Jul 2010
Location: Colorado Springs, CO, USA
Posts: 25
2005 K1200LT Dead RADIO and INTERCOM

Yesterday my radio quit while riding. I pressed power button and it came back on. When I stopped to refuel, it wouldn't come back on.

While looking around for possible problems, I noticed that the intercom in the oddment box isn't lighting up.

Preliminarily, I checked all fuses. They're good.

Anyone know a problem common to both items? I'm looking for a wiring schematic to see if there is a possibility of a plug that might have come loose. I believe the radio "ON" button is actually a "wake-up" signal to activate the radio and amp (does it also turn on the intercom?)

I believe I have the V.o.i.c.e. II unit (Rotary knob and green LED indicator) and a J&M 2005 CB

Any help is appreciated.

Jay
Colorado Springs, CO
valcenius is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
A New Radio Problem? RVB1019 K1200LT 7 Sep 3rd, 2007 6:55 pm
K1200LT Intercom - Help Guys! dsidler K1200LT 2 Apr 29th, 2007 11:55 am

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome