My Baehr is Working - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Jul 1st, 2006, 11:11 pm Thread Starter
Lifetime Supporter
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,778
My Baehr is Working

This shouldn't be worthy of a separate thread, but from the effort it's taken to get to this point I'll go ahead with it. I've had several previous posts on this topic; some of you have followed those threads, offered advice, provided assistance, etc. Bottom line: new Baehr was delivered today, I plugged it in and we have liftoff! Radio and CD into both helmets, with intercom functionality. It's almost midnight and now I have to wait until tomorrow after church to try it out on the road (it's only been in use in the garage since I got home a few minutes ago).

Here's the short story:
1. Ordered the unit from Raffy. It arrives; got 2 helmet sets installed (Sierra Electronics, Troy, OH).
2. I install it the intercom. No audio in helmets. Leave the same day for four-day trip to KY with no intercom.
3. Talk w/Baehr; talk w/Raffy. Send the main unit and the RUP box (the black junction box that installs beneath the rear seat) back to Baehr USA/National Cycle. They said they would test the main unit, but did not (found this out later). They see a broken piece of plastic on the cable connection from rear to front units and assume that's the culprit. They sell me another RUP at their best possible price
4. New RUP arrives; I install it. Still no sound. #@$%!
5. Ride to Troy, OH to get helmets tested; they are fine.
6. Ride to Mansfield, OH to meet grizzly (Mike Gerlica); we swap Baehrs between bikes. The main unit is the culprit!
7. Call Baehr USA with this info;. I ship them the old unit, they overnight me a new unit, guaranteeing Saturday delivery. We wait around the house today for it to arrive; can't wait any longer, and we leave at noon for our day trip to PA. Unit is delivered an hour after we leave.
8. Return home at 11:00 pm, install unit, all is good.

Thanks to Raffy for his top-notch support (pre- and post-sale).
Thanks to Baehr USA for stepping up and overnighting me the unit. (Although I think they owe me $$ for the RUP box which may have been OK after all).
Thanks to Mike Gerlica for meeting me halfway between Columbus and Cleveland with his LT and Baehr. Swapping intercoms with him was the determining factor in finding the culprit.

I would not hesitate to purchase this product again, even with these troubles. It's entirely possible the problem was caused by me when I first connected helmets, etc., to the Baehr. I may have broken the plastic connector, which may have shorted out the intercom. Learn from my mistake: be careful when plugging the cords in, ensuring they are lined up correctly.

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by hschisler; Jul 1st, 2006 at 11:25 pm.
hschisler is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Jul 2nd, 2006, 12:13 am
Senior Member
 
motorhead's Avatar
 
Join Date: Feb 2004
Location: Old Hangtown, CA, USA
Posts: 2,406
So Glad you have a working system now !!!

You and your S/O will love being able to talk normally, plus all the flexablity the system offers. You will LOVE IT ... Sure know we do.

Regards.
Scott

"00" Canyon Red LTI ~ Well Farklized ~ Bug Splattered
Our "semi" quiet riot
*** Trailer Too ***

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
T
wisties Required
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

motorhead is offline  
post #3 of 5 Old Jul 2nd, 2006, 5:51 pm
Member
 
GeorgeS's Avatar
 
Join Date: May 2005
Location: Barrie, ON, Canada
Posts: 82
Baehr

Howard,
I purchased my Baehr same time as you from Raffy and I had a problem with the main unit also, I sent it back to baehr usa and am still waiting for the repair or new unit, seems they must of had a few bad units. Glad to hear yours is working, hopfully mine arrives soon.
GeorgeS is offline  
 
post #4 of 5 Old Jul 2nd, 2006, 6:22 pm
Senior Member
 
mwnahas's Avatar
 
Join Date: Dec 2004
Location: Bedford Hts, OH, USA
Posts: 4,238
Wow, 2 bad Baehrs! who'd a thunk.

Just Go
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Mike
Cleveland Ohio
2019 K1600b Grand America, Blue Max.
mwnahas is offline  
post #5 of 5 Old Jul 2nd, 2006, 9:22 pm Thread Starter
Lifetime Supporter
 
hschisler's Avatar
 
Join Date: Sep 2005
Location: Rushville, OH, USA
Posts: 7,778
That is velly intelesting...

Quote:
Originally Posted by GeorgeS
Howard,
I purchased my Baehr same time as you from Raffy and I had a problem with the main unit also, I sent it back to baehr usa and am still waiting for the repair or new unit, seems they must of had a few bad units. Glad to hear yours is working, hopfully mine arrives soon.
George: same symptoms as what I described -- no sound after initial installation? These things have a terrific reputation, but like most man-made objects they can be manufactured with a flaw, or fail.

Baehr USA/National Cycle was surprised to hear I had a problem. Did you talk with Tom Mackey or Carl Reaver at NC? They are the 2 sales/support guys I've talked with for the past month.

The good news (as mentioned) is that the replacement unit is just fine. Will give it the road test tomorrow on the way to work.

Howard Schisler
2015 BMW K1600GTL
2009 BMW K1200LT - 60k miles
2012 BMW F650GS (sold)
2005 BMW K1200LT - "Gray Ghost", traded at 120k miles
2005 Honda Shadow 650 (sold)
AMA, IBA, BMW MOA. CCRs: Braselton 2006, Osage Beach 2007, Duluth 2012


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
[/URL]
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
hschisler is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Still Having Problems w/the New Baehr hschisler Intercom, CB, & 2-Way Radios 7 Apr 25th, 2007 11:43 am
Looking for Baehr Owners in Ohio hschisler Mid West 14 Jul 10th, 2006 6:50 pm
Fix for the Baehr K1200LT and CB radio. CARNEYM Intercom, CB, & 2-Way Radios 5 Jan 15th, 2006 4:01 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome