Replaced NAV II mount with 665LM mount - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Mar 18th, 2013, 11:07 am Thread Starter
Senior Member
 
Triker's Avatar
 
Join Date: Sep 2005
Location: Longmont, CO, USA
Posts: 189
Replaced NAV II mount with 665LM mount


Ok guys, here goes.
Long story... started with NAV II and factory mount on my 04 LT. Switched to SP 2820, and went thru 3 units (all three died). Was using my old NAV II just as a speedometer. Maps woefully out of date.

Then, saw the add for Touratech's package deal for a 665LM AND locking mount. Investigated it pretty thoroughly and noticed that there were four holes in the mount that seemed like they might just match the four holding the factory mount for the NAV II. I called them and talked to a very knowledgable tech who said even if they didn't match exactly, the mount was aluminum and could be drilled to fit. So, I sprang for the package. Not cheap, but I've looked at many other options and the 665LM was the only one I felt was truly viable. I also didn't want to get one that would lose support from Garmin in a year or two. (Side note. I hate Garmin for their pricing, and lack of compassion for my having just purchased a lifetime maps for my last 2820 and when it broke, they weren't supporting in ANY fashion the 2820. Didn't even offer to refund my lifetime maps cost and wouldn't consider moving the license to another unit. Ah, but I digress)

The kit came in, and yesterday, with the help of the Trike dealer in Windsor, CO (NECE, Monty Loftus, p.s. He did all the work) we removed all the skins (Boo BMW for requiring this much effort to get into the top of the bike), removed the old mount and cables, and installed the new mount.

When removing the old cables, the holes between the pass-thrus did not line up and the plastic hole in the top most hole had to be reamed out about 3/4 inch on both sides to allow the new cable to fit thru. We unhooked the old cables from their connectors, used a checker to find the right pins for ground and power, spliced them in, turned on the LT's key and viola', the unit powered up. Then, all that remained was to reinstall all skins, put the unit into the new mount, secure it with the key and come home.

One other note, when removing the old mount, (four metric screws with 2.5 hex heads(metric) lift the grey plastic hood off the actual mount), be careful not to lose the four captive square nuts. they will fall out very easily. they're captive, but only on three sides. There is an open sides on all four. So remove those as soon as you remove the grey plastic hood,

Otherwise, it's really straight forward and looks like it came that way from the factory.
Attached Thumbnails
Click image for larger version

Name:	IMAG0012.jpg
Views:	55
Size:	1.22 MB
ID:	37950   Click image for larger version

Name:	IMAG0013.jpg
Views:	52
Size:	1.31 MB
ID:	37951   Click image for larger version

Name:	IMAG0014.jpg
Views:	51
Size:	1.34 MB
ID:	37952   Click image for larger version

Name:	IMAG0015.jpg
Views:	49
Size:	1.21 MB
ID:	37953   Click image for larger version

Name:	IMAG0016.jpg
Views:	45
Size:	1.14 MB
ID:	37954  


Triker
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Longmont, CO
2005 LT Hannigan Trike
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Triker is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Final drive replaced last November and still??? nearmisses K1200LT 11 Nov 17th, 2010 11:19 am
Zumo mount on BMW k1200 lt Keithb GPS 48 Apr 28th, 2010 11:15 pm
LT camera mount test pics yechave Other Stuff 3 Aug 10th, 2008 10:58 pm
Garmin 2720 amps mount Tourdog GPS 7 May 15th, 2007 3:53 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome