BMW Zumo Connection Problem - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old Aug 7th, 2009, 10:06 am Thread Starter
Senior Member
 
Join Date: Jun 2009
Location: Wilmington, NC, USA
Posts: 747
BMW Zumo Connection Problem

I've had a BMW Zumo on my RT for about a year when it went dead day before yesterday.
Wouldn't respond at all to on/off button while on the bike and when I took it out of the cradle, it was still dead so I hooked it to my wall charger and saw that it had a dead battery.

The battery recharged fine and it appears that the cause was a poor connection either inside the unit at the battery terminals or in the cradle somewhere. Anyway, I cleaned both with Deoxit (a connection cleaner one can sometimes find in big box home builder places) and everything seems to be OK again.

Not sure how common "funky connections" might be. They are pretty well engineered so I wouldn't expect this to be too common.

Anyone else had this happen?
racer7 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old Aug 7th, 2009, 12:19 pm
Jim
Slow Old Guy
 
Jim's Avatar
 
Join Date: Apr 2002
Location: Idyllwild, CA, USA
Posts: 2,012
Re: BMW Zumo Connection Problem

If you go here...

http://www.zumoforums.com/

there is some discussion about this. You have to register to read the forums, but there is a lot of info.

Jim Anderson
Idyllwild, CA
'04 Ural Tourist
'08 Tiger
Jim is offline  
post #3 of 5 Old Aug 8th, 2009, 10:58 am Thread Starter
Senior Member
 
Join Date: Jun 2009
Location: Wilmington, NC, USA
Posts: 747
Re: BMW Zumo Connection Problem

Jim,
Thanks for the tip. Wow- a quick search found a 53 page thread about dead Zumos and apparently excellent Garmin customer service in dealing with the issues. Educational for sure.

The dead battery in mine might be from a bad connection (as I originally thought) or possibly a software glitch (I just synched a new IPhone and deleted some other pairings) that left the thing running with a dark screen...Apparently the latter isn't a rare event.
If its the software I guess I'll see it again soon though no issues at the moment.
I did note the battery screw wasn't my version of tight and I did tweak the connectors a bit also to ensure a tight fit - I hope that's all it is. Even though Garmin seems to have excellent service I'd rather have mine keep working...

The zumoforums guy must be someone's corporate IT geek. An 8 character password and non-automated registration for a site of the type is a bit of overkill.
racer7 is offline  
 
post #4 of 5 Old Aug 8th, 2009, 11:24 am
Jim
Slow Old Guy
 
Jim's Avatar
 
Join Date: Apr 2002
Location: Idyllwild, CA, USA
Posts: 2,012
Re: BMW Zumo Connection Problem

Quote:
Originally Posted by racer7
The zumoforums guy must be someone's corporate IT geek. An 8 character password and non-automated registration for a site of the type is a bit of overkill.
Glad it helped. Yea, I was a bit surprised that you couldn't just read the forum without registering.

Jim Anderson
Idyllwild, CA
'04 Ural Tourist
'08 Tiger
Jim is offline  
post #5 of 5 Old Aug 9th, 2009, 9:27 am
Senior Member
 
FredR's Avatar
 
Join Date: Sep 2005
Location: Burlington, CT, USA
Posts: 236
Re: BMW Zumo Connection Problem

On my last trip going to the MOA rally in Johnson City my Zumo 550 stopped and none of the refresh tricks worked except removing the battery and putting it back in (Cold boot). I had to go to a hardware store to get a 2mm(?) allen wrench to remove the battery. From that day forward I carry the correct allen wrench on the bike and in the car. I learned that trick and the other reset tricks from the Zumo site mentioned above, very helpful.

Fred Rosenbaum
NF1U
2006 K1200LT Totaled
2005 R1200GS
FredR is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Final Drive failure - no BMW warranty support BobbyLT K1200LT 28 Aug 21st, 2014 3:14 pm
2002 BMW K1200LT Headlight problem DesertCoyote K1200LT 10 Sep 17th, 2010 2:43 pm
mount bmw zumo to lt mmariog GPS 5 Feb 24th, 2008 12:25 pm
BMW Branded Zumo powwow GPS 4 Nov 20th, 2007 7:04 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome