Zumo 550 - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 1 Old Jan 17th, 2009, 7:49 pm Thread Starter
Senior Member
 
GVPurvis's Avatar
 
Join Date: Mar 2008
Location: Maylene, Al, USA
Posts: 235
Zumo 550


Just got my Zumo 550 back from the factory.The Garmin tech tried to fix it over the phone,and by e-mail,no luck.So he sent me a brand new unit.It seems to work fine althought it is to cold to get on the bike and give it a workout.The new unit also has some upgrades that my old unit didn't have.Now I can put GPS coordinates in it.Garmin service rocks..
GVPurvis is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Zumo 550 and phone constantly disconnecting? petevandyke GPS 10 May 12th, 2010 7:44 pm
Zumo 550 SOLVED! rdog GPS 0 Jul 5th, 2008 5:14 pm
Zumo and my concerns - Email to Garmin strsout GPS 10 May 10th, 2008 8:24 pm
The Final Word on ZUMO and 2730--From Garmin Tech Support petevandyke GPS 9 Apr 28th, 2008 11:19 am
Zumo & Bluetooth Phone to Autocom on the cheap wcarter GPS 1 Sep 2nd, 2007 2:24 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome