Mapsource can't "find" my BMW Nav II - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old Sep 27th, 2008, 8:58 pm Thread Starter
Senior Member
 
Allred's Avatar
 
Join Date: Jul 2007
Location: Riverton, Utah, USA
Posts: 155
Question Mapsource can't "find" my BMW Nav II

My '03 LT came with a BMW Nav II, which works just fine on its own.

However, I cannot get my PC Mapsource to recognize it in order to download maps, routes, waypoints, etc from PC to Nav II.

When I hook Nav II up and try to download from PC to Nav II, Mapsource says "devices found, but doesn't have proper settings"...or something similar. "Concludes with "change interface option on your GPS to Garmin or host" How does one do that? I can't find any menu on the Nav II that has interface settings, nor does the owner's manual talk about it.

Mapsource works fine with my Garmin Zumo, and Garmin Map60Csx GPS units which I have used for years with no problems.

Is this a BMW Nav glitch? Is the Nav II different from Garmin 2610?

To say I'm confused would be an understatement.

Thanks for any suggestions.

Bob Allred
Riverton, Utah
'03 K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2 old Airheads & 1 Oilhead



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Allred is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old Sep 28th, 2008, 2:20 am
Senior Member
 
Rockdoc's Avatar
 
Join Date: Jun 2004
Location: Oakwood, Derbyshire, UK
Posts: 824
Re: Mapsource can't "find" my BMW Nav II

I think there's something odd about the current USB drivers. I need to rerun the setup program every time I want to connect my NavII to my computer.

Keith


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
UK 2004 K1200LT Lux - Katie
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Rockdoc is offline  
post #3 of 4 Old Sep 28th, 2008, 5:39 am
 
Join Date: Feb 2004
Posts: 4,905
Re: Mapsource can't "find" my BMW Nav II

Sounds to me like a USB drivers issue entirely. Download these drivers and install. HTH
messenger13 is offline  
 
post #4 of 4 Old Sep 28th, 2008, 6:00 pm Thread Starter
Senior Member
 
Allred's Avatar
 
Join Date: Jul 2007
Location: Riverton, Utah, USA
Posts: 155
Thumbs up Hooray! Success

Quote:
Originally Posted by messenger13
Sounds to me like a USB drivers issue entirely. Download these drivers and install. HTH

Thanks for the suggestion Joe. You were right, downloading the drivers according to insstructions was just the thing.

Mapsource now "sees" my Nav II, and I can transfer waypoints, routes, etc.

I am a happy camper once again!

Bob Allred
Riverton, Utah
'03 K1200LT
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2 old Airheads & 1 Oilhead



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Allred is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Garmin 550 next to BMW Zumo Oldmanwheeler GPS 23 Jan 1st, 2012 10:05 pm
BMW Recall- 2007 Models RVB1019 Bike Talk 3 Nov 9th, 2011 7:04 pm
Just got a "New" 19-ball Crown Bearing from Chicago BMW this week? Holy Cow K1200LT 29 Oct 19th, 2007 11:58 pm
UK to develop BMW techs Bayliner2052 Chit Chat 2 Dec 14th, 2005 5:47 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome