Navigator I Won't Power Up - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 7 Old Aug 10th, 2008, 8:37 am Thread Starter
Senior Member
 
asleeplessknight's Avatar
 
Join Date: Jul 2008
Location: Cape Elizabeth, ME, USA
Posts: 215
Question Navigator I Won't Power Up

Bought my 03 LTE a few weeks ago and get no power to the Navigator I (the cb radio won't power up either--not sure if it's related). A couple questions: 1) where's the fuse for the GPS? How do I remove the GPS from the bracket?
Note: previous owner recently changed battery.

Thanks!

Robert
Asleeplessknight
Beemer Rookie
asleeplessknight is offline  
Sponsored Links
Advertisement
 
post #2 of 7 Old Aug 10th, 2008, 10:03 am
Senior Member
 
Join Date: May 2007
Location: El Paso, TX, USA
Posts: 223
Re: Navigator I Won't Power Up

To remove the Navigator I:

There are three connectors: the knurled antenna connector, the four pin power connector, and a earphone-type plug. Disconnect these three.

Then there is a knurled knob on a screw holding the Navigator to the frame. Loosen that screw. Press down slightly on the GPS and it should pop out.

When it's out, put in a new set of batteries, being careful to observe the polarities.

At that point, it should power up (though it won't give you any GPS data because it's not connected to the antenna).
ljjohns is offline  
post #3 of 7 Old Aug 10th, 2008, 11:04 am Thread Starter
Senior Member
 
asleeplessknight's Avatar
 
Join Date: Jul 2008
Location: Cape Elizabeth, ME, USA
Posts: 215
Re: Navigator I Won't Power Up

PERFECT!

The pressure I was applying was feeling like I was going to twist the bracket off the dash.... so I would hesitate... needed the confidence check...

Thanks LJ

Robert
asleeplessknight is offline  
 
post #4 of 7 Old Aug 10th, 2008, 1:35 pm
Senior Member
 
Join Date: May 2007
Location: El Paso, TX, USA
Posts: 223
Re: Navigator I Won't Power Up

Garmin still has a contact number for the BMW Navigator: 866-455-7012. They have been helpful to me.

I was lucky: the PO of my 03 LTC had kept everything. I have all the manuals, the parts for operating the Navigator off of the bike (a AC/DC power supply/antenna) and even a massive cigarette lighter power supply (along with a beanbag to set the Navigator on a dashboard).

The folks at Garmin may be able to help you get the documentation for your Navigator and how to update the map info; you need to check and see if there's a removable chip (I think it's on the right side under a one-inch rubber cap) which is used to update stuff from the software.

Good luck.
ljjohns is offline  
post #5 of 7 Old Aug 10th, 2008, 5:03 pm Thread Starter
Senior Member
 
asleeplessknight's Avatar
 
Join Date: Jul 2008
Location: Cape Elizabeth, ME, USA
Posts: 215
Re: Navigator I Won't Power Up

LJ.. Oh yeah.. you read my mind... I've already downloaded the update software... manuals... and have ordered the cable (found a low cost substitute online) to connect to the pc. It does have the chip installed.

.... of course, we won't talk about the fact that I left the key ON... and wandered off to buy some lithium batteries... ... now the only thing powering up on her is the GPS!
@@#$%#$(*@#$%&%
I can spell I-D-I-O-T too!
All I need on this message board is a Homer Simpson Doohht sound effect.

A Dope Slap works fine.

Robert

Asleep(at the wheel)Knight
asleeplessknight is offline  
post #6 of 7 Old Aug 10th, 2008, 6:26 pm
Senior Member
 
Join Date: May 2007
Location: El Paso, TX, USA
Posts: 223
Re: Navigator I Won't Power Up

Now that you've got it powered up, you'll find new depths of meaning to the term "klunky."

But it's useful in a variety of ways. For starters, it's easier to see and more accurate than the speedo...
ljjohns is offline  
post #7 of 7 Old Sep 1st, 2008, 9:27 pm Thread Starter
Senior Member
 
asleeplessknight's Avatar
 
Join Date: Jul 2008
Location: Cape Elizabeth, ME, USA
Posts: 215
Re: Navigator I Won't Power Up

....weeks later...

now that I got the batteries.. and the gps is technically working.. but, it is working on battery power... is there an inline fuse on the Nav I that I can access without taking off a bunch of tupperware? At the same time, the CB handset does not power up... I wonder if it might be related to the no power sit on the gps?

Anybody have any ideas or suggestions?

Asleeplessknight
'03 LTE Titan Silver

Last edited by asleeplessknight; Sep 1st, 2008 at 10:30 pm.
asleeplessknight is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Problem TomMoss Satellite Radio 3 Aug 1st, 2010 10:48 pm
iWay 500c audio problem was GPS 11 Apr 26th, 2007 8:07 pm
No power at lower Power Outlets MattKas K1200LT 7 Mar 6th, 2007 10:49 am
Bike power to the trailer for accessories Dezrae Australia, New Zealand, and AsiaPac 2 Oct 25th, 2005 4:43 am
Delayed Power to Headset and Detector Canabarry K1200LT 8 Oct 15th, 2005 9:20 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome