foggy again !!! - BMW Luxury Touring Community
 
LinkBack Thread Tools Display Modes
post #1 of 22 Old Oct 29th, 2007, 9:58 am Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
foggy again !!!

This is my second 2720 and the same problem after 9 months use.
Afetr I roll out of the garage, and the sun hits the unit, the screen gets a large white cloud on it (in it).
After about 45 minutes, the cloud has shrunk and is gone until the next morning when the sun hits it again. Not the "end of the world" but, kind of a PITA. It's out of warranty now and $300 to repair seems like a long way toward a 2820 or Zumo. Anyone else with this problem ? (or, better yet, a solution, like rub with ***)

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
Sponsored Links
Advertisement
 
post #2 of 22 Old Oct 29th, 2007, 10:52 am
Senior Member
 
FredR's Avatar
 
Join Date: Sep 2005
Location: Burlington, CT, USA
Posts: 236
yepp i know the feeling. I am on my third 2720 with the same issue and I am also out of warrantee. The silly thing is fine in the car no matter how long I leave it or maybe the sun does not hit it directly and I cannot see the foggy spot
I am thinking of putting it up on ebay and then picking up a zumo 550 sometime in the future.

Fred Rosenbaum
NF1U
2006 K1200LT Totaled
2005 R1200GS
FredR is offline  
post #3 of 22 Old Oct 29th, 2007, 12:08 pm
Senior Member
 
zaphod's Avatar
 
Join Date: Aug 2003
Location: Little Rock, AR, USA
Posts: 654
Just hope the screen doesnít completely de-laminate. My 2610 started out just fogging like you describe, then the screen starting flaking. It got so bad I had to scrape the remaining protective screen off, and now 80% of the time I canít read the darn thing. I called Garmin but since it was out of warrantee it would be $250 to fix. So what to do, get it fixed for $250, get a referbed 2720 for around $400 and have itís screen go bad sooner or later, get the new Zumo and hope for the best, or look for something else. So far Iím still looking for something else.

Malcolm McGee
Little Rock, AR
'00 K1200LTC Canyon Red
'09 Kawasaki KLR 650
'96 Bunkhouse
IBA #24557
BMWMOA #117769


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zaphod is offline  
 
post #4 of 22 Old Oct 29th, 2007, 12:15 pm
Senior Member
 
pgeller's Avatar
 
Join Date: Feb 2004
Location: Beaverton, Oregon, USA
Posts: 100
Here's a thought; why not open it up, and put in a couple of those little bags of silica gel that come with cameras, etc. They suck up the humidity and might help with your fogging. Also, a small vent in the case might help, although it clearly will no longer be submersible (hint: neither is your bike).

pg
DD

Quote:
Originally Posted by STARFIGHTER
This is my second 2720 and the same problem after 9 months use.
Afetr I roll out of the garage, and the sun hits the unit, the screen gets a large white cloud on it (in it).
pgeller is offline  
post #5 of 22 Old Oct 29th, 2007, 12:25 pm
 
Join Date: Dec 2004
Posts: 1,291
If you are getting the $300 dollar charge from the website, before you do anything else, CALL THEM! My 2620 was replaced twice for the same thing, out of warranty. CALL THE SERVICE CENTER!!
Big_E is offline  
post #6 of 22 Old Oct 29th, 2007, 12:37 pm
Senior Member
 
pgeller's Avatar
 
Join Date: Feb 2004
Location: Beaverton, Oregon, USA
Posts: 100
Oh, good point! I've had excellent service from Garmin when I call and schmooze the support folks. They've never charged me a dime, in or out of warranty. Usually just send a new unit, with gifts.

pg
DD

Quote:
Originally Posted by Big_E
If you are getting the $300 dollar charge from the website, before you do anything else, CALL THEM! My 2620 was replaced twice for the same thing, out of warranty. CALL THE SERVICE CENTER!!
pgeller is offline  
post #7 of 22 Old Oct 29th, 2007, 2:25 pm Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
called the service center......they said "bring it in the house overnight and that should stop it."

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #8 of 22 Old Oct 29th, 2007, 4:24 pm
 
Join Date: Dec 2004
Posts: 1,291
Quote:
Originally Posted by STARFIGHTER
called the service center......they said "bring it in the house overnight and that should stop it."
Call them back, tell them that didn't work.
Big_E is offline  
post #9 of 22 Old Oct 29th, 2007, 4:43 pm
Junior Member
 
bman28's Avatar
 
Join Date: Aug 2005
Location: Tewksbury, MA, USA
Posts: 23
2610 Delaminated

My 2610 delaminated and garmin told me it was ~$275 to repair. Went to Staples and picked up Heavy duty clear packing tape (Like scotch tape). I disassembled the 2610, peeled off the last of the protecting film over the screen and put the tape on tight over just the screen. It has not fogged and worked well for over a year without a problem.

Just completed a 7300 mi cross country with no problems.

-Bob


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
-Bob

'05 Ocean Blue LT
04 Victory (Traded)
bman28 is offline  
post #10 of 22 Old Oct 30th, 2007, 11:02 am Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
Well, I called Garmin back. This time I got a great guy.
He said " it's a problem they're working on and hope to have resolution soon."
said he'd be glad to take it back and send another BUT.....I could expect the same problem to reoccur. I told him that while the hour of foggy screeen was a PITA, my real concern was that delamination or worse would occur..
He then gave me a string of numbers to keep on file and said that he didn't care if it was two years from now, if any problem arose or I was contacted that they'd resolved the problem, he would replace the unit at no cost.
Seems fair to me and I always like honesty.

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #11 of 22 Old Oct 30th, 2007, 12:53 pm
Senior Member
 
zaphod's Avatar
 
Join Date: Aug 2003
Location: Little Rock, AR, USA
Posts: 654
Quote:
Originally Posted by STARFIGHTER
Well, I called Garmin back. This time I got a great guy.
Did you get his name?

Malcolm McGee
Little Rock, AR
'00 K1200LTC Canyon Red
'09 Kawasaki KLR 650
'96 Bunkhouse
IBA #24557
BMWMOA #117769


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
zaphod is offline  
post #12 of 22 Old Oct 30th, 2007, 2:22 pm Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
He gave me his personal extension and a way to identify "our deal."
But, I think the important thing is that garmin intends to stand behind these units and will keep replacing them until they get it resolved.
Like I said it's only for about an hour after the sun hits it then no prob. all day. I even considered paying the difference between the 2720 and 2820 but he said they have the same problem. I wonder if that Zumo does ?

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #13 of 22 Old Oct 30th, 2007, 5:20 pm
Lifetime Supporter
 
bmwhd's Avatar
 
Join Date: Apr 2003
Location: Grapevine, TX, USA
Posts: 2,645
All three of my 2720s (first 2 went belly up for other reasons) have done this and still do. I've just gotten used to it I guess. It is a PITA. My 3rd unit is now starting to act up in a different way (screen acts like someone is touching it and then drops in to calibration mode). I'm not going to get another 2720, that's for sure.

I'm waiting on the Zumo II which I hope will come with Bluetooth 2.0 Stereo music. Until that's offered, I'll limp this one along.

Todd R.
Grapevine, TX USA

'78 R80/7
'06 FJR1300A

"You will now be thrown into the Obamaucracy. In his belly you will find a new definition of pain and suffering as you are slowly taxed to death over the next four years."
bmwhd is offline  
post #14 of 22 Old Oct 30th, 2007, 5:33 pm
Senior Member
 
Heracleitus's Avatar
 
Join Date: May 2007
Location: Wichita Falls, TX, USA
Posts: 184
Garage
same issue

My 2720 does the same thing. For me, at least, it normally isn't that much of an issue. The only time it screws with my vision is if the sun is over my shoulder. I do like the idea of a desiccant, though. I think I'll be putting a packet in just to see how, or if, it works.

Heracleitus

'12 Victory Cross Country Vivian Vader
'07 LT
die Blau Frau SOLD!
MBW-MOA Member #140221
Heracleitus is offline  
post #15 of 22 Old Oct 31st, 2007, 9:18 am Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
If anyone does put in a dessicant, please post results

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #16 of 22 Old Nov 2nd, 2007, 5:10 pm Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
Well, I owe that first tech an apology...
I kept the gPS in the house for a few days and put it on the bike for a ride today and............no fog !!!
I do have a heated garage but just enough to keep the chill off and not nearly the 68 degrees of the house...........
I wrapped some microfibre rags around it in the garage and will see if that make a difference tomorrow.....
(Although as i recall, I did bring it into motel rooms for the night and it still fogged in the morning......but not in for 3 days...)

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #17 of 22 Old Nov 2nd, 2007, 6:04 pm
 
Join Date: Dec 2004
Posts: 1,291
Quote:
Originally Posted by STARFIGHTER
Well, I owe that first tech an apology...
I kept the gPS in the house for a few days and put it on the bike for a ride today and............no fog !!!
I do have a heated garage but just enough to keep the chill off and not nearly the 68 degrees of the house...........
I wrapped some microfibre rags around it in the garage and will see if that make a difference tomorrow.....
(Although as i recall, I did bring it into motel rooms for the night and it still fogged in the morning......but not in for 3 days...)
It'll be back, it's still in there.
Big_E is offline  
post #18 of 22 Old Nov 2nd, 2007, 7:36 pm
Senior Member
 
Heracleitus's Avatar
 
Join Date: May 2007
Location: Wichita Falls, TX, USA
Posts: 184
Garage
I got a desiccant silica pack today. I've just not had time to tear open the GPS yet. I should have time tomorrow and I'll update the situation.

Heracleitus

'12 Victory Cross Country Vivian Vader
'07 LT
die Blau Frau SOLD!
MBW-MOA Member #140221
Heracleitus is offline  
post #19 of 22 Old Nov 4th, 2007, 9:05 am Thread Starter
Lifetime Supporter
 
STARFIGHTER's Avatar
 
Join Date: May 2005
Location: Hot Springs Village, AR, USA
Posts: 1,561
I opened the remote to consider drilling holes for a lanyard for Karen......
I think your going to find the same thing I did.............no room.

Allan..Illinois, Oregon, Arkansas, and tomorrow the Universe
2003 K1200LT trike - Starfighter
2004 R1150RTP - Combat Touring
IBA #38152
BMW-MOA 97667
Patriot Guard Riders
...and man of leisure


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
STARFIGHTER is offline  
post #20 of 22 Old Dec 19th, 2007, 11:36 pm
Senior Member
 
hdfan's Avatar
 
Join Date: Oct 2006
Location: Bellevue, WA, USA
Posts: 286
Maybe I am too late... About a year ago I had the same problem with my 2730 after a month or so. Called Garmin, they said that this was a common problem and because I live in the North Wet, this would continue to be a problem. They shipped me a new 2820 instead. No problems.
hdfan is offline  
post #21 of 22 Old Dec 25th, 2007, 9:50 pm
Senior Member
 
dmatson's Avatar
 
Join Date: Dec 2004
Location: Torrance, CA, USA
Posts: 1,680
I have been through 3 2610's because of this and Garmin has always just sent me a rebuilt one (like new). The one I have now is just starting to do it again so I am goin to call again. I have asked about upgrading and they said they don't do that, but they have it sounds like. My 2730 stays in the car and the 2820 is on the LT (2610 stays on the 950). I have never have had a problem with them, only the 2610.

05' LT Dark Grey, "Battle Star"
14' KTM 1190
03' KTM 450 EXC Dually
72' Honda SL 100
67' Triumph Bonneville
65' Honda CB160
70' Honda CB350
dmatson is offline  
post #22 of 22 Old Dec 28th, 2007, 7:27 am
Senior Member
 
Offwego's Avatar
 
Join Date: Feb 2004
Location: Palmetto Bay (Miami), FL, USA
Posts: 401
2720 sucks!

My first 2720 fogged in 3 months. I sent it back, paid the shipping and they replaced it with a refurbished one that had a dark display and fuzzy picture. I called and sent it back and they sent me a new one with all the stuff that comes in a new box. So far it's ok, but, I've been home for th holidays and will ride again soon. I'm interested if anyone else gets to upgrade, as they told me I couldn't pay up as I was still under warantee.

Craig

2000 K1200LTC "Little Turd"
2001 Harley Softail Deuce "Ground Pounder"
BMWMOA #113448
Offwego is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Foggy radio display screen robasay K1200LT 24 Jul 16th, 2012 9:52 pm
Feedback on trying to clean 'foggy / hazy' widscreen Geoffrey K1200LT 7 Nov 24th, 2007 6:56 am
foggy windshield yatts K1200LT 16 Jun 21st, 2007 10:49 am
Radio readout is getting foggy davek1 K1200LT 5 May 22nd, 2006 6:38 pm
Cleaning a 'foggy windscreen' Geoffrey K1200LT 14 Nov 2nd, 2005 11:53 pm

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome