Nav VI Screen Issues - BMW Luxury Touring Community
 3Likes
  • 2 Post By timothya1
  • 1 Post By PMitchell
 
LinkBack Thread Tools Display Modes
post #1 of 6 Old Feb 18th, 2020, 3:50 pm Thread Starter
Member
 
timothya1's Avatar
 
Join Date: May 2010
Location: Silverdale, WA, USA
Posts: 61
Garage
Nav VI Screen Issues

This isn't new to some of you, but it was to me. I thought maybe there could be some other person, like me, who wasn't aware of the screen issues associated with the Nav VI.

I've had my Nav VI for about 30 months. It recently started to act possessed - screen would change randomly and without user input, wouldn't accept input reliably and would change brightness abruptly with no real change in ambient light. If I already had a route active, it would continue to navigate, but I couldn't view the map long enough for it to be really useful. I tried all the usual remedies - cleaned contacts, cleaned the screen and eventually did a master reset - all without success. The issue happened while mounted in the cradle and while trying to use it off the bike.

A friend suggested I call Garmin because he believed it is a Nav VI issue and knew that Garmin had replaced the unit for other customers.

I was on the phone with Garmin for about 2 minutes (including hold time). They are going to replace the entire unit (not just the screen). I will be shipping my old unit and they will return a new one. My only cost will be the cost of shipping the old unit to them.
meese and scottydawg like this.

Timothy Allen
2017 R1200RT
timothya1 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old Feb 18th, 2020, 5:01 pm
Lifetime Supporter
 
PMitchell's Avatar
 
Join Date: Aug 2006
Location: Hudson, OH, USA
Posts: 2,922
Re: Nav VI Screen Issues

Same issues here.
Great Customer Service.

I have a new NAV VI and where I couldn't access gpx files from the additional storage chip, now I can.

pm
--
Life is too short to do anything
other than that about which you
are absolutely passionate . . .
Ride till you can't!

"Der Weg ist das Ziel"
2005 Pyrenees of France & Spain
2006 Tuscany
2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 South Africa
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2014 The Dolomites of Italy, Alps of Switzerland & Austria and returning to Milan via the "Gold Coast" of the French Riveria.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2016 Northern & Central Spain & Portugal
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 Central & Eastern Europe: Slovenia, Austria, Poland,Hungary, Czech Republic & Slovakia!

2019 Maritime Provinces of Canada & New England 3,500 miles

'18 R1200RTW
'00 K1200LTC (Dealer is taking on consignment!)
'90 K75-Sold to a new BMW owner (2016)
'62 R 50/2 (Rode hard and put away wet)-Sold in '81
'63 Vespa 150 (1st and only dirt bike!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sold in '67



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PMitchell is offline  
post #3 of 6 Old Feb 20th, 2020, 2:34 pm
Member
 
Join Date: Jul 2017
Posts: 43
Re: Nav VI Screen Issues

Make sure you remove the battery, cover and send just the unit only

Sent from my SM-N960U1 using Tapatalk
nhonnguyen61 is offline  
 
post #4 of 6 Old Feb 21st, 2020, 3:36 pm
Lifetime Supporter
 
PMitchell's Avatar
 
Join Date: Aug 2006
Location: Hudson, OH, USA
Posts: 2,922
Re: Nav VI Screen Issues

Quote:
Originally Posted by nhonnguyen61 View Post
Make sure you remove the battery, cover and send just the unit only

Sent from my SM-N960U1 using Tapatalk
Hmmm, I was told to just remove the battery.
nhonnguyen61 likes this.

pm
--
Life is too short to do anything
other than that about which you
are absolutely passionate . . .
Ride till you can't!

"Der Weg ist das Ziel"
2005 Pyrenees of France & Spain
2006 Tuscany
2008
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

2011 South Africa
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2014 The Dolomites of Italy, Alps of Switzerland & Austria and returning to Milan via the "Gold Coast" of the French Riveria.
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2016 Northern & Central Spain & Portugal
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


2018 Central & Eastern Europe: Slovenia, Austria, Poland,Hungary, Czech Republic & Slovakia!

2019 Maritime Provinces of Canada & New England 3,500 miles

'18 R1200RTW
'00 K1200LTC (Dealer is taking on consignment!)
'90 K75-Sold to a new BMW owner (2016)
'62 R 50/2 (Rode hard and put away wet)-Sold in '81
'63 Vespa 150 (1st and only dirt bike!)
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Sold in '67



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
PMitchell is offline  
post #5 of 6 Old Feb 21st, 2020, 8:08 pm
Member
 
Join Date: Jul 2017
Posts: 43
Re: Nav VI Screen Issues

Quote:
Originally Posted by PMitchell View Post
Hmmm, I was told to just remove the battery.
That is fine too, the replacement unit comes with a new battery. Then it will break down again in 2 years again, I am don with NAV VI, may be going back to V

Sent from my SM-N960U1 using Tapatalk
nhonnguyen61 is offline  
post #6 of 6 Old Feb 21st, 2020, 11:17 pm Thread Starter
Member
 
timothya1's Avatar
 
Join Date: May 2010
Location: Silverdale, WA, USA
Posts: 61
Garage
Re: Nav VI Screen Issues

Quote:
Originally Posted by PMitchell View Post
Hmmm, I was told to just remove the battery.
Hmmm, I wasn't told to do anything with the battery.

Timothy Allen
2017 R1200RT
timothya1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the BMW Luxury Touring Community forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome